2 bolangchanxin bolangchanxin 于 2017.11.11 14:54 提问

使用idea社区版构建maven项目,访问异常 5C

各位大神:我在使用idea练习maven项目时,访问时后端报了类型转换异常,在网上查了一下,说是配置的servlet-api与tomcat自带的版本冲突,需要将pom.xml中的依赖包配置scope=provided,但是配置后仍然这样!哪位大神能帮解答一下,谢谢!
图片说明
图片说明
图片说明
以下是tomcat的插件
图片说明
图片说明
图片说明

2个回答

gjx3650
gjx3650   2017.11.11 21:41

可以把相关代码贴出来么?还有tomcat 的版本信息。

gjx3650
gjx3650   2017.11.11 21:43

可以先把servlet-api 的依赖版本降到3.0。查看一下代码中所导入的servlet包是否和tomcat中的lib中jar包不一致。

bolangchanxin
bolangchanxin 回复搏浪禅心: 哈哈,解决了,是JDK-jre\lib\ext里面的包冲突了,把这个里面同名字的包删掉就好了
10 天之前 回复
bolangchanxin
bolangchanxin tomcat是用的maven插件,把servlet-api降到3.0后,代码就出现编译问题,应该是这个版本缺少一些新特性。
10 天之前 回复
Csdn user default icon
上传中...
上传图片
插入图片