TBACAMILLE 2018-01-20 12:43 采纳率: 50%
浏览 1196
已采纳

杭电OJ1005 不明白错误在哪

Number Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 187350 Accepted Submission(s): 46661

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0

Sample Output
2
5

Author
CHEN, Shunbao

Source
ZJCPC2004

代码如下:
import java.util.*;

public class Main{
private static Scanner in;

public static void main(String[] args) {

in = new Scanner(System.in);
while(in.hasNext())
{
int A = in.nextInt();
int B = in.nextInt();
int n = in.nextInt();
int []a = new int[n+2];
a[1] = 1;
a[2] = 1;
if(n==1||n==2) {
System.out.println(1);;
}
if(A==0&&B==0&&n==0) {
continue;
}
if(A1000&n>1000000000) {
System.exit(0);
}
else if(A>=1&&B<=1000&&n>=3&&n<=1000000000)
{
for(int t = 3;t<=n;t++)
{
a[t] = ((A*a[t-1])+(B*a[t-2]))%7;
if(t==n) {
System.out.println(a[t]);
}
}
}
}
}
}

我输入0 0 0时eclipse显示错误;不明白怎么改,求大神帮忙

  • 写回答

3条回答 默认 最新

  • 坎特 2018-01-20 12:50
    关注

    把对0 0 0的判断拉到前面
    if(A==0&&B==0&&n==0) {
    continue;
    }
    放在循环体开头
    错在数组下标越界吧,n=0的时候,数组只有a[0],a[1]才对
    int []a = new int[n+2];
    a[1] = 1;
    a[2] = 1;

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(2条)

报告相同问题?

悬赏问题

  • ¥15 素材场景中光线烘焙后灯光失效
  • ¥15 请教一下各位,为什么我这个没有实现模拟点击
  • ¥15 执行 virtuoso 命令后,界面没有,cadence 启动不起来
  • ¥50 comfyui下连接animatediff节点生成视频质量非常差的原因
  • ¥20 有关区间dp的问题求解
  • ¥15 多电路系统共用电源的串扰问题
  • ¥15 slam rangenet++配置
  • ¥15 有没有研究水声通信方面的帮我改俩matlab代码
  • ¥15 ubuntu子系统密码忘记
  • ¥15 保护模式-系统加载-段寄存器