2 taowong taowong 于 2014.05.09 22:13 提问

LSM在linux内核版本2.6.22之后如何注册安全模块

在2.6.22之前我们可以通过register_security(ops)注册安全模块,加载成功后就可以进行访问控制,而在版本较高的内核中,例如我用的3.4.70 调用register_security(ops)是不能成功的,而unregister_security()函数在security.c中是不存在的,请问这种情况下,如何注册安全模块以及如何撤销该模块?
最后还想问Linux内核这样改的原因是什么?
求高手讲解下,多谢

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!