排行榜

  • 用户榜
  • 标签榜
  • 冲榜分奖金

频道

最新最热悬赏待采纳 筛选
  • 0

    回答

  • 13

    浏览

做了一个简单的UDP服务器,其中有一部分:套接字1接收到addr1发来的数据,用套接字2发送信息到addr1,现在的问题是addr1处收不到信息 s1 = socket.socket(socket.AF_INET, socket.SOCK_DRGAM) s2 = socket.socket(socket.AF_INET, socket.SOCK_DRGAM) s1.bind("0.0.0.0", 12345) # s1接收 data, addr = s1.recvfrom(1024) # s2发送到addr s2.sendto(b'OK', addr) 如果是同一个套接字可以正常收发(如下) s = socket.socket(socket.AF_INET, socket.SOCK_DRGAM) s.bind("0.0.0.0", 12345) data, addr = s.recvfrom(1024) s.sendto(b'OK', addr) 为什么上面的就不行呢?

  • 4

    回答

  • 20

    浏览

  • 4

    回答

  • 22

    浏览

项目中的corenlp需要使用Java,Java是放在系统默认的可执行目录里,chmod已经改过权限了,当前用户也是rwx,并且Linux里执行java -version也是生效的,应该不是Java本身的问题。但程序报错PermissionError: [Errno 13] Permission denied: 'java'请问这种远程使用被拒绝是什么原因导致的,怎么解决?

  • 1

    回答

  • 8

    浏览

在ubuntu16.4服务器运行 .py 文件 按下回车后光标移至下一行,没有任何报错与输出 ctrl+Z退出后重复进行运行,大概20次总有一次会运行成功 想问一问是什么问题

  • 1

    回答

  • 10

    浏览

程序功能:用python编写socket广播接收程序,使用了多线程技术接收数据,并将接收到的数据放入队列中,消费者进程判断队列中接收的数据是否满足筛选条件,若满足则将筛选出的数据写入文件中。 出现的问题:程序运行大概3、4天后,out of memory被killed掉,不知道问题出在了哪里。如果需要找出问题,应该从哪几方面debug呢?  

山那边的狗崽子
采纳率75%
6天前
  • 3

    回答

  • 30

    浏览

Ubuntu中使用wine运行了直接从windows系统中拉过来的的IDA7.0。Ubuntu中已经安装python2.7.17(也安装了python3.8)。可直接python启动。 已经将https://github.com/devttys0/ida.git目录下的ida下载到本地,并且ida下的plugins下的.py文件已经全部复制到windows移植的IDA根目录,script也已经复制IDA的根目录,但是plugins依然不能用            

  • 1

    回答

  • 5

    浏览

  • 5

    回答

  • 32

    浏览

ubuntu18.04,cuda11.0,显卡驱动460.73.01 电脑在不运行pycharm的情况下,非常流畅,非常丝滑,但是一旦run起来(只是打开Pycharm,不运行也没问题),电脑马上变得非常卡顿,点击个文件夹半天才“慢慢地”出现,关闭窗口也是“慢慢地”消失,和PPT一样…… 尝试过重装显卡驱动(4次,每次不一样),固定Linux内核,卸载搜狗浏览器,重装Commuinity版本的Pycharm,全部都不起作用…… 该如何解决呢?

  • 2

    回答

  • 24

    浏览

在linux 上如何用python 删除文件夹(文件夹里面有文件和子文件夹),有没有一个语句就可以实现的。

回答 一支向阳花
采纳率66.7%
11天前
  • 2

    回答

  • 19

    浏览

本地判断文件是否存在是: if os.path.exists(gaussTrFor) :                     os.remove(os.path.join(gaussTrFor))  判断远程服务器中指定目录下的文件是否存在该怎么写: 是   if sftp_client.这后面应该写哪个方法来做判断?            sftp_client.remove(odsTrFor)             

回答 一支向阳花
采纳率66.7%
11天前
  • 4

    回答

  • 20

    浏览

Centos 环境下编译安装 GDAL,其中一步需要安装 PROJ,但是在编译安装 PROJ 过程中,在PROJ 源码目录下,执行命令:“./configure --prefix=/usr/local/PROJ7”,其中 /usr/local/PROJ7 目录自己已经创建好了 出现 Requested 'sqlite3 >= 3.11' but version of SQLite is 3.7.17 问题。 如图: 其中,环境中已经编译安装好了 sqlite3 ,如图:   安装的和 sqlite 相关的有:   并且 Yum 仓库里也只有这个版本的 所以,编译安装 PROJ 的时候那个 “Requested 'sqlite3 >= 3.11' but version of SQLite is 3.7.17 ” 错误该怎么处理。

  • 4

    回答

  • 26

    浏览

这个为什么我已经更新到了21.0.1还要我更新pip?

  • 0

    回答

  • 15

    浏览

比如说我再C++中声明了一个QWidget类并且实例化,在pyQt中如何获取这个QWidget类实例化后的对象?

  • 3

    回答

  • 20

    浏览

有一个需求就是用户在网站或App上写一段内容,提交到数据库,定时通过邮箱发送信件给客户,这个时间要求精确到分钟,请问如何实现。技术栈要求在php和python。目前有一种思路就是通过linux自带的corntab。想问一下还有什么比较省内存的实现方法吗

  • 2

    回答

  • 23

    浏览

请问在树莓派(安装的是Linux)上可以使用fastapi吗?如果不可以,那在树莓派上可以使用什么来管理python的接口呢

  • 3

    回答

  • 30

    浏览

TeamViewer最新版只能登录才能使用,登录后就提示这个要去除限制,点击后登录上一直找不到去除限制的地方 按下图提示点击去除限制,登录我的账号后,一直找不到去除限制的地方,大神们试下?求解 找了好久都找不到.....