dqx76962
dqx76962
2012-12-11 17:12
浏览 136
已采纳

未定义的函数mysql_connect()

I have ran aptitude install php5-mysql (and restarted MySQL/Apache 2), but I am still getting this error:

Fatal error: Call to undefined function mysql_connect() in /home/validate.php on line 21

phpinfo() says the /etc/php5/apache2/conf.d/pdo_mysql.ini file has been parsed.

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

13条回答 默认 最新

  • dongzhentiao2326
    dongzhentiao2326 2012-12-11 17:13
    已采纳

    Well, this is your chance! It looks like PDO is ready; use that instead.

    Try checking to see if the PHP MySQL extension module is being loaded:

    <?php
        phpinfo();
    ?>
    

    If it's not there, add the following to the php.ini file:

    extension=php_mysql.dll
    
    点赞 评论
  • dongyi0114
    dongyi0114 2012-12-11 17:31

    I see that you tagged this with Ubuntu. Most likely the MySQL driver (and possibly MySQL) is not installed. Assuming you have SSH or terminal access and sudo permissions, log into the server and run this:

    sudo apt-get install mysql-server mysql-client php5-mysql
    

    If the MySQL packages or the php5-mysql package are already installed, this will update them.


    UPDATE

    Since this answer still gets the occasional click I am going to update it to include PHP 7. PHP 7 requires a different package for MySQL so you will want to use a different argument for the apt-get command.

    sudo apt-get install mysql-server mysql-common php7.0 php7.0-mysql
    

    And importantly, mysql_connect() has been deprecated since PHP v5.5.0. Refer the official documentation here: PHP: mysql_connect()

    点赞 评论
  • douhu2890
    douhu2890 2012-12-11 17:39

    Try:

    <?php
      phpinfo();
    ?>
    

    Run the page and search for mysql. If not found, run the following in the shell and restart the Apache server:

    sudo apt-get install mysql-server mysql-client php5-mysql
    

    Also make sure you have all the following lines uncommented somewhere in your apache2.conf (or in your conf.d/php.ini) file, from

    ;extension=php_mysql.so
    

    to

    extension=php_mysql.so
    
    点赞 评论
  • dongsi4547
    dongsi4547 2012-12-11 17:40

    My guess is your PHP installation wasn't compiled with MySQL support.

    Check your configure command (php -i | grep mysql). You should see something like '--with-mysql=shared,/usr'.

    You can check for complete instructions at http://php.net/manual/en/mysql.installation.php. Although, I would rather go with the solution proposed by @wanovak.

    Still, I think you need MySQL support in order to use PDO.

    点赞 评论
  • donglun2024
    donglun2024 2015-07-11 18:10

    There must be some syntax error. Copy/paste this code and see if it works:

    <?php
        $link = mysql_connect('localhost', 'root', '');
        if (!$link) {
            die('Could not connect:' . mysql_error());
        }
        echo 'Connected successfully';
        ?
    

    I had the same error message. It turns out I was using the msql_connect() function instead of mysql_connect().

    点赞 评论
  • doupi6737
    doupi6737 2016-04-24 14:29

    (Windows mysql config)

    Step 1 : Go To Apache Control Panel > Apache > Config > PHP.ini

    Step 2 : Search in Notepad (Ctrl+F) For: ;extension_dir = "" (could be commented with a ;). Replace this line with: extension_dir = "C:\php\ext" (please do not you need to remove the ; on the beginning of the sentence).

    Step 3 : Search For: extension=php_mysql.dll and remove the ; in the beginning.

    Step 4 : Save and Restart You Apache HTTP Server. (On Windows this usually done via a UI)

    That's it :)

    If you get errors about missing php_mysql.dll you'll probably need to download this file from either the php.net site or the pecl.php.net. (Please be causius about where you get it from)

    More info on PHP: Installation of extensions on Windows - Manual

    点赞 评论
  • douren5898
    douren5898 2016-05-04 08:19

    If you are getting the error as

    Fatal error: Call to undefined function mysql_connect()

    Kindly login to the cPanel >> Click on Select Php version >> select the extension MYSQL

    点赞 评论
  • douyue1481
    douyue1481 2016-06-17 09:15

    In case, you are using PHP7 already, the formerly deprecated functions mysql_* were removed entirely, so you should update your code using the PDO-functions or mysqli_* functions instead.

    If that's not possible, as a workaround, I created a small PHP include file, that recreates the old mysql_* functions with mysqli_*()-functions: fix_mysql.inc.php

    点赞 评论
  • dongyingjiu0669
    dongyingjiu0669 2016-08-04 03:07

    If someone came here with the problem of docker php official images, type below command inside the docker container.

    $ docker-php-ext-install mysql mysqli pdo pdo_mysql
    

    For more information, please refer to the link above How to install more PHP extensions section(But it's a bit difficult for me...).

    Or this doc may help you.

    https://docs.docker.com/samples/library/php/

    点赞 评论
  • dongweiben5229
    dongweiben5229 2016-09-20 13:18

    In php.ini file

    change this

    ;extension=php_mysql.dll
    

    into

    extension=php_mysql.dll
    
    点赞 评论
  • dougan1330
    dougan1330 2016-12-09 16:48

    The question is tagged with ubuntu, but the solution of un-commenting the extension=mysqli.dll is specific to windows. I am confused here?!, anyways, first thing run <? php phpinfo ?> and search for mysql* under Configuration heading. If you don't see such a thing implies you have not installed or enabled php-mysql. So first install php-mysql

    sudo apt get install php-mysql

    This command will install php-mysql depending on the php you have already installed, so no worries about the version!!.

    Then comes the unix specific solution, in the php.ini file un-comment the line

    extension=msql.so
    

    verify that msql.so is present in /usr/lib/php/<timestamp_folder>, ELSE

    extension=path/to/msql.so
    

    Then finally restart the apache and mysql services, and you should now see the mysql section under Configrations heading in phpinfo page

    点赞 评论
  • dongshi1966
    dongshi1966 2017-08-09 19:16

    I was getting this error because the project I was working on was developed on php 5.6 and after install, the project was unable to run on php7.1.

    Just for anyone that uses Vagrant with ubuntu/nginx, in the nginx directory(/etc/nginx/), there is a directory named "sites-available" which contains a file named like the url configured for the vagrant maschine. In my case was homestead.app. Within this file there is a line that says something like

        fastcgi_pass unix:/var/run/php/php7.1-fpm.sock;
    

    There you can change the php version to the desired for that particular site.

    Googled this but wasnt really able to find a simple answer that said where to look and what to change.

    Hope that this helps anyone. Thanks.

    点赞 评论
  • duanli5662
    duanli5662 2017-08-12 11:26

    I was also stuck with the same problem of undefined MySQL_connect().I tried to make changes in PHP.ini file but it was giving me the same error. Then I came to this solution where I changed my code from depreciated php functions to new functions.

    $con=mysqli_connect($host,$user,$password);
    
    mysqli_select_db($con,dbname); 
    //To select the database
    
    session_start(); //To start the session
    
    $query=mysqli_query($con,your query); 
    //made query after establishing connection with database.
    

    I hope this will help you . This solution is correctly working for me .

    EDIT:

    If you upgrade form old php you need to apt-get install php7.0-mysql

    点赞 评论

相关推荐