dongsanhu4784 2017-08-31 04:31
浏览 120
已采纳

Slackware 14.2中的runc安装错误

I'm trying to install Docker in Slackware 14.2 via SBoTools, but I got an error message of runc installation.

undefined reference to `seccomp_rule_add_exact_array' collect2: error: ld returned 1 exit status

make: *** [all] Error 2

Makefile:30: recipe for target 'all' failed

Failures: runc: runc.SlackBuild return non-zero

I tried to build runc from source, but got the same error. I'm not an specialist with go-lang and don't know if the problem is with it.

Thanks,


More details:

The problem happens when in the installation when it gives that command:

go build -i -ldflags "-X main.gitCommit=54296cf40ad8143b62dbcaa1d90e520a2136ddfe -X main.version=1.0.0-rc2" -tags "seccomp" -o runc .

Edit #2 - Problem solved.

Alright, the problem was in Makefile of runc package from slackbuilds. There is two lines where the command "go build" will be used and in both there is an flag called "-ldflags"... To solve the problem, just update this flag with "-gccgoflags" and that sould work. Obs: If you're trying to install Docker, you'll have this problem with containerd too.

Hope this can help someone and I'll report this for the mainteiner of the package in Slackbuilds :)

  • 写回答

3条回答 默认 最新

  • douchen2011 2017-09-05 17:00
    关注

    You did not have your PATH variable correctly set when building. The go executable is being picked up from /usr/bin; that executable corresponds to gccgo, not to the one in the google-golang package, which is the one to be used.

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(2条)

报告相同问题?

悬赏问题

  • ¥15 为什么apriori的运行时间会比fp growth的运行时间短呢
  • ¥15 帮我解决一下膳食平衡的线性规划模型的数据实例
  • ¥40 万年历缺少农历,需要和阳历同时显示
  • ¥250 雷电模拟器内存穿透、寻基址和特征码的教学
  • ¥200 比特币ord程序wallet_constructor.rs文件支持一次性铸造1000个代币,并将它们分配到40个UTXO上(每个UTXO上分配25个代币),并设置找零地址
  • ¥15 关于Java的学习问题
  • ¥15 如何使用chatgpt完成文本分类任务?
  • ¥15 已知速度v关于位置s的等式,怎么转化为已知位置求速度v的等式
  • ¥15 我有个餐饮系统,用wampserver把环境配置好了,但是后端的网页却进去,是为什么,能不能帮远程一下?
  • ¥15 R运行没有名称为"species"的插槽对于此对象类"SDMmodelCV"