dongwen5870 2017-10-23 11:03
浏览 1159
已采纳

从Github位置获取go软件包时,克隆git存储库时退出状态128

I want to configure the GoLang GB compiler for the projects in my local. based on the documentation given in the url I am trying to get the gb compiler using the command enter image description here

its returning status code 128. I am unable to understand whats happening here as there is no reference to resolve this issue.

adding GIT_CURL_VERBOSE=1 or 2 is not helping as its not giving any other valuable details as output.

$ GIT_CURL_VERBOSE=1 go get -u -v github.com/constabulary/gb/...
$ github.com/constabulary/gb (download)
$ # cd .; git clone https://github.com/constabulary/gb 
  C:\work\GitHub\GoLib\src\github.com\constabulary\gb
  Cloning into 'C:\work\GitHub\GoLib\src\github.com\constabulary\gb'...
  package github.com/constabulary/gb/...: exit status 128

Still getting the avove output

below is the output when not using -u

$ GIT_TRACE=2 go get -v github.com/constabulary/gb/...
github.com/constabulary/gb (download)
# cd .; git clone https://github.com/constabulary/gb 
C:\work\GitHub\GoLib\src\github.com\constabulary\gb
17:20:25.818538 git.c:328               trace: built-in: git 'clone' 
'https://github.com/constabulary/gb' 'C:\work\GitHub\GoLib\                                                
src\github.com\constabulary\gb'
17:20:25.867542 run-command.c:626       trace: run_command: 'remote-https' 
'origin' 'https://github.com/constabulary/gb'
Cloning into 'C:\work\GitHub\GoLib\src\github.com\constabulary\gb'...
17:20:25.970553 git.c:560               trace: exec: 'git-remote-https' 
'origin' 'https://github.com/constabulary/gb'
17:20:25.970553 run-command.c:626       trace: run_command: 'git-remote-
https' 'origin' 'https://github.com/constabulary/gb'
package github.com/constabulary/gb/...: exit status 128
  • 写回答

1条回答 默认 最新

  • dongmeng1868 2017-10-27 06:23
    关注

    I tried to resolve the issue for a couple of days. In My configuration I was on organizational GitHub and the codelibrary I was trying to get was from github.com. So I thought that might be causing the issue. But that was not true.

    I suspected that there is somethisng wrong with the git configuration. as even Organizational github account was not accessible. I tried a lot of solutions from multiple threads.. nothing worked.

    Then I ultimately uninstalled GitHub and tortoise git from My machine and installed it again. and did the complete git configuration setup on my machine from scratch.

    It Worked.

    What caused that issue in first place was identified when I went to uninstall git. Instalation date was the date when the issue started. So i suspect that there was some faulty update installed for git unknowingly and that caused this issue.

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

悬赏问题

  • ¥15 爬取豆瓣电影相关处理
  • ¥15 手机淘宝抓清除消息接口
  • ¥15 C#无selenium
  • ¥15 LD衰减计算的结果过大
  • ¥15 用机器学习方法帮助保险公司预测哪些是欺诈行为
  • ¥15 计算300m以内的LD衰减
  • ¥15 数据爬取,python
  • ¥15 怎么看 cst中一个面的功率分布图,请说明详细步骤。类似下图
  • ¥15 为什么我的pycharm无法用pyqt6的QtWebEngine
  • ¥15 FOR循环语句显示查询超过300S错误怎么办