qq_15379219
奋斗的金鱼
2015-01-01 15:07
采纳率: 100%
浏览 5.7k
已采纳

使用wampsever时localhost打不开而127.0.0.1可以正常访问,怎么解决?

T^T试了所有的方法,改过apache中conf文件的端口没用又改回了80,而且IIS在进程中没有开启,且关闭了在控制面板-添加删除程序-添加windows组件中的Internet服务。localhost还是会显示IIS的图,实在不知道怎么好了,打开127.0.0.1的时候是可以正常访问的。下面的是图片,刚开始学web技术,还请各位多多指教!~T^T好急的!!
windowd里面hosts文件配置应该是正确的ping localhost和127.0.0.1的时候地址都相同127.0.0.1的显示界面localhost的显示界面
!
后续:
图片说明
刚才测试了一下80端口,发现是apache中的mod_fcgid占用了80端口,求问各位怎么修改呢?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

12条回答 默认 最新

  • fdipzone
    傲雪星枫 2015-01-03 02:40
    已采纳

    ping localhost 看看是否127.0.0.1
    如果不是,需要在系统盘找到 windows/system32/drivers/etc/hosts文件。
    在文件内加入
    127.0.0.1 localhost

    然后ping一下是否正常,否则再重启一下。

    点赞 评论
  • caozhy

    到底是apache还是iis?如果是IE,有没有绑定正确的host(主机头)

    点赞 评论
  • qq_15379219
    奋斗的金鱼 2015-01-01 15:11

    是apache
    用的wampsever中的配置环境php+apache+mysql

    点赞 评论
  • u010730965
    小小小小菜 2015-01-01 15:39

    同问!!!求帮助啊!!!

    点赞 评论
  • oyljerry
    oyljerry 2015-01-01 16:23

    DNS Client服务重启一下

    点赞 评论
  • oyljerry
    oyljerry 2015-01-01 16:24

    看上去是host失效了,系统重启等方式刷新一下

    点赞 评论
  • caozhy

    试试看按照这篇文章的介绍绑定下主机头

    http://luwenxiang1990.blog.163.com/blog/static/173607639201182505818593/

    点赞 评论
  • eagleyan
    Coursera 2015-01-01 17:39

    你的浏览器上不是写了“域名重定向”么,那是http code301.你可以检查一下你的.htaccess文件,是不是对你的网站进行了重定向。

    点赞 评论
  • u010793236
    xc_torres 2015-01-02 00:13

    你可以再http-conf里面把80的端口换成别的比如8082,然后在服务器地址为127.0.0:8082就可以啦~有一些杀毒软件和其他聊天的有可能占用这个端口号

    点赞 评论
  • xuzuning
    xuzuning 2015-01-03 08:47

    你最后一个截图显示:http://localhost 进入了 IIS 管理的网站
    其实既然有了 IIS 又何必再用 Apache 呢?

    点赞 评论
  • gejiedb
    gejiedb 2015-01-04 05:04

    这要关闭iis,应该就可以了吧

    点赞 评论
  • fdipzone
    傲雪星枫 2015-01-04 14:32

    用apache就不要用iis,80端口冲突的。

    点赞 评论

相关推荐