tomcatJDK1.6在部署项目的时候为何说版本过低?

项目本来是用jdk1.6来编译的,但是从svn检出我电脑上的时候,用自带的jdk却不能部署了,说Unsupported major.minor version 51.0 不支持的主要小版本51.0,我以为是自带的不行,就重新下载了JDK1.6,想不到还是报一样的错误,我用JDK1.7却可以运行,但是我们的项目是用1.6,经理在弄class文件的时候整合不了,我该怎么办呢,
startup Host Config deploy Directory
Error deploying web application directory mgr
java lang Unsupported Class Version Error
启动主机配置部署目录中
经理错误部署web应用程序目录
java朗不支持的类版本错误
这是几个报错的提示,翻译过来的 ,现在项目紧,大家帮帮小生。感激不尽

4个回答

如果是用MyEclipse的话可以设置tomcat使用的jdk版本

从新设置默认版本的jdk

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问