用npm安装package.json时出现错误

我是在win8 64bit上面操作,本来安装的nodejs是64位的,

npm install时一直出现错误,上网查后有说要安装32位的,而且需要安装vs,

于是我卸载64的node又安装32的node,又安装vs2012,

然后又npm install

出现如下异常:

 npm WARN optional dep failed, continuing fsevents@0.3.8
\


> spawn-sync@1.0.13 postinstall E:\project2\shijuan\node_modules\node-sass\node_modules\sas
modules\spawn-sync
> node postinstall

\


> node-sass@3.2.0 install E:\project2\shijuan\node_modules\node-sass
> node scripts/install.js

Binary downloaded and installed at E:\project2\shijuan\node_modules\node-sass\vendor\win32-



> node-sass@3.2.0 postinstall E:\project2\shijuan\node_modules\node-sass
> node scripts/build.js

` E:\project2\shijuan\node_modules\node-sass\vendor\win32-ia32-14\binding.node ` exists.
 testing binary.
Binary is fine; exiting.
\


> bufferutil@1.1.0 install E:\project2\shijuan\node_modules\webpack-dev-server\node_modules
> node-gyp rebuild

|
(venv) Think@RESEARCH E:\project2\shijuan\node_modules\webpack-dev-server\node_modules\sock
> if not defined npm_config_node_gyp (node "C:\Program Files (x86)\nodejs\node_modules\npm\
e  rebuild )
在此解决方案中一次生成一个项目。若要启用并行生成,请添加“/m”开关。
  bufferutil.cc
     正在创建库 E:\project2\shijuan\node_modules\webpack-dev-server\node_modules\socket.io\
util
  .expb 和对象 E:\project2\shijuan\node_modules\webpack-dev-server\node_modules\socket.io\n
  正在生成代码
  已完成代码的生成
  bufferutil.vcxproj -> E:\project2\shijuan\node_modules\webpack-dev-server\node_modules\so
  se\\bufferutil.node
|


> utf-8-validate@1.1.0 install E:\project2\shijuan\node_modules\webpack-dev-server\node_mod
f-8-validate
> node-gyp rebuild

/
(venv) Think@RESEARCH E:\project2\shijuan\node_modules\webpack-dev-server\node_modules\sock
ate
> if not defined npm_config_node_gyp (node "C:\Program Files (x86)\nodejs\node_modules\npm\
e  rebuild )
在此解决方案中一次生成一个项目。若要启用并行生成,请添加“/m”开关。
  validation.cc
     正在创建库 E:\project2\shijuan\node_modules\webpack-dev-server\node_modules\socket.io-
ild\
  Release\validation.lib 和对象 E:\project2\shijuan\node_modules\webpack-dev-server\node_mo
tf
  -8-validate\build\Release\validation.exp
  正在生成代码
  已完成代码的生成
  validation.vcxproj -> E:\project2\shijuan\node_modules\webpack-dev-server\node_modules\so
  lidate\build\Release\\validation.node

> utf-8-validate@1.1.0 install E:\project2\shijuan\node_modules\webpack-dev-server\node_mod
> node-gyp rebuild


(venv) Think@RESEARCH E:\project2\shijuan\node_modules\webpack-dev-server\node_modules\sock
> if not defined npm_config_node_gyp (node "C:\Program Files (x86)\nodejs\node_modules\npm\
e  rebuild )
在此解决方案中一次生成一个项目。若要启用并行生成,请添加“/m”开关。
  validation.cc
     正在创建库 E:\project2\shijuan\node_modules\webpack-dev-server\node_modules\socket.io\
lida
  tion.lib 和对象 E:\project2\shijuan\node_modules\webpack-dev-server\node_modules\socket.i
va
  lidation.exp
  正在生成代码
  已完成代码的生成
  validation.vcxproj -> E:\project2\shijuan\node_modules\webpack-dev-server\node_modules\so
  elease\\validation.node

> bufferutil@1.1.0 install E:\project2\shijuan\node_modules\webpack-dev-server\node_modules
util
> node-gyp rebuild


(venv) Think@RESEARCH E:\project2\shijuan\node_modules\webpack-dev-server\node_modules\sock
> if not defined npm_config_node_gyp (node "C:\Program Files (x86)\nodejs\node_modules\npm\
e  rebuild )
在此解决方案中一次生成一个项目。若要启用并行生成,请添加“/m”开关。
  bufferutil.cc
     正在创建库 E:\project2\shijuan\node_modules\webpack-dev-server\node_modules\socket.io-
Rele
  ase\bufferutil.lib 和对象 E:\project2\shijuan\node_modules\webpack-dev-server\node_module
ru
  til\build\Release\bufferutil.exp
  正在生成代码
  已完成代码的生成
  bufferutil.vcxproj -> E:\project2\shijuan\node_modules\webpack-dev-server\node_modules\so
  il\build\Release\\bufferutil.node
vinyl-named@1.1.0 node_modules\vinyl-named
└── through@2.3.8

manifest-revision-webpack-plugin@0.0.5 node_modules\manifest-revision-webpack-plugin
└── walk@2.3.9 (foreachasync@3.0.0)

coffee-script@1.9.3 node_modules\coffee-script

superagent@1.3.0 node_modules\superagent
├── extend@1.2.1
├── methods@1.0.1
├── cookiejar@2.0.1
├── component-emitter@1.1.2
├── reduce-component@1.0.1
├── mime@1.3.4
├── qs@2.3.3
├── debug@2.2.0 (ms@0.7.1)
├── readable-stream@1.0.27-1 (inherits@2.0.1, isarray@0.0.1, string_decoder@0.10.31, core-u
├── formidable@1.0.14
└── form-data@0.2.0 (async@0.9.2, combined-stream@0.0.7, mime-types@2.0.14)

其实看上去也成功了很多,但是前面那几个异常怎么解决呢?谢谢各位

package.json如下

{
  "repository": {
    "type": "git",
    "url": ""
  },
  "license": "MIT",
  "description": "Project Shijuan",
  "scripts": {
    "start": "node_modules/.bin/webpack-dev-server --config conf/webpack.config.js --progress --colors --port 5001 --content-base build/public",
    "build": "node_modules/.bin/webpack --config conf/webpack.config.js --progress --profile --colors"
  },
  "dependencies": {
    "amazeui": "^2.4.2",
    "babel-core": "^5.4.7",
    "babel-loader": "^5.1.3",
    "coffee-loader": "^0.7.2",
    "coffee-script": "^1.9.3",
    "css-loader": "^0.15.6",
    "echarts": "^2.2.7-beta7",
    "extract-text-webpack-plugin": "^0.8.1",
    "file-loader": "^0.8.4",
    "html-loader": "^0.3.0",
    "jquery": "^2.1.4",
    "manifest-revision-webpack-plugin": "^0.0.5",
    "node-sass": "^3.2.0",
    "postcss-loader": "^0.5.1",
    "sass-loader": "^2.0.0",
    "style-loader": "^0.12.3",
    "superagent": "^1.3.0",
    "url-loader": "^0.5.6",
    "vinyl-named": "^1.1.0",
    "vue": "^0.12.10",
    "vue-loader": "^2.1.1",
    "vue-validator": "^1.4.0",
    "webpack": "^1.10.0",
    "webpack-dev-server": "^1.9.0",
    "zrender": "ecomfe/zrender"
  }
}

3个回答

在此解决方案中一次生成一个项目。若要启用并行生成,请添加“/m”开关。
--- 这是一些提示建议等,没看到你说的具体问题是什么

deyuzhi
is_thinking 谢谢,不过这个应该是指导如何做package.json的,我的package.json 应该没有问题,这是个从github上面clone下来的。
4 年多之前 回复

我npm install也出现也在此解决方案中一次生成一个项目。若要启用并行生成,请添加“/m”开关。
请问你最后怎么解决的啊

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
npm安装package.json时repository为空
在编辑package.json 时,请问如果repository为空,那么npm会去哪里找 "repository" : { "type" : "git" , "url" : "" }
使用npm 执行package.json 里面的脚本报错,但是 脚本单独拿出来执行不报错
# package.json { "name": "fe", "version": "1.0.0", "description": "前端代码", "main": "index.js", "scripts": { "test": "echo \"Error: no test specified\" && exit 1", "dev" : "WEBPACK_ENV=dev webpack-dev-server --inline --port 8088" }, "repository": { "type": "git", "url": "git@gitee.com:。。。。。。" }, "author": "tomxfei", "license": "ISC", "devDependencies": { "css-loader": "^0.28.7", "extract-text-webpack-plugin": "^3.0.2", "file-loader": "^1.1.5", "html-loader": "^0.5.1", "html-webpack-plugin": "^2.30.1", "style-loader": "^0.19.0", "url-loader": "^0.6.2", "webpack": "^3.8.1", "webpack-dev-server": "^2.9.4" }, "dependencies": {} } # 执行 npm run dev报如下错误 ```Liuxf@DESKTOP-D3UCHLD MINGW64 /d/fe (fe_v1.0) $ npm run dev > fe@1.0.0 dev D:\fe > WEBPACK_ENV=dev webpack-dev-server --inline --port 8088 'WEBPACK_ENV' ▒▒▒▒▒ڲ▒▒▒▒ⲿ▒▒▒Ҳ▒▒▒ǿ▒▒▒▒еij▒▒▒ ▒▒▒▒▒▒▒▒▒ļ▒▒▒ npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! fe@1.0.0 dev: `WEBPACK_ENV=dev webpack-dev-server --inline --port 8088` npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the fe@1.0.0 dev script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above. npm ERR! A complete log of this run can be found in: npm ERR! C:\Users\75056\AppData\Roaming\npm-cache\_logs\2017-11-25T12_16_13_958Z-debug.log # 直接执行 WEBPACK_ENV=dev webpack-dev-server --inline --port 8088` 没有问题``` ``` ```
package-lock.json的用处
我打算把另一个项目的package.json给拷到我新项目去。。请问是不是不需要靠package-lock.json。。。然后自动生成就可以了?
依赖在node-modules中有了,但package.json中没有
npm install xxxx 安装了依赖之后 我现在想同步后安装在node-modules中的依赖到package.json中,怎么解决啊
webstrome创建项目是只有package.json和yarn-error.log两个文件
我用webstrome创建项目,应该会有public和src等目录的。但是现在创建出错了 <br> <br> yarn-error.log中的信息 ```node Arguments: /usr/local/Cellar/node/12.6.0/bin/node /usr/local/Cellar/yarn/1.17.3/libexec/bin/yarn.js --registry=https://registry.npm.taobao.org PATH: /Users/zhangmeng/WebstormProjects/untitled3/node_modules/.bin:/Users/zhangmeng/WebstormProjects/node_modules/.bin:/Users/zhangmeng/node_modules/.bin:/Users/node_modules/.bin:/node_modules/.bin:/usr/local/Cellar/node/12.6.0/bin:/Users/zhangmeng/.npm/_npx/22924/bin:/usr/local/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/Apple/usr/bin:/Library/Apple/bin:/Users/zhangmeng/apache-maven-3.6.1/bin Yarn version: 1.17.3 Node version: 12.6.0 Platform: darwin x64 Trace: Error: https://registry.npm.taobao.org/@vue%2fcli-plugin-babel: Invalid URI "https://registry.npm.taobao.org/@vue%2fcli-plugin-babel" at Request.module.exports.Request.init (/usr/local/Cellar/yarn/1.17.3/libexec/lib/cli.js:140552:31) at new Request (/usr/local/Cellar/yarn/1.17.3/libexec/lib/cli.js:140406:8) at request (/usr/local/Cellar/yarn/1.17.3/libexec/lib/cli.js:137312:10) at RequestManager.execute (/usr/local/Cellar/yarn/1.17.3/libexec/lib/cli.js:66882:15) at RequestManager.shiftQueue (/usr/local/Cellar/yarn/1.17.3/libexec/lib/cli.js:66920:10) at /usr/local/Cellar/yarn/1.17.3/libexec/lib/cli.js:66599:13 at new Promise (<anonymous>) at new F (/usr/local/Cellar/yarn/1.17.3/libexec/lib/cli.js:5296:28) at RequestManager.request (/usr/local/Cellar/yarn/1.17.3/libexec/lib/cli.js:66597:19) at NpmRegistry.<anonymous> (/usr/local/Cellar/yarn/1.17.3/libexec/lib/cli.js:31694:42) npm manifest: { "name": "untitled3", "version": "0.1.0", "private": true, "devDependencies": { "@vue/cli-plugin-babel": "^4.0.0", "@vue/cli-plugin-eslint": "^4.0.0", "@vue/cli-service": "^4.0.0" } } yarn manifest: No manifest Lockfile: No lockfile ``` 还有就是创建时会出现cue-cli不能更新,啥的。 ![图片说明](https://img-ask.csdn.net/upload/201910/28/1572266299_129622.png) <br> 求助
关于vue的cli里面package.json文件?
求大神指教一下这里面的东西都是啥?特别是scripts里面的,我发现我家里电脑的scripts里面的东西跟公司里scripts里面的东西是不一样的? ``` { "name": "zhiliao.0", "version": "1.0.0", "description": "A Vue.js project", "author": "momo <552488648@qq.com>", "private": true, "scripts": { "dev": "node build/dev-server.js", "build": "npm run build-prod", "start": "cross-env node build/webpack.dll.js && cross-env TYPE=local node build/dev-server.js", "start-dev": "node build/webpack.dll.js && cross-env TYPE=dev node build/dev-server.js", "start-test": "node build/webpack.dll.js && cross-env TYPE=test node build/dev-server.js", "start-prod": "node build/webpack.dll.js && cross-env TYPE=prod node build/dev-server.js", "build-local": "cross-env TYPE=local model=dev node build/webpack.dll.js && cross-env TYPE=local node build/build.js", "build-dev": "cross-env TYPE=dev model=build node build/webpack.dll.js && cross-env TYPE=dev node build/build.js", "build-test": "cross-env TYPE=test model=build node build/webpack.dll.js && cross-env TYPE=test node build/build.js", "build-prod": "cross-env TYPE=prod model=build node build/webpack.dll.js && cross-env TYPE=prod node build/build.js" }, "dependencies": { "axios": "^0.15.3", "blueimp-md5": "^2.7.0", "es6-promise": "^4.1.0", "mint-ui": "^2.2.1", "qs": "^6.4.0", "vue": "^2.2.2", "vue-baidu-map": "^0.10.5", "vue-router": "^2.2.0", "vuex": "^2.2.1", "weixin-js-sdk": "^1.2.0" }, "devDependencies": { "add-asset-html-webpack-plugin": "^2.1.2", "autoprefixer": "^6.7.2", "babel-core": "^6.22.1", "babel-eslint": "^8.0.3", "babel-loader": "^6.2.10", "babel-plugin-syntax-jsx": "^6.18.0", "babel-plugin-transform-runtime": "^6.22.0", "babel-plugin-transform-vue-jsx": "^3.5.0", "babel-preset-env": "^1.2.1", "babel-preset-es2015": "^6.24.1", "babel-preset-stage-2": "^6.22.0", "babel-register": "^6.22.0", "babel-runtime": "^6.26.0", "chalk": "^1.1.3", "connect-history-api-fallback": "^1.3.0", "copy-webpack-plugin": "^4.0.1", "cross-env": "^5.1.1", "css-loader": "^0.26.4", "eslint": "4.4.1", "eslint-config-standard": "10.2.1", "eslint-friendly-formatter": "3.0.0", "eslint-loader": "1.9.0", "eslint-plugin-html": "3.1.1", "eslint-plugin-import": "2.7.0", "eslint-plugin-node": "5.1.1", "eslint-plugin-promise": "3.5.0", "eslint-plugin-standard": "3.0.1", "eventsource-polyfill": "^0.9.6", "express": "^4.14.1", "extract-text-webpack-plugin": "^2.0.0", "file-loader": "^0.10.0", "form-data": "^0.2.0", "friendly-errors-webpack-plugin": "^1.1.3", "function-bind": "^1.1.0", "happypack": "^4.0.0", "html-webpack-plugin": "^2.28.0", "http-proxy-middleware": "^0.17.3", "iconv-lite": "^0.4.7", "mime": "~1.3.4", "node-sass": "^4.9.3", "opn": "^4.0.2", "optimize-css-assets-webpack-plugin": "^1.3.0", "ora": "^1.3.0", "portfinder": "^1.0.13", "request": "~2.72.0", "rimraf": "^2.6.0", "sass-loader": "^6.0.6", "semver": "^5.3.0", "shelljs": "^0.8.1", "url-loader": "^0.5.7", "urlencode": "^1.1.0", "verification-code": "^1.0.0", "vue-loader": "^11.1.4", "vue-style-loader": "^2.0.5", "vue-template-compiler": "^2.2.4", "webpack": "^2.2.1", "webpack-bundle-analyzer": "^2.2.1", "webpack-dev-middleware": "^1.10.0", "webpack-hot-middleware": "^2.16.1", "webpack-merge": "^2.6.1", "webpack-parallel-uglify-plugin": "^1.0.2", "workbox-webpack-plugin": "^2.1.2", "ws": "^0.4.32" }, "engines": { "node": ">= 4.0.0", "npm": ">= 3.0.0" }, "publishConfig": { "registry": "http://registry.npm.alibaba-inc.com" }, "browserslist": [ "> 1%", "last 2 versions", "not ie <= 8" ] } ```
spring boot + reactjs如何整合在一起?
用npm启动react,可以显示前端页面,但是拿不到数据。 用spring boot启动可以拿到数据,但是显示不出前端页面。 分别是maven的pom.xml和npm的package.json做的配置。 请问spring boot + reactjs如何整合,是不是应该把配置文件写成一个? 新手求老司机指点! 多谢了!
npm安装webpack失败!!!
node.js已经安装好了 npm也已经安装。安装的时候一路确定没有做路径的修改。 ![图片说明](https://img-ask.csdn.net/upload/201709/27/1506504327_787644.png) 项目放在D盘下面 也用npm生成了package.json文件 ![图片说明](https://img-ask.csdn.net/upload/201709/27/1506504408_978490.png) 最后我在安装全局webpack的时候失败!无论在哪安装都是报这个错.... ![图片说明](https://img-ask.csdn.net/upload/201709/27/1506504460_937589.png) 也不知道哪错了 心累┭┮﹏┭┮ 求大神指点。。。
关于安装npm过程中出现的错误
![图片说明](https://img-ask.csdn.net/upload/201902/27/1551248194_518694.png) 今天刚学习npm,完全不懂错在哪里了,能帮忙看看吗? ![图片说明](https://img-ask.csdn.net/upload/201902/27/1551248607_180807.png) 还有我在is this ok这边后面加上yes后点击回车没有反应是什么原因?我直接ctrl+c跳出来了。但是也生成了完整的package.json
npm安装@vue/cli失败,提示仅支持https
之前装过这些,但因为别的原因,把AppData下相关文件和用户的注册文件删了重装,结果这次安装失败。 先是卡在**fetchmetadata:sill resolvewithnewmodule typescript**不动,然后取消了两次后, 配置了阿里镜像:npm config set registry https://registry.npm.taobao.org,然后再执行就报错误,说仅支持https。 这是dos界面提示 ![图片说明](https://img-ask.csdn.net/upload/201909/20/1568914845_998077.png) cnpm模块的package.json文件: ![图片说明](https://img-ask.csdn.net/upload/201909/20/1568915208_526334.png) debug文件: ``` 0 info it worked if it ends with ok 1 verbose cli [ 1 verbose cli 'D:\\work softs\\web_html\\nodejs\\node.exe', 1 verbose cli 'D:\\work softs\\web_html\\nodejs\\node_modules\\npm\\bin\\npm-cli.js', 1 verbose cli 'install', 1 verbose cli '@vue/cli', 1 verbose cli '-g' 1 verbose cli ] 2 info using npm@6.10.3 3 info using node@v12.10.0 4 verbose npm-session 599580d47326bd14 5 silly install loadCurrentTree 6 silly install readGlobalPackageData 7 silly fetchPackageMetaData error for @vue/cli@latest Only HTTP(S) protocols are supported 8 timing stage:rollbackFailedOptional Completed in 1ms 9 timing stage:runTopLevelLifecycles Completed in 27ms 10 verbose stack TypeError: Only HTTP(S) protocols are supported 10 verbose stack at getNodeRequestOptions (D:\work softs\web_html\nodejs\node_modules\npm\node_modules\node-fetch-npm\src\request.js:135:11) 10 verbose stack at D:\work softs\web_html\nodejs\node_modules\npm\node_modules\node-fetch-npm\src\index.js:44:21 10 verbose stack at new Promise (<anonymous>) 10 verbose stack at fetch (D:\work softs\web_html\nodejs\node_modules\npm\node_modules\node-fetch-npm\src\index.js:41:10) 10 verbose stack at D:\work softs\web_html\nodejs\node_modules\npm\node_modules\make-fetch-happen\index.js:332:14 10 verbose stack at D:\work softs\web_html\nodejs\node_modules\npm\node_modules\promise-retry\index.js:29:24 11 verbose cwd C:\Users\86180 12 verbose Windows_NT 10.0.18362 13 verbose argv "D:\\work softs\\web_html\\nodejs\\node.exe" "D:\\work softs\\web_html\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "@vue/cli" "-g" 14 verbose node v12.10.0 15 verbose npm v6.10.3 16 error Only HTTP(S) protocols are supported 17 verbose exit [ 1, true ] ```
安装npm install时出现错误
我是在win8上面操作,需要在github上面克隆一个项目在本地编辑 在nodejs官网上面下载了一个安装包,安装后进行了如下操作 1:新建了一个文件夹,用virtualenv做成虚拟环境 2:将github上面的项目clone到该文件夹 3:将该文件夹进入venv虚拟环境 4:安装Python的依赖包flask之类的 5:进入项目的static文件夹,(这里面有package.json文件,dependencies里有一项是"sass-loader": "^2.0.0",) 输入了如下命令:npm install 错误如下: ``` Building: C:\Program Files\nodejs\node.exe node_modules\pangyp\bin\node-gyp rebuild --libsass_ext= --libsass_cflags= --libsa ss_ldflags= --libsass_library= gyp WARN install got an error, rolling back install gyp ERR! configure error gyp ERR! stack Error: node-v0.12.7.tar.gz local checksum 88bc1dbe3f1da75a4b5eabea55ab1f40a99373b8ae7356d2374e8053ced04ec0 no 42e53067127a5061415be7e12f39d gyp ERR! stack at deref (E:\project1_2\shijuan\node_modules\node-sass\node_modules\pangyp\lib\install.js:304:20) gyp ERR! stack at Request.<anonymous> (E:\project1_2\shijuan\node_modules\node-sass\node_modules\pangyp\lib\install.js:3 gyp ERR! stack at Request.emit (events.js:129:20) gyp ERR! stack at IncomingMessage.<anonymous> (E:\project1_2\shijuan\node_modules\node-sass\node_modules\pangyp\node_mod gyp ERR! stack at IncomingMessage.emit (events.js:129:20) gyp ERR! stack at _stream_readable.js:908:16 gyp ERR! stack at process._tickCallback (node.js:355:11) gyp ERR! System Windows_NT 6.3.9600 gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "E:\\project1_2\\shijuan\\node_modules\\node-sass\\node_modules\\pang ibsass_cflags=" "--libsass_ldflags=" "--libsass_library=" gyp ERR! cwd E:\project1_2\shijuan\node_modules\node-sass gyp ERR! node -v v0.12.7 gyp ERR! pangyp -v v2.3.0 gyp ERR! not ok Build failed ``` 不知道是哪个地方的原因,希望各位老师不吝赐教,谢谢
npm start missing log信息在下面
0 info it worked if it ends with ok 1 verbose cli [ 'D:\\ProgramFiles\\nodejs\\node.exe', 1 verbose cli 'C:\\Users\\fgdt\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js', 1 verbose cli 'start' ] 2 info using npm@5.5.1 3 info using node@v8.9.0 4 verbose config Skipping project config: C:\Users\fgdt/.npmrc. (matches userconfig) 5 verbose stack Error: missing script: start 5 verbose stack at run (C:\Users\fgdt\AppData\Roaming\npm\node_modules\npm\lib\run-script.js:151:19) 5 verbose stack at C:\Users\fgdt\AppData\Roaming\npm\node_modules\npm\lib\run-script.js:61:5 5 verbose stack at C:\Users\fgdt\AppData\Roaming\npm\node_modules\npm\node_modules\read-package-json\read-json.js:115:5 5 verbose stack at C:\Users\fgdt\AppData\Roaming\npm\node_modules\npm\node_modules\read-package-json\read-json.js:402:5 5 verbose stack at checkBinReferences_ (C:\Users\fgdt\AppData\Roaming\npm\node_modules\npm\node_modules\read-package-json\read-json.js:357:45) 5 verbose stack at final (C:\Users\fgdt\AppData\Roaming\npm\node_modules\npm\node_modules\read-package-json\read-json.js:400:3) 5 verbose stack at then (C:\Users\fgdt\AppData\Roaming\npm\node_modules\npm\node_modules\read-package-json\read-json.js:160:5) 5 verbose stack at ReadFileContext.<anonymous> (C:\Users\fgdt\AppData\Roaming\npm\node_modules\npm\node_modules\read-package-json\read-json.js:332:20) 5 verbose stack at ReadFileContext.callback (C:\Users\fgdt\AppData\Roaming\npm\node_modules\npm\node_modules\graceful-fs\graceful-fs.js:78:16) 5 verbose stack at FSReqWrap.readFileAfterOpen [as oncomplete] (fs.js:420:13) 6 verbose cwd C:\Users\fgdt\Desktop\testReact 7 verbose Windows_NT 6.1.7601 8 verbose argv "D:\\ProgramFiles\\nodejs\\node.exe" "C:\\Users\\fgdt\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js" "start" 9 verbose node v8.9.0 10 verbose npm v5.5.1 11 error missing script: start 12 verbose exit [ 1, true ]
vue-cli npm run build报错
![图片说明](https://img-ask.csdn.net/upload/201907/30/1564459555_859850.png)![图片说明](https://img-ask.csdn.net/upload/201907/30/1564459566_230960.png)![图片说明](https://img-ask.csdn.net/upload/201907/30/1564459740_221490.png) 之前打包都没有问题,但是打包之后又npm安装了一个东西,再打包就报错了,但是在package.json文件中已经存在新加了东西,不知道要怎么解决,求助各位大神啦
关于electron项目npm start的问题
如下图,我在electron项目中,将package.json中的scripts属性的start属性,修改成下面的值,执行npm start命令,都可以启动项目; 但是我,将scripts属性的start属性改成electron时执行npm start报错; 将scripts属性的start属性改成main.js时执行npm start报错; 这是为什么 ![图片说明](https://img-ask.csdn.net/upload/201609/22/1474510078_132278.png) ![图片说明](https://img-ask.csdn.net/upload/201609/22/1474510087_939661.png)
gulp全局安装报错如下,有人知道怎么解决吗,非常感谢
![图片说明](https://img-ask.csdn.net/upload/201812/04/1543915646_254672.png)gulp安装报错如图,node.js和npm都安装了,报错有11个漏洞,不知道为什么,package.json文件也放到要安装的目录了
运行Vue项目时,报错npm ERR! errno 1 npm ERR! Failed at the single@1.0.0 dev script.
运行Vue项目时,报错,不清楚是哪里出了问题 ``` Error: Cannot find module 'webpack-cli/bin/config-yargs' at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15) at Function.Module._load (internal/modules/cjs/loader.js:562:25) at Module.require (internal/modules/cjs/loader.js:690:17) at require (internal/modules/cjs/helpers.js:25:18) at Object.<anonymous> (E:\HBuilderProjects\Vue\single\node_modules\_webpack-dev-server@3.7.1@webpack-dev-server\bin\webpack-dev-server.js:60:1) at Module._compile (internal/modules/cjs/loader.js:776:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:787:10) at Module.load (internal/modules/cjs/loader.js:653:32) at tryModuleLoad (internal/modules/cjs/loader.js:593:12) at Function.Module._load (internal/modules/cjs/loader.js:585:3) npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! single@1.0.0 dev: `webpack-dev-server --open --hot --port 8020` npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the single@1.0.0 dev script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above. npm ERR! A complete log of this run can be found in: npm ERR! C:\Users\asus\AppData\Roaming\npm-cache\_logs\2019-06-15T16_43_01_654Z-debug.log ``` ``` ``` 这个是package.json文件 ``` { "name": "single", "version": "1.0.0", "description": "", "main": "main.js", "scripts": { "dev": "webpack-dev-server --open --hot --port 8020" }, "keywords": [], "author": "", "license": "ISC", "dependencies": { "vue": "^2.6.10" }, "devDependencies": { "babel-core": "^6.26.3", "babel-loader": "^8.0.6", "babel-preset-env": "^1.7.0", "css-loader": "^3.0.0", "file-loader": "^4.0.0", "vue-html-loader": "^1.2.4", "vue-loader": "^15.7.0", "vue-style-loader": "^4.1.2", "vue-template-compiler": "^2.6.10", "webpack": "^4.34.0", "webpack-dev-server": "^3.7.1" } } ```
angular-cli node sqlite3编译出错
1. 描述问题 使用angular-universal创建服务时,在node里添加sqlit3模块,添加后再编译的时候总是报错,导致无法执行 2.相关代码 ``` const sqlite3 = require('sqlite3').verbose(); const db = new sqlite3.Database('./src/assets/NLAT.1.db'); db.all("SELECT * from blah blah blah where this=",function(err,rows){ //rows contain values while errors, well you can figure out. }); ``` 3.报错信息 ``` E:\project\NetWork-Analysis\dist\server.js:33542 throw new Error("package.json does not exist at " + package_json_path); ^ Error: package.json does not exist at E:\package.json at Object.exports.find (E:\project\NetWork-Analysis\dist\server.js:33542:15) at Object.<anonymous> (E:\project\NetWork-Analysis\dist\server.js:23111:27) at Object.module.exports (E:\project\NetWork-Analysis\dist\server.js:23317:30) at __webpack_require__ (E:\project\NetWork-Analysis\dist\server.js:20:30) at Module.<anonymous> (E:\project\NetWork-Analysis\dist\server.js:120:17) at __webpack_require__ (E:\project\NetWork-Analysis\dist\server.js:20:30) at E:\project\NetWork-Analysis\dist\server.js:84:18 at Object.<anonymous> (E:\project\NetWork-Analysis\dist\server.js:87:10) at Module._compile (internal/modules/cjs/loader.js:776:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:787:10) ``` 4.尝试过的方式,方法,报错内容提示 网上搜索过,但是没有找到相关的报错信息,报错出现在npm run serve:ssr之后,build:ssr都可以执行并编译
在终端执行webpack调用webpack.config.js 时,报错
### 在终端执行webpack调用webpack.config.js 时,报错,求大佬解决 ### 这是我 webpack.config.js 的代码 ``` JavaScript const path = require('path') module.exports = { entry: './src/main.js', output: { path: path.join(__dirname, './dist'), filename: 'bundle.js' }, mode: 'development' } ``` ### 这是我 package.json 的内容 ``` { "name": "webpack-b", "version": "1.0.0", "description": "", "main": "index.js", "scripts": { "test": "echo \"Error: no test specified\" && exit 1" }, "keywords": [], "author": "", "license": "ISC", "devDependencies": { "jquery": "^3.3.1", "webpack": "^4.20.2", "webpack-cli": "^3.1.2" } } ``` 这是目录结构 ![图片说明](https://img-ask.csdn.net/upload/201810/09/1539066890_92808.png) 这是我报错的信息 ![图片说明](https://img-ask.csdn.net/upload/201810/09/1539066961_249766.png) #### 但是如果我在package.json的 script 中加上 ``` javascript "scripts": { "test": "echo \"Error: no test specified\" && exit 1", "dev": "webpack --mode development ./src/main.js --output ./dist/bundle.js" }, ```` 然后在终端执行 npm run dev,却是成功的,求解 ![图片说明](https://img-ask.csdn.net/upload/201810/09/1539067218_230104.png)
解決 vue code ELIFECYCLE 的方法
![图片说明](https://img-ask.csdn.net/upload/201911/28/1574908016_151108.jpg) ![图片说明](https://img-ask.csdn.net/upload/201911/28/1574909752_15853.png) 環境 npm -v 6.12.0 node -v -->v8.16.1 npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! tabbar@1.0.0 dev: `webpack-dev-server --inline --progress --config build/webpack.dev.conf.js` npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the tabbar@1.0.0 dev script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above. google 百度查找方法一(不ok) ``` rm -rf node_modules rm package-lock.json npm cache clear --force npm install ``` 方法二(還是不OK) ``` npm uninstall webpack-dev-server npm install webpack-dev-server@2.9.1 ``` vue版本和webpack-dev-server版本不匹配導致
终于明白阿里百度这样的大公司,为什么面试经常拿ThreadLocal考验求职者了
点击上面↑「爱开发」关注我们每晚10点,捕获技术思考和创业资源洞察什么是ThreadLocalThreadLocal是一个本地线程副本变量工具类,各个线程都拥有一份线程私有的数
程序员必须掌握的核心算法有哪些?
由于我之前一直强调数据结构以及算法学习的重要性,所以就有一些读者经常问我,数据结构与算法应该要学习到哪个程度呢?,说实话,这个问题我不知道要怎么回答你,主要取决于你想学习到哪些程度,不过针对这个问题,我稍微总结一下我学过的算法知识点,以及我觉得值得学习的算法。这些算法与数据结构的学习大多数是零散的,并没有一本把他们全部覆盖的书籍。下面是我觉得值得学习的一些算法以及数据结构,当然,我也会整理一些看过...
《奇巧淫技》系列-python!!每天早上八点自动发送天气预报邮件到QQ邮箱
此博客仅为我业余记录文章所用,发布到此,仅供网友阅读参考,如有侵权,请通知我,我会删掉。 补充 有不少读者留言说本文章没有用,因为天气预报直接打开手机就可以收到了,为何要多此一举发送到邮箱呢!!!那我在这里只能说:因为你没用,所以你没用!!! 这里主要介绍的是思路,不是天气预报!不是天气预报!!不是天气预报!!!天气预报只是用于举例。请各位不要再刚了!!! 下面是我会用到的两个场景: 每日下
死磕YOLO系列,YOLOv1 的大脑、躯干和手脚
YOLO 是我非常喜欢的目标检测算法,堪称工业级的目标检测,能够达到实时的要求,它帮我解决了许多实际问题。 这就是 YOLO 的目标检测效果。它定位了图像中物体的位置,当然,也能预测物体的类别。 之前我有写博文介绍过它,但是每次重新读它的论文,我都有新的收获,为此我准备写一个系列的文章来详尽分析它。这是第一篇,从它的起始 YOLOv1 讲起。 YOLOv1 的论文地址:https://www.c...
知乎高赞:中国有什么拿得出手的开源软件产品?(整理自本人原创回答)
知乎高赞:中国有什么拿得出手的开源软件产品? 在知乎上,有个问题问“中国有什么拿得出手的开源软件产品(在 GitHub 等社区受欢迎度较好的)?” 事实上,还不少呢~ 本人于2019.7.6进行了较为全面的回答,对这些受欢迎的 Github 开源项目分类整理如下: 分布式计算、云平台相关工具类 1.SkyWalking,作者吴晟、刘浩杨 等等 仓库地址: apache/skywalking 更...
20行Python代码爬取王者荣耀全英雄皮肤
引言 王者荣耀大家都玩过吧,没玩过的也应该听说过,作为时下最火的手机MOBA游戏,咳咳,好像跑题了。我们今天的重点是爬取王者荣耀所有英雄的所有皮肤,而且仅仅使用20行Python代码即可完成。 准备工作 爬取皮肤本身并不难,难点在于分析,我们首先得得到皮肤图片的url地址,话不多说,我们马上来到王者荣耀的官网: 我们点击英雄资料,然后随意地选择一位英雄,接着F12打开调试台,找到英雄原皮肤的图片...
简明易理解的@SpringBootApplication注解源码解析(包含面试提问)
欢迎关注文章系列 ,关注我 《提升能力,涨薪可待》 《面试知识,工作可待》 《实战演练,拒绝996》 欢迎关注我博客,原创技术文章第一时间推出 也欢迎关注公 众 号【Ccww笔记】,同时推出 如果此文对你有帮助、喜欢的话,那就点个赞呗,点个关注呗! 《提升能力,涨薪可待篇》- @SpringBootApplication注解源码解析 一、@SpringBootApplication 的作用是什...
西游记团队中如果需要裁掉一个人,会先裁掉谁?
2019年互联网寒冬,大批企业开始裁员,下图是网上流传的一张截图: 裁员不可避免,那如何才能做到不管大环境如何变化,自身不受影响呢? 我们先来看一个有意思的故事,如果西游记取经团队需要裁员一名,会裁掉谁呢,为什么? 西游记团队组成: 1.唐僧 作为团队teamleader,有很坚韧的品性和极高的原则性,不达目的不罢休,遇到任何问题,都没有退缩过,又很得上司支持和赏识(直接得到唐太宗的任命,既给袈...
Python语言高频重点汇总
Python语言高频重点汇总 GitHub面试宝典仓库 回到首页 目录: Python语言高频重点汇总 目录: 1. 函数-传参 2. 元类 3. @staticmethod和@classmethod两个装饰器 4. 类属性和实例属性 5. Python的自省 6. 列表、集合、字典推导式 7. Python中单下划线和双下划线 8. 格式化字符串中的%和format 9. 迭代器和生成器 10...
究竟你适不适合买Mac?
我清晰的记得,刚买的macbook pro回到家,开机后第一件事情,就是上了淘宝网,花了500元钱,找了一个上门维修电脑的师傅,上门给我装了一个windows系统。。。。。。 表砍我。。。 当时买mac的初衷,只是想要个固态硬盘的笔记本,用来运行一些复杂的扑克软件。而看了当时所有的SSD笔记本后,最终决定,还是买个好(xiong)看(da)的。 已经有好几个朋友问我mba怎么样了,所以今天尽量客观
程序员一般通过什么途径接私活?
二哥,你好,我想知道一般程序猿都如何接私活,我也想接,能告诉我一些方法吗? 上面是一个读者“烦不烦”问我的一个问题。其实不止是“烦不烦”,还有很多读者问过我类似这样的问题。 我接的私活不算多,挣到的钱也没有多少,加起来不到 20W。说实话,这个数目说出来我是有点心虚的,毕竟太少了,大家轻喷。但我想,恰好配得上“一般程序员”这个称号啊。毕竟苍蝇再小也是肉,我也算是有经验的人了。 唾弃接私活、做外
ES6基础-ES6的扩展
进行对字符串扩展,正则扩展,数值扩展,函数扩展,对象扩展,数组扩展。 开发环境准备: 编辑器(VS Code, Atom,Sublime)或者IDE(Webstorm) 浏览器最新的Chrome 字符串的扩展: 模板字符串,部分新的方法,新的unicode表示和遍历方法: 部分新的字符串方法 padStart,padEnd,repeat,startsWith,endsWith,includes 字...
Python爬虫爬取淘宝,京东商品信息
小编是一个理科生,不善长说一些废话。简单介绍下原理然后直接上代码。 使用的工具(Python+pycharm2019.3+selenium+xpath+chromedriver)其中要使用pycharm也可以私聊我selenium是一个框架可以通过pip下载 pip install selenium -i https://pypi.tuna.tsinghua.edu.cn/simple/ 
阿里程序员写了一个新手都写不出的低级bug,被骂惨了。
你知道的越多,你不知道的越多 点赞再看,养成习惯 本文 GitHub https://github.com/JavaFamily 已收录,有一线大厂面试点思维导图,也整理了很多我的文档,欢迎Star和完善,大家面试可以参照考点复习,希望我们一起有点东西。 前前言 为啥今天有个前前言呢? 因为你们的丙丙啊,昨天有牌面了哟,直接被微信官方推荐,知乎推荐,也就仅仅是还行吧(心里乐开花)
Java工作4年来应聘要16K最后没要,细节如下。。。
前奏: 今天2B哥和大家分享一位前几天面试的一位应聘者,工作4年26岁,统招本科。 以下就是他的简历和面试情况。 基本情况: 专业技能: 1、&nbsp;熟悉Sping了解SpringMVC、SpringBoot、Mybatis等框架、了解SpringCloud微服务 2、&nbsp;熟悉常用项目管理工具:SVN、GIT、MAVEN、Jenkins 3、&nbsp;熟悉Nginx、tomca
Python爬虫精简步骤1 获取数据
爬虫的工作分为四步: 1.获取数据。爬虫程序会根据我们提供的网址,向服务器发起请求,然后返回数据。 2.解析数据。爬虫程序会把服务器返回的数据解析成我们能读懂的格式。 3.提取数据。爬虫程序再从中提取出我们需要的数据。 4.储存数据。爬虫程序把这些有用的数据保存起来,便于你日后的使用和分析。 这一篇的内容就是:获取数据。 首先,我们将会利用一个强大的库——requests来获取数据。 在电脑上安装
作为一个程序员,CPU的这些硬核知识你必须会!
CPU对每个程序员来说,是个既熟悉又陌生的东西? 如果你只知道CPU是中央处理器的话,那可能对你并没有什么用,那么作为程序员的我们,必须要搞懂的就是CPU这家伙是如何运行的,尤其要搞懂它里面的寄存器是怎么一回事,因为这将让你从底层明白程序的运行机制。 随我一起,来好好认识下CPU这货吧 把CPU掰开来看 对于CPU来说,我们首先就要搞明白它是怎么回事,也就是它的内部构造,当然,CPU那么牛的一个东
破14亿,Python分析我国存在哪些人口危机!
2020年1月17日,国家统计局发布了2019年国民经济报告,报告中指出我国人口突破14亿。 猪哥的朋友圈被14亿人口刷屏,但是很多人并没有看到我国复杂的人口问题:老龄化、男女比例失衡、生育率下降、人口红利下降等。 今天我们就来分析一下我们国家的人口数据吧! 更多有趣分析教程,扫描下方二维码关注vx公号「裸睡的猪」 即可查看! 一、背景 1.人口突破14亿 2020年1月17日,国家统计局发布
web前端javascript+jquery知识点总结
Javascript javascript 在前端网页中占有非常重要的地位,可以用于验证表单,制作特效等功能,它是一种描述语言,也是一种基于对象(Object)和事件驱动并具有安全性的脚本语言 ,语法同java类似,是一种解释性语言,边执行边解释。 JavaScript的组成: ECMAScipt 用于描述: 语法,变量和数据类型,运算符,逻辑控制语句,关键字保留字,对象。 浏览器对象模型(Br
Qt实践录:开篇
本系列文章介绍笔者的Qt实践之路。
在家远程办公效率低?那你一定要收好这个「在家办公」神器!
相信大家都已经收到国务院延长春节假期的消息,接下来,在家远程办公可能将会持续一段时间。 但是问题来了。远程办公不是人在电脑前就当坐班了,相反,对于沟通效率,文件协作,以及信息安全都有着极高的要求。有着非常多的挑战,比如: 1在异地互相不见面的会议上,如何提高沟通效率? 2文件之间的来往反馈如何做到及时性?如何保证信息安全? 3如何规划安排每天工作,以及如何进行成果验收? ......
作为一个程序员,内存和磁盘的这些事情,你不得不知道啊!!!
截止目前,我已经分享了如下几篇文章: 一个程序在计算机中是如何运行的?超级干货!!! 作为一个程序员,CPU的这些硬核知识你必须会! 作为一个程序员,内存的这些硬核知识你必须懂! 这些知识可以说是我们之前都不太重视的基础知识,可能大家在上大学的时候都学习过了,但是嘞,当时由于老师讲解的没那么有趣,又加上这些知识本身就比较枯燥,所以嘞,大家当初几乎等于没学。 再说啦,学习这些,也看不出来有什么用啊!
这个世界上人真的分三六九等,你信吗?
偶然间,在知乎上看到一个问题 一时间,勾起了我深深的回忆。 以前在厂里打过两次工,做过家教,干过辅导班,做过中介。零下几度的晚上,贴过广告,满脸、满手地长冻疮。   再回首那段岁月,虽然苦,但让我学会了坚持和忍耐。让我明白了,在这个世界上,无论环境多么的恶劣,只要心存希望,星星之火,亦可燎原。   下文是原回答,希望能对你能有所启发。   如果我说,这个世界上人真的分三六九等,
为什么听过很多道理,依然过不好这一生?
记录学习笔记是一个重要的习惯,不希望学习过的东西成为过眼云烟。做总结的同时也是一次复盘思考的过程。 本文是根据阅读得到 App上《万维钢·精英日课》部分文章后所做的一点笔记和思考。学习是一个系统的过程,思维模型的建立需要相对完整的学习和思考过程。以下观点是在碎片化阅读后总结的一点心得总结。
B 站上有哪些很好的学习资源?
哇说起B站,在小九眼里就是宝藏般的存在,放年假宅在家时一天刷6、7个小时不在话下,更别提今年的跨年晚会,我简直是跪着看完的!! 最早大家聚在在B站是为了追番,再后来我在上面刷欧美新歌和漂亮小姐姐的舞蹈视频,最近两年我和周围的朋友们已经把B站当作学习教室了,而且学习成本还免费,真是个励志的好平台ヽ(.◕ฺˇд ˇ◕ฺ;)ノ 下面我们就来盘点一下B站上优质的学习资源: 综合类 Oeasy: 综合
雷火神山直播超两亿,Web播放器事件监听是怎么实现的?
Web播放器解决了在手机浏览器和PC浏览器上播放音视频数据的问题,让视音频内容可以不依赖用户安装App,就能进行播放以及在社交平台进行传播。在视频业务大数据平台中,播放数据的统计分析非常重要,所以Web播放器在使用过程中,需要对其内部的数据进行收集并上报至服务端,此时,就需要对发生在其内部的一些播放行为进行事件监听。 那么Web播放器事件监听是怎么实现的呢? 01 监听事件明细表 名
3万字总结,Mysql优化之精髓
本文知识点较多,篇幅较长,请耐心学习 MySQL已经成为时下关系型数据库产品的中坚力量,备受互联网大厂的青睐,出门面试想进BAT,想拿高工资,不会点MySQL优化知识,拿offer的成功率会大大下降。 为什么要优化 系统的吞吐量瓶颈往往出现在数据库的访问速度上 随着应用程序的运行,数据库的中的数据会越来越多,处理时间会相应变慢 数据是存放在磁盘上的,读写速度无法和内存相比 如何优化 设计
一条链接即可让黑客跟踪你的位置! | Seeker工具使用
搬运自:冰崖的部落阁(icecliffsnet) 严正声明:本文仅限于技术讨论,严禁用于其他用途。 请遵守相对应法律规则,禁止用作违法途径,出事后果自负! 上次写的防社工文章里边提到的gps定位信息(如何防止自己被社工或人肉) 除了主动收集他人位置信息以外,我们还可以进行被动收集 (没有技术含量) Seeker作为一款高精度地理位置跟踪工具,同时也是社交工程学(社会工程学)爱好者...
作为程序员的我,大学四年一直自学,全靠这些实用工具和学习网站!
我本人因为高中沉迷于爱情,导致学业荒废,后来高考,毫无疑问进入了一所普普通通的大学,实在惭愧...... 我又是那么好强,现在学历不行,没办法改变的事情了,所以,进入大学开始,我就下定决心,一定要让自己掌握更多的技能,尤其选择了计算机这个行业,一定要多学习技术。 在进入大学学习不久后,我就认清了一个现实:我这个大学的整体教学质量和学习风气,真的一言难尽,懂的人自然知道怎么回事? 怎么办?我该如何更好的提升
前端JS初级面试题二 (。•ˇ‸ˇ•。)老铁们!快来瞧瞧自己都会了么
1. 传统事件绑定和符合W3C标准的事件绑定有什么区别? 传统事件绑定 &lt;div onclick=""&gt;123&lt;/div&gt; div1.onclick = function(){}; &lt;button onmouseover=""&gt;&lt;/button&gt; 注意: 如果给同一个元素绑定了两次或多次相同类型的事件,那么后面的绑定会覆盖前面的绑定 (不支持DOM事...
相关热词 c# 数组类型 泛型约束 c#的赛狗日程序 c# 传递数组 可变参数 c# 生成存储过程 c# list 补集 c#获得所有窗体 c# 当前秒数转成年月日 c#中的枚举 c# 计算校验和 连续随机数不重复c#
立即提问