qiebixuefu2013
陶子11
采纳率33.3%
2015-11-03 13:08 阅读 2.8k
已采纳

关于ubuntu中qt5环境配置得问题

3

在网上下了qt-opensource-linux-x64-5.5.0-2.run,在ubuntu14.10中安装,没有任何问题,安装之后写了个小程序
运行之后发现:-1: error: cannot find -lGL :-1: error: collect2: error: ld returned 1 exit status
发现网上给的答案是安装libgl1-mesa-dev
结果下列软件包有未满足的依赖关系:
libgl1-mesa-dev : 依赖: mesa-common-dev (= 10.1.3-0ubuntu0.5)
依赖: libgl1-mesa-glx (= 10.1.3-0ubuntu0.5) 或
libgl1-mesa-glx-lts-utopic 但是它将不会被安装 或
libgl1-mesa-glx-lts-vivid 但是它将不会被安装
依赖: libx11-dev 但是它将不会被安装
依赖: libx11-xcb-dev 但是它将不会被安装
依赖: libxcb-dri3-dev 但是它将不会被安装
依赖: libxcb-present-dev 但是它将不会被安装
依赖: libxcb-sync-dev 但是它将不会被安装
依赖: libxshmfence-dev 但是它将不会被安装
依赖: libxcb-dri2-0-dev 但是它将不会被安装
依赖: libxcb-glx0-dev 但是它将不会被安装
依赖: libxdamage-dev 但是它将不会被安装
依赖: libxext-dev 但是它将不会被安装
依赖: libxfixes-dev 但是它将不会被安装
依赖: libxxf86vm-dev 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
结果一直没有找的合适得方法,求指教

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

2条回答 默认 最新

  • 已采纳
    lln_01 lln_01 2015-11-03 22:13

    加上 -f 选项试试

    点赞 评论 复制链接分享
  • qq_31433193 qq_31433193 2015-11-03 14:37

    f的范德萨发的发的发的发生大幅度

    点赞 评论 复制链接分享

相关推荐