2 yuv web yuv_web 于 2016.01.19 15:14 提问

Win10系统80端口被占用问题

电脑更新了win10系统后,打开wamp发现用不了,在网上找了一下解决办法,也找到了
图片说明
图片说明
这个进程占用了80端口,于是又找办法解决
1、打开注册表:regedit
2、找到:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\HTTP
3、在右边找到Start这一项,将其改为0
4、重启系统,System进程不会占用80端口
重启之后,再启动Apache就可以了。
图片说明
照着网上的办法都修改过来 了,可是重启之后打开wamp,发现还是那样
图片说明
找开注册表也显示修改过为0了,各位大神,遇到这样的情况要怎么办,有啥解决的办法?

4个回答

caozhy
caozhy   Ds   Rxr 2016.01.19 16:41

电脑感染了360非法流氓软件,建议重装下系统吧。

save4me
save4me   Ds   Rxr 2016.01.19 23:16

参考【Windows 8】pid为4的system进程占用80端口的解决办法

以管理员权限运行c:\windows\system32\cmd.exe

C:\WINDOWS\system32>net stop http

HTTP Service 服务已成功停止。

C:\WINDOWS\system32>netstat -ano | findstr 0.0.0.0:80

C:\WINDOWS\system32>sc config http start=disabled
[SC] ChangeServiceConfig 成功

oyljerry
oyljerry   Ds   Rxr 2016.01.20 07:49

这还是有端口占用问题 是不是有恶意程序等一直抢占80端口

yuv_web
yuv_web   2016.01.28 09:32

最终换成了AppServ,没有用wamp了.............................

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
记PHPStudy-win10系统80端口被占用的经历
1、打开注册表:regedit 2、找到:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\HTTP 3、在右边找到Start这一项,将其改为0 4、重启系统,System进程不会占用80端口 重启之后,再启动Apache就可以了。
升级win10 系统后80 端口被占用 问题排查、解决
终于空出点时间可以安装win10 系统了,在各种等待和重启之后,系统终于装好了,将各种软件统统启动走一遍,没有问题,可以开始干活了。然而悲剧发生了,phpstudy居然启动失败,在重启一次,还是不行。 怎么办呢,google走起。 找到点有用的:开始 “运行” 中输入 cmd 在命令行中输入 netstat -ano 查找80端口号占用的对应PID第一个就是占用80端口的程序。桌面下方菜单栏 -》
win10系统80端口被System (PID=4)占用的解决
今天想用wamp搭建虚拟目录。发现80端口被占用,操作挺麻烦的,所以想要更改。 具体流程如下: 1、“win+R”输入“cmd”,然后输入“netstat -ano | findstr "80"” 2、从上图可以知道,80端口被win10系统进程占用了,在资源管理器里无法直接删除。 3、打开cmd,输入regedit,逐层找到HKEY_LOCAL_MACHINE\SYSTEM\Cu
【完美解决】在WIN10中,解决80端口默认被占用的问题
在WIN10中,解决80端口默认被占用的问题方案1: 以管理员身份运行cmd; 输入:net stop http; 如果提示是否真的需要停止这些服务,则选择“Y”; 完成后输入:sc config http start=disabled. 方案2: Ctrl+x,然后选择“计算机管理”,展开“服务和应用程序”; 找到“服务”; 找到“World Wide Web Publishing Service
windows10下phpstudy 80端口被占用问题
先介绍一下phpstudy这款集成环境,想对来比较方便,内置环境切换比较多。(有'pache+php,nginx+php,iis+php) 个人比较喜欢使用,后来电脑升级到win10 之后一直出现端口占用情况,以楼主宁可装逼到死也不愿意接受装逼失败我结果,折腾了一个多小时终于搞定;   首先 先检查端口占用情况 开始–运行–cmd 进入命令提示符 输入netstat
Win10系统80端口被System占用如何解决
运行netstat -aon | findstr :80 ,发现pid是4的进程占用着80端口,这还是一个系统进程,kill不掉。所以只能另想办法: 1、打开注册表:regedit 2、找到:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\HTTP 3、在右边找到Start这一项,将其改为0 4、重启系统,Syste
Win10更新,自定义nginx 80端口被系统占用
当使用nginx联系前端和后台的时候,我给它配置文件中的端口是80,(因为浏览网页服务默认的端口号是80) 当我启动nginx输入start nginx命令后,弹框出现又消失后(正确执行),在任务管理器中却不见nginx。当我执行nginx操作的时候,出现如下错误提示 这属于最常见的错误。一般引起这个错误的主要原因是nginx不能处理特定pid的nginx进程。 通过查询nginx的
win7 win10下80端口被System进程占用的解决方法
用如下方法可以解决System进程占用80端口的问题: 打开RegEdit:开始-运行-输入regedit-调出注册表 找到HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP 找到一个DWORD值Start,将其改为0 重启电脑,System进程将不会占用80端口 就可以打开你的apache了 这种方法确实暂时解决
win10 系统和压缩内存占用80端口解决
以系统管理员身份运行 cmd  执行停止http 服务操作 net stop http 执行修改启动项操作 sc config http start=disabled
解决80端口被系统占用的问题
首先检查80端口被什么程序占用如: 打开附件-运行 输入cmd,回车 进入dos界面 输入命令:netstat -ano 回车 然后查看占用80端口的pid 发现占用80端口的是system 解决方案: 打开管理工具-服务 找到:World Wide Web Publishing Service 服务 停止就行了。 该服务win7下默认的是开机启动,更改为手动启动,有些人在这里就可以了