2 itnewself itnewself 于 2016.03.01 13:07 提问

Maven项目:project facet Dynamic Web Module to 2.5

![图片说明

![图片说明
按照网上提供的解决方法,问题并没有解决,还有别的方法么?

1个回答

caozhy
caozhy   Ds   Rxr 2016.03.07 05:43
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
maven+eclipse项目问题报错原因(Cannot change version of project facet Dynamic web module to 2.5)
http://blog.csdn.net/cai5/article/details/20553731 http://blog.csdn.net/steveguoshao/article/details/38414145 以上两篇文章资料较为详细的解决了这个问题,另外第一篇文章里还比较系统的讲解了eclipse加maven在使用过程中的大部分问题,这里仅供参考
解决maven项目上有红叉,Cannot change version of project facet Dynamic web module to 2.5
摘要 maven,红叉, Cannot change version of project facet Dynamic web 我们用Eclipse创建Maven结构的web项目的时候选择了Artifact Id为maven-artchetype-webapp,项目上会有一个红叉,打开目录会发现src和web里根本没有错误,而且程序还能正常执行,但是看着就是不爽,原因是由于这个cata
maven Cannot change version of project facet Dynamic Web Module to 2.5
有这么一个奇怪的错误,而且这个错误特别容易出现在maven 的web工程上面 就是maven web工程上面有红叉号,源文件目录上面也有红叉号,可是下面没有具体的错误。 但是eclipse的Marker栏目里面提示下面的错误信息, Cannot change version of project facet Dynamic Web Module to 2.5     上面这段英文报错的意思
Project facet Dynamic Web Module version 3.0 is not supported
背景:web项目无法部署到JBoss服务器上,出现“Project facet Dynamic Web Module version 3.0 is not supported”错误。        Web Module Version是什么意思?每次在创建一个web项目时,都会同时让你选择Web Module Version,            Dynamic web module ve
Cannot change version of project facet Dynamic Web Module to 2.5
在eclipse的工程上选择属性,再选择Project Facets里面中选择Dynamic Web Module ,将2.3修改为2.5,提示如下信息: Cannot change version of project facet Dynamic Web Module to 2.5 解决方法: 在工程目录下有一个.settings文件夹,打开org.eclipse.wst.comm
Cannot change version of project facet Dynamic web module to 2.5
在Eclipse中新建了一个web项目,但是项目上报错,有红色小叉叉,但是展开项目,子项目上并没有报错,单是这样看的话找不到错误在哪里。打开Markers窗口,提示pom.xml文件有错,但是无论怎么改都不起作用,这个问题让人很无语,知道有错,但却不知道该怎么改。不过,在伟大的江江同学的帮助下,最后终于解决了。 原来是这样的:我们用Eclipse创建Maven结构的web项目的时候选择了Arti
解决Eclipse建Maven项目Dynamic web Module无法转换为2.5
Maven项目在Project Facets里面修改Dynamic web module为2.5的时候就会出现Cannot change version of project facet Dynamic web module to 2.5     下面提供一种解决方式   1    window  -->  show view  --> Navigator  打开   
项目提示 Cannot change version of project facet Dynamic Web Module to 2.5 错误
一、问题描述 使用Maven新建Web项目时使用的是Artifact Id为maven-artchetype-webapp,由于这个catalog比较老,用的servlet还是2.3的,而一般现在至少都是2.5,在Project Facets里面修改Dynamic web module为3.0的时候就会出现Cannot change version of project facet Dy
解决MyEclipse10里project facet Dynamic web module to不能选择 2.5或3.0的问题
我们用Eclipse创建Maven结构的web项目的时候选择了Artifact Id为maven-artchetype-webapp,由于这个catalog比较老,用的servlet还是2.3的,而一般现在至少都是2.5,在Project Facets里面修改Dynamic web module为2.5的时候就会出现Cannot change version of project facet Dy
解决Cannot change version of project facet Dynamic web module to 2.5
一般我们用Eclipse创建Maven项目的时候