嚜寒 2016-03-01 12:31 采纳率: 100%
浏览 1897
已采纳

acm水题 二叉树模拟 hdu5444,能想到的测试数据都测了还是WA,求大神

1)我的代码(题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=5444,也有复制内容在代码下面)

 #include <iostream>
#include <string.h>
using namespace std;
const int maxn=1010;
char record[maxn];
int sum=0;
struct tree{
    int left;
    int right;
}tree_1[maxn];
void build_tree(int root,int num)
{
    if(root>num&&!tree_1[root].right){
        tree_1[root].right=num;
    }
    if(root<num&&!tree_1[root].left){
        tree_1[root].left=num;
    }
    if(root>num){
        build_tree(tree_1[root].right,num);
    }
    if(root<num){
        build_tree(tree_1[root].left,num);
    }
}
void dfs_tree(int root,int num)
{

    if(num==root&&!sum){
        sum=1;
        return ;
    }
    if(num<root&&tree_1[root].right){
        record[sum++]='E';
        dfs_tree(tree_1[root].right,num);
    }
    else if(num>root&&tree_1[root].left){
        record[sum++]='W';
        dfs_tree(tree_1[root].left,num);
    }
}
int main()
{
    int kase;cin>>kase;
    while(kase--){
        int n;cin>>n;
        int root;cin>>root;
        n--;
        while(n--){
            int room_num;cin>>room_num;
            build_tree(root,room_num);
        }


        int m;cin>>m;
        record[0]='\0';
        while(m--){
            int bk_num;cin>>bk_num;
            dfs_tree(root,bk_num);
            for(int i=0;i<sum;i++){
                cout<<record[i];
            }
            cout<<endl;
            memset(record,0,sizeof(record));
            record[0]='\0';
            sum=0;
        }
        memset(tree_1,0,sizeof(tree_1));

    }
}

2)
Problem Description
Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.

Input
First you are given an integer T(T≤10) indicating the number of test cases.

For each test case, there is a number n(n≤1000) on a line representing the number of rooms in this tree. n integers representing the sequence written at the root follow, respectively a1,...,an where a1,...,an∈{1,...,n}.

On the next line, there is a number q representing the number of mails to be sent. After that, there will be q integers x1,...,xq indicating the destination room number of each mail.

Output
For each query, output a sequence of move (E or W) the postman needs to make to deliver the mail. For that E means that the postman should move up the eastern branch and W the western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.

Sample Input
2
4
2 1 4 3
3
1 2 3
6
6 5 4 3 2 1
1
1

Sample Output
E

WE
EEEEE

  • 写回答

2条回答

  • u52983610 2016-03-02 02:21
    关注

    ac了,在最后那里的for循环中加了一个if,如果record[0]=='\0'的话不输出直接break,不然输出的不是空行,是‘a’

     #include <iostream>
    #include <string.h>
    using namespace std;
    const int maxn=1010;
    char record[maxn];
    int sum=0;
    struct tree{
        int left;
        int right;
    }tree_1[maxn];
    void build_tree(int root,int num)
    {
        if(root>num&&!tree_1[root].right){
            tree_1[root].right=num;
        }
        if(root<num&&!tree_1[root].left){
            tree_1[root].left=num;
        }
        if(root>num){
            build_tree(tree_1[root].right,num);
        }
        if(root<num){
            build_tree(tree_1[root].left,num);
        }
    }
    void dfs_tree(int root,int num)
    {
    
        if(num==root&&!sum){
            sum=1;
            return ;
        }
        if(num<root&&tree_1[root].right){
            record[sum++]='E';
            dfs_tree(tree_1[root].right,num);
        }
        else if(num>root&&tree_1[root].left){
            record[sum++]='W';
            dfs_tree(tree_1[root].left,num);
        }
    }
    int main()
    {
        int kase;cin>>kase;
        while(kase--){
            int n;cin>>n;
            int root;cin>>root;
            n--;
            while(n--){
                int room_num;cin>>room_num;
                build_tree(root,room_num);
            }
    
    
            int m;cin>>m;
            record[0]='\0';
            while(m--){
                int bk_num;cin>>bk_num;
                dfs_tree(root,bk_num);
                for(int i=0;i<sum;i++){
                    if(record[0]=='\0'){
                        break;
                    }
                    cout<<record[i];
                }
                cout<<endl;
                memset(record,0,sizeof(record));
                record[0]='\0';
                sum=0;
            }
            memset(tree_1,0,sizeof(tree_1));
    
        }
    }
    
    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

悬赏问题

  • ¥15 如何实现H5在QQ平台上的二次分享卡片效果?
  • ¥15 python爬取bilibili校园招聘网站
  • ¥30 求解达问题(有红包)
  • ¥15 请解包一个pak文件
  • ¥15 不同系统编译兼容问题
  • ¥100 三相直流充电模块对数字电源芯片在物理上它必须具备哪些功能和性能?
  • ¥30 数字电源对DSP芯片的具体要求
  • ¥20 antv g6 折线边如何变为钝角
  • ¥30 如何在Matlab或Python中 设置饼图的高度
  • ¥15 nginx中的CORS策略应该如何配置