2 neil1225 neil1225 于 2016.03.05 10:05 提问

eclipse导入项目中文出现了乱码!

打开工作空间发现编码是utf-8,为什么还是出现中文乱码呀!求告诉原因呀!

3个回答

zoujun826915
zoujun826915   2016.03.05 11:21

一楼说的对,不是调到utf-8就不出现乱码,而是要看你本身的项目是什么编码格式,然后导入项目的时候设置成对应的编码格式就好了

qijian0503
qijian0503   2016.03.05 10:08

并不是说 用的是UTF-8 就不会出现乱码问题,而是要调整到建项目时,用的编码类型。

wojiushiwo945you
wojiushiwo945you   Ds   Rxr 2016.03.05 10:11

说明原来的编码方式是gbk的,修改工作空间的编码为中文编码试试。window-preferrence-workspace选项修改编码。

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
Eclipse 导入项目乱码问题(中文乱码)
1.修改项目编码格式:  鼠标移到项目名,右键->Properties->Resource->Text file enCoding ->更改编码(GBK、UTF-8等)->Apply->OK>退出2.修改整个Eclipse工作空间的编码   Window->Preferences->General->Workspace->text ...
eclipse导入项目出现中文乱码解决方案
1、最傻瓜的方案 适用于工程特别小的情况,手动拷贝代码。 2、修改编码格式 preferences->workspace->text file encoding->选择utf-8 3、修改编码字符 preferences->content type->text 自己手动写入utf-8
eclipse导入工程后出现中文乱码
eclipse之所以会出现乱码问题是因为eclipse编辑器选择的编码规则是可变的。一般默认都是UTF-8或者GBK,当从外部导入的一个工程时,如果该工程的编码方式与eclipse中设置的编码方式不同,就会产生中文的乱码问题,这其中还有几种情况。 如果导入的整个工程的编码方式与eclipse的编码方式有冲突,那么这个工程里所有的中文 都是乱码;如果所有工程的编码方式与eclipse工作空间的
Eclipse导入工程中文乱码问题
使用eclipse导入项目时候有时候会出现中文注释乱码的现象,如图所示: 在这种情况下我们可以使用如下方法: 1.在工程名上右击 -> Properties -> Resource,如果Text files encoding改为UTF-8时出现乱码,那就将其改为GBK,否则反之 。
JAVA导入新项目代码中有乱码的解决办法
在网上找了一些解决办法,大部分为: 1.在项目上右键properties,选择Resource,更改Text file encoding   设置(bgk或者utf-8  等...) 2.在IDE(Eclipse),选择Window--->preferences---->General---->Workspace----找到Text file encoding  设置 编码格式 3.(我使用
解决eclipse中导入项目中文乱码的问题
在平时开发的过程中,导入别人的项目学习或者二次开发的经历相信大家都有,但是导入项目之后出现中文乱码的问题相信也困扰了不少人,当里面内容少的时候还可以通过复制粘贴解决,但项目内容多的时候就头痛了。         教大家一个间的快捷的方法       首先导入的文件成为了乱码是因为workspace的编码方式不对,linux下默认编码是UTF-8,windows的是GBK, 那么怎
eclipse中java项目中文注释乱码
在使用eclipse编辑java时,导入项目时会出现中文注释乱码 解决方法: windows–preferences–General–Content Types–text–java source file 将default encoding改为GBK,点击update即可但是有时候把导入项目解决了,会发现原有已存在的项目出现乱码问题 这时需要检查该项目是不是默认编码为GBK 右击项
NetBeans导入别人的项目中文乱码解决
在NetBeans导入别人的项目的时候发生了这个错误。 别人的项目是英文的,我把其中的英文改成中文之后就出现这个问题了。 处理办法: 1、修改文档编码 项目右键选择属性,在“源”里面有个编码,请选择合适的编码,中文建议GBK。 2、修改编译编码 项目右键选择属性,在“生成”-》“编译”里面的其它编译器选项中加上:-encoding gbk 设置好这两个了之后,就OK了。
Eclipse导入的项目中的中文都是乱码,如何解决?
把项目导入Eclipse时,里边的中文全是乱码,试了很多方法,最终总结一下! eclipse之所以会出现乱码问题是因为eclipse编辑器选择的编码规则是可变的。一般默认都是UTF-8或者GBK,当从外部导入的一个工程时,如果该工程的编码方式与eclipse中设置的编码方式不同,就会产生中文的乱码问题,这其中还有几种情况。   对于eclipse工作空间 ,eclipse会把你改的设置保存在
引入项目中文乱码???明明是utf-8
1、我们引入项目到eclipse中(android studio我没碰到,但是原理是一样的),只是中文是乱码的,然后很操蛋,只能用一些文本工具进行查看注解。。。。而你的编译环境明明又是utf-8,全部都是utf-8,为什么不可以?? 因为,他妈的别人有可能编译的时候是gbk,知道么???你被别人坑了。。。修改方法是:Window-->preference----> general---