明知道这是一场意外 2016-03-31 10:31 采纳率: 66.7%
浏览 972
已结题

关于ACM中遇到的一些怪问题求解 Uva 227-Puzzle

A children’s puzzle that was popular 30 years ago consisted of a 5×5 frame which contained 24 small
squares of equal size. A unique letter of the alphabet was printed on each small square. Since there
were only 24 squares within the frame, the frame also contained an empty position which was the same
size as a small square. A square could be moved into that empty position if it were immediately to the
right, to the left, above, or below the empty position. The object of the puzzle was to slide squares
into the empty position so that the frame displayed the letters in alphabetical order.
The illustration below represents a puzzle in its original configuration and in its configuration after
the following sequence of 6 moves:
1) The square above the empty position moves.
2) The square to the right of the empty position moves.
3) The square to the right of the empty position moves.
4) The square below the empty position moves.
5) The square below the empty position moves.
6) The square to the left of the empty position moves.
Write a program to display resulting frames given their initial configurations and sequences of moves.
Input
Input for your program consists of several puzzles. Each is described by its initial configuration and
the sequence of moves on the puzzle. The first 5 lines of each puzzle description are the starting
configuration. Subsequent lines give the sequence of moves.
The first line of the frame display corresponds to the top line of squares in the puzzle. The other
lines follow in order. The empty position in a frame is indicated by a blank. Each display line contains
exactly 5 characters, beginning with the character on the leftmost square (or a blank if the leftmost
square is actually the empty frame position). The display lines will correspond to a legitimate puzzle.
The sequence of moves is represented by a sequence of As, Bs, Rs, and Ls to denote which square
moves into the empty position. A denotes that the square above the empty position moves; B denotes
that the square below the empty position moves; L denotes that the square to the left of the empty
position moves; R denotes that the square to the right of the empty position moves. It is possible that
there is an illegal move, even when it is represented by one of the 4 move characters. If an illegal move
occurs, the puzzle is considered to have no final configuration. This sequence of moves may be spread
over several lines, but it always ends in the digit 0. The end of data is denoted by the character Z.
Output
Output for each puzzle begins with an appropriately labeled number (Puzzle #1, Puzzle #2, etc.). If
the puzzle has no final configuration, then a message to that effect should follow. Otherwise that final
configuration should be displayed.
Format each line for a final configuration so that there is a single blank character between two
adjacent letters. Treat the empty square the same as a letter. For example, if the blank is an interior
position, then it will appear as a sequence of 3 blanks — one to separate it from the square to the left,
one for the empty position itself, and one to separate it from the square to the right.
Separate output from different puzzle records by one blank line.
Note: The first record of the sample input corresponds to the puzzle illustrated above.
Sample Input
TRGSJ
XDOKI
M VLN
WPABE
UQHCF
ARRBBL0
ABCDE
FGHIJ
KLMNO
PQRS
TUVWX
AAA
LLLL0
ABCDE
FGHIJ
KLMNO
PQRS
TUVWX
AAAAABBRRRLL0
Z
Sample Output
Puzzle #1:
T R G S J
X O K L I
M D V B N
W P A E
U Q H C F
Puzzle #2:
A B C D
F G H I E
K L M N J
P Q R S O
T U V W X
Puzzle #3:
This puzzle has no final configuration.

以下是我的代码,已AC,但不知道为什么在code:blocks里总是无法正常结束,复制标准输入再到dos界面右键后最后还是有提示输入的光标,enter后才能正常结束。。。。不过中午的时候意外又可以正常结束,现在我优化了以下代码不知道为什么又不行了,跪求各位巨巨解答囧

#include <stdio.h>
#include <string.h>
#include <ctype.h>
//2.#include<stdlib.h>
char str[100];
int main()
{
//    freopen("C:\\Users\\Aliez\\Desktop\\input.txt","r",stdin);
//    freopen("C:\\Users\\Aliez\\Desktop\\output.txt","w",stdout);
    char puz[5][5],temp;
    int ch,c,len,m,n,T = 0,real,k;
    while(1){
        real = 1;
        k = 0;
        memset(str,'\0',sizeof(str));
        memset(puz,' ',sizeof(puz));
        for(int i = 0;i < 5;i++){
            gets(puz[i]);
            if(puz[0][0] == 'Z')
                return 0;
                //1.break;
                //2.exit(0);
            if(puz[i][4] == '\0')
                puz[i][4] = ' ';
        }
        /*1.if(puz[0][0] == 'Z')
            break;*/
        for(int i = 0;i < 5;i++){
            for(int j = 0;j < 5;j++){
                if(puz[i][j] == ' '){
                    m = i;
                    n = j;
                }
            }
        }

        while((c = getchar())!='0'){
            if(!isspace(c))
                str[k++] = c;
        }
        while(1){
            c = getchar();
            if(isspace(c))
                break;
        }
        //以下注释部分为测试代码
//        puts(puz[0]);
//        puts(str);
//        printf("m=%d,n=%d\n",m,n);
        len = strlen(str);
        int x = m, y = n;
        for(int i = 0; i < len;i++){
            switch(str[i])
            {
                case 'A':
                        x--;
                    break;
                case 'B':
                        x++;
                    break;
                case 'L':
                        y--;
                    break;
                case 'R':
                        y++;
                    break;
                default:
                    real = 0;
                    break;
            }
            if(x < 0||x >4||y < 0||y > 4){
                real = 0;
                break;
            }
            else{
                puz[m][n] = puz[x][y];
                puz[x][y] = ' ';
                m = x;
                n = y;
            }
        }
        if(T++)
            printf("\n");
        printf("Puzzle #%d:\n",T);

        if(real){
            for(int i = 0;i < 5;i++){
                printf("%c",puz[i][0]);
                for(int j = 1;j < 5;j++)
                    printf(" %c",puz[i][j]);
                printf("\n");
            }
        }
        else
            printf("This puzzle has no final configuration.\n");
    }
    return 0;
}


下图是enter之前
图片说明

下图是enter之后
图片说明

  • 写回答

0条回答

    报告相同问题?

    悬赏问题

    • ¥15 执行 virtuoso 命令后,界面没有,cadence 启动不起来
    • ¥50 comfyui下连接animatediff节点生成视频质量非常差的原因
    • ¥20 有关区间dp的问题求解
    • ¥15 多电路系统共用电源的串扰问题
    • ¥15 slam rangenet++配置
    • ¥15 有没有研究水声通信方面的帮我改俩matlab代码
    • ¥15 ubuntu子系统密码忘记
    • ¥15 保护模式-系统加载-段寄存器
    • ¥15 电脑桌面设定一个区域禁止鼠标操作
    • ¥15 求NPF226060磁芯的详细资料