2 lax 2016 lax_2016 于 2016.04.06 17:11 提问

Springmvc项目运行出错

org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'baseDaoImpl': Injection of resource dependencies failed; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'util' defined in file [D:\360安全浏览器下载\apache-tomcat-7.0.52-windows-x64\apache-tomcat-7.0.52\webapps\student\WEB-INF\classes\com\springTest\util\DBUtil.class]: Initialization of bean failed; nested exception is org.springframework.beans.ConversionNotSupportedException: Failed to convert property value of type 'org.springframework.jdbc.core.simple.SimpleJdbcTemplate' to required type 'javax.sql.DataSource' for property 'simpleJdbcTemplate'; nested exception is java.lang.IllegalStateException: Cannot convert value of type [org.springframework.jdbc.core.simple.SimpleJdbcTemplate] to required type [javax.sql.DataSource] for property 'simpleJdbcTemplate': no matching editors or conversion strategy found

2个回答

caozhy
caozhy   Ds   Rxr 2016.04.06 17:15

电脑不幸感染了360了,建议先重装下吧。

CSDNXIAOD
CSDNXIAOD   2016.04.06 17:21

在android项目中运行普通的java程序出错!
----------------------biu~biu~biu~~~在下问答机器人小D,这是我依靠自己的聪明才智给出的答案,如果不正确,你来咬我啊!

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
eclipse搭建Springmvc工程中容易出现的几个错误
版本: eclipse lunna,java 1.7,Spring 4.1.4,tomcat 7.0.70 问题1:出现(missing)的问题只需将器删除并且重新添加即可 勾选和点击add folder效果如下 问题二:搭建的工程默认的java版本是1.5,要修改java版本可以直接在buildpath里面edit,随后在project facets里面修改java版本
idea 部署springMVC maven项目到tomcat出错, java.lang.ClassNotFoundException:处理
IDEA 部署springMVC maven项目到tomcat出错java.lang.ClassNotFoundException异常处理 最近自己下班搭建springMVC项目,用的maven管理,项目依赖的jar都在dependencies正确配置了, 但是部署项目war到tomcat,启动运行报错:java.lang.ClassNotFoundException:org.apache.c
导入SpringMVC项目报错
报错:HttpServletRequest cannot be resolved to a type 翻译:HttpServletRequest不能解决一个类型 解决: 项目名--> 右键  Property--> 选择  Java Build Path--> 选择  Add External JARs--> 选择
SpringMVC项目 JDK编译版本错误
SpringMVC项目 JDK编译版本问题 说明项目编译的JDK版本过低 处理:右击错误,选择Quick Fix 切换成1.8就行
SpingMVC项目导入jar包运行报错,编译不报错的解决方式
在springmvc的web项目中,使用到了导出pdf的iText的jar包,一开始整个工程是使用meaven来管理jar包,但发现在pom.xm配置使用iText,myeclipse就一直卡在54%,无奈尝试这以前直接在src的目录下新建一个lib包,然后复制jar包到里面,选择右键添加到工程里面,这时候,的确工程没有报错,但是一运行,使用到导出pdf的类时,总会报如下的错误:
IDEA搭建springMVC项目时出现的错误汇总
适用对象:初涉IDEA+springMVC 1、Tomcat启动成功,但是打开的所有页面都是404 原因:Tomcat配置出错Deployment中配置了Exter.. 解决:1、Tomcat小窗口选择Edit Configurations→左上角绿色“+”→Tomcat/local 按照你的配置配置好server的基本信息,此时左侧猫头上有个小红叉且此栏底部有Warning
配置文件springmvc.xml或spring.xml 能运行但总是出现错误
1:在java开发时总遇到配置文件配置正确,可以运行但有时显示错误。例如下图 上面配置文件正确但有时显错就不能运行。原因是配置文件的约束项错了。 原因是自己的jar包和配置文件版本不同。如果电脑联网它会找网络上的对应jar版本。但是网络慢...就报错了。 解决方法: 我用的是maven在pom.xml配置(自己导jar原理一样)。如下图 之后m
springmvc运行后是一个空白页面,后台不报错
是因为没有访问到controller
Spring MVC入门之构建到运行,超详细(利用Maven构建)项目代码
个人博客《Spring MVC入门之构建到运行,超详细(利用Maven构建)》的项目代码
SpringMVC处理器映射问题( 错误:包含了项目名 )
在看视频学习SpringMVC的时候,自己用XML配置 或者使用注解配置的Controller( Handler ),一直找不到该处理器的映射地址,其他配置都是对的,控制台显示的错误是找不到该映射地址,项目名SpringMVC1都包括进去了。百思不得其解! 最后把项目的配置打开,发现引用的jar包有问题,竟然还包含中文,于是在配置项目中把所有的jar包和library给删