DoubleE_cz 2016-09-06 10:41 采纳率: 75%
浏览 892
已采纳

也不知道那位大神能帮我解决一下,关于易语言的,我今天也是刚弄。

我没有币了所以没法悬赏了

 .版本 2
.支持库 iext

.子程序 _按钮2_被单击
.局部变量 表项, 整数型
.局部变量 计数, 整数型

打开 (“F:\学习文件夹\E\会员表.edb”, , , , , , )
信息框 (“数据库启动”, 0, , )

.计次循环首 (取记录数 (), 计数)
    跳过 (计数)
    表项 = 超级列表框1.插入表项 (, , , , , )
    超级列表框1.置标题 (表项, 0, 读 (“姓名”))
    超级列表框1.置标题 (表项, 1, 读 (“密码”))
.计次循环尾 ()

.子程序 _窗口2_创建完毕

超级列表框1.插入列 (, “姓名”, 80, , , )
超级列表框1.插入列 (, “密码”, 80, , , )

上面是代码

下面是运行结果

图片说明

#在下面是数据库

图片说明

为什么在超级列表框中只显示1条记录

  • 写回答

2条回答 默认 最新

  • threenewbee 2016-09-06 16:10
    关注

    http://blog.sina.com.cn/s/blog_6a5cddf60102vopd.html
    你缺少 记录集.到下一条 ()

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

悬赏问题

  • ¥50 可视化界面构建,实现信息模块功能
  • ¥15 基于bert-base-chinese的中文文本处理
  • ¥15 高价求抖音抓包技术,抖音抓包无网络问题
  • ¥15 【matlab】已知功率谱密度反求时域信号
  • ¥15 mindspore项目_模型适配
  • ¥15 openstack使用cinder后,实例运行时分配的总空间不能大于ceph的总空间
  • ¥15 [pcl::PLYWriter::writeASCII] Error during opening (?鶂?)!
  • ¥15 得到XY两轴的数据如何绘制成圆,输入整形器
  • ¥29 PHP读取PDF文件添加多个数字签名
  • ¥25 联邦学习vgg修改最后一个全连接层报错(默认是1000个输出,我的改为11就报错,改为200就没问题)