mao20162016
mao20162016
2016-12-19 04:04

易语言转换到C++ 自定义数据类型的问题

3
  • c++

易语言中代码

自定义数据类型如下

.版本 2

.数据类型 数据
    .成员 坐标, 坐标_数据类型

.数据类型 坐标_数据类型
    .成员 x, 小数型
    .成员 z, 小数型
    .成员 y, 小数型

这里的自定义数据类型下的"数据"类型下的"坐标"成员引用自定义数据类型"坐标_数据类型"

子程序如下

 .版本 2

.子程序 自己数据
.参数 返回数据, 数据, 参考

返回数据.坐标.x = 1
返回数据.坐标.z = 2
返回数据.坐标.y = 3

这里的子程序内的参数"返回数据"定义了个自定义数据类型"数据"

C++代码如下

 struct 数据
{
    坐标_数据类型 坐标;
};
struct 坐标_数据类型
{
    float x;
    float z;
    float y;
};

C++编译就提示如下
error C2146: 语法错误: 缺少“;”(在标识符“坐标”的前面)
error C4430: 缺少类型说明符 - 假定为 int。注意: C++ 不支持默认 int

请问高手们,该如何转换呢。本人菜鸟 懂的不多 嘿嘿!

  • 点赞
  • 回答
  • 收藏
  • 复制链接分享

1条回答