u014254538
Ckai~老西儿
采纳率0%
2017-03-01 06:41

Eclipse下利用Fragment+ViewPage实现底部导航菜单

背景:
SDK24.4.1+ADT23.0.6;已成功导入android-support-v7-appcompat包和android-support-v4包
已在order和export下勾选了这两个包。
问题:
编译时不报错,运行时报错:Could not find class 'android.support.v7.app.AppCompatDelegateImplV11', referenced from method android.support.v7.app.AppCompatDelegate.create。
如何解决?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

3条回答

  • qq_27969037 Mr康 4年前

    应该是你的v7和v4不兼容

    点赞 评论 复制链接分享
  • oSanYeCao1234567 RoidCoder 4年前

    android-support-v7-appcompat包下没有 AppCompatDelegate这个类,v7貌似有很多版本的,不同的版本包含的代码不同

    点赞 评论 复制链接分享
  • dongfeng9ge 东风玖哥 4年前

    不要用eclipse

    点赞 评论 复制链接分享

相关推荐