Eclipse 创建项目文件报错 R.

图片说明
新开的一门课程,想自己装eclipse用,但是遇到好多问题,虽然查了好多解决了,但是这个一直没解决,就是创建新项目时会出现R.的报错,也不知道为什么,提示英文也看不懂,希望大神帮忙解决一下

6个回答

都是报的资源找不到,你看下xml哪些地方报错

sinat_38874420
一紙线稿 是有一个xml文件错误,我查了,说是因为版本更新问题,原来在drawable里的文件现在在mipmap里面了,改一下就行,现在的问题是每次创建都需要去改,虽然无所谓,但还是希望有解决办法
2 年多之前 回复

xml文件有错,没有生成项目自己的.R资源文件索引吧

sinat_38874420
一紙线稿 不清楚,怎么解决啊?
2 年多之前 回复

看你的报错连mainifest都有错

sinat_38874420
一紙线稿 我查了一下,有一个XML文件的android:icon="@drawable/ic_launcher"报错,改成android:icon="@drawable/ic_launcher"就没错了,但是每次新建都要这么改很麻烦,求大神帮我看看怎么能解决根本问题。。。
2 年多之前 回复
sinat_38874420
一紙线稿 不知道啊。。。前几天刚装的软件,今天下载了一天的SDK,该下的都下了,软件不懂,老师就教了NEW->App Project->然后就是写代码,其他的都一带而过了TAT
2 年多之前 回复

可能是你的sdk版本问题,提示说@style/Theme.AppCompat没有,这个是support v7包下的,你看看你的sdk中有没有support v7包

sinat_38874420
一紙线稿 extras里面的都下载了
2 年多之前 回复
sinat_38874420
一紙线稿 我用都是SDK manager下的,是不是那个extras
2 年多之前 回复

clean一下项目,再不行就删除bulid文件下的所有文件,重新clean。。如果还是没有R文件,就是你的ADT插件版本问题,换一个版本,版本要根据你eclipse对应的。

sinat_38874420
一紙线稿 好像是版本问题,有一个xml文件报错,android:icon="@drawable/ic_launcher"改成android:icon="@drawable/ic_launcher"就行了
2 年多之前 回复

你如果每次创建都会出这样的情况的话,那你最好重新下sdk 重新指定位置。

sinat_38874420
一紙线稿 好吧
2 年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问