ubuntu python版本问题

安装ubuntu12自带python2.7,由于安装其他软件需要python2.6,但是后来安装openstack和python2.6产生包依赖问题,于是把2.6相关的文件都删除了,重装了python2.7。之后仍提示depends on python (>= 2.7.1-0ubuntu2); however: Version of python on system is 2.6.5-0ubuntu1。之后运行sudo apt-get -f install修复后,然后安装openstack又出现python Package python is not installed。 求大神解救 !!!!!

4个回答

系统用自带的2.7,然后2.6安装到其他目录,需要用2.6的用对应2.6目录下的

会不会是环境变量的问题?或者是将版本信息写入了配置文件?

使用virtualenv创建虚拟目录,随便你使用那个版本的python

直接下载anaconda,包含各种最新的库,和系统python 版本完全隔离

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问