qq_40197058
qq_40197058
2017-09-12 09:52
采纳率: 50%
浏览 4.7k
已采纳

Kettle建立资源库出现错误(SQL数据库,测试成功)

org.pentaho.di.core.exception.KettleException:
Error connecting to the repository!

The version of the repository is -1.-1.
This Kettle edition requires it to be at least version 5.0 and as such an upgrade is required.

To upgrade, backup your database and export the repository to XML for additional safety.

Then select the 'Edit' button followed by the 'Create or Upgrade' button.

Please consult the Upgrade Guide for eventually special instructions for this version.

at org.pentaho.di.repository.kdr.delegates.KettleDatabaseRepositoryConnectionDelegate.connect(KettleDatabaseRepositoryConnectionDelegate.java:160)
at org.pentaho.di.repository.kdr.KettleDatabaseRepository.connect(KettleDatabaseRepository.java:191)
at org.pentaho.di.repository.kdr.KettleDatabaseRepository.connect(KettleDatabaseRepository.java:180)
at org.pentaho.di.ui.repository.RepositoriesHelper.loginToRepository(RepositoriesHelper.java:269)
at org.pentaho.di.ui.repository.controllers.RepositoriesController$3.run(RepositoriesController.java:218)
at java.lang.Thread.run(Thread.java:745)

Caused by: org.pentaho.di.core.exception.KettleException:

The version of the repository is -1.-1.
This Kettle edition requires it to be at least version 5.0 and as such an upgrade is required.

To upgrade, backup your database and export the repository to XML for additional safety.

Then select the 'Edit' button followed by the 'Create or Upgrade' button.

Please consult the Upgrade Guide for eventually special instructions for this version.

at org.pentaho.di.repository.kdr.delegates.KettleDatabaseRepositoryConnectionDelegate.verifyVersion(KettleDatabaseRepositoryConnectionDelegate.java:219)
at org.pentaho.di.repository.kdr.delegates.KettleDatabaseRepositoryConnectionDelegate.connect(KettleDatabaseRepositoryConnectionDelegate.java:146)
... 5 more
  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

相关推荐