cnchenghm
2017-11-07 07:39
采纳率: 0%
浏览 1.7k

求救:Linux 出现segmentation fault 问题怎么解决

OpenSUSE 11原来安装的glibc-2.11,下载了glibc-2.14. 编译安装,
然后执行了 ln -sf /usr/local/glibc-2.14/lib/libc-2.14.so /lib64/libc.so.6
就出现segmentation fault ,任何操作都无法执行,求救解决方法

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

4条回答 默认 最新

  • threenewbee 2017-11-07 14:42

    你的系统是64位的么,下载的库和系统版本是否一致?

    打赏 评论
  • 重名的atools 2021-02-25 14:17

    同样问题。。。。

    LD_PRELOAD=/lib64/libselinux.so.1:/lib64/libtermcap.so.2:/lib64/libacl.so.1:/lib64/libc.so.6:/lib64/libdl.so.2:/lib64/libsepol.so.1:/lib64/libattr.so.1 more /etc/ld.so.conf

    打赏 评论
  • C&JJ 2021-03-11 16:04

    解决了没有呀。我也是。

    打赏 评论
  • Quartz010 2017-11-14 08:02

    看一下 库的头

    readelf -h
    

    一下

    1 打赏 评论

相关推荐 更多相似问题