u011732393
若水三千丈
采纳率17.6%
2018-01-05 06:43 阅读 1.4k
已采纳

Myeclipse,tomcat的部署问题

5

为什么我明明要部署的是xwq项目,而下面部署的路径显示的却是C:\Program Files (x86)\Apache Software Foundation\Tomcat 7.0\webapps\MyLibrary

而不是C:\Program Files (x86)\Apache Software Foundation\Tomcat 7\xwq

能部署成功,最后输入http://localhost:8080/MyLibrary/这样可以跳转
而http://localhost:8080/xwq/ 却不能跳转 ( 如下图所示)

求解决方法!!!!!!!!!!

![图片说明](https://img-ask.csdn.net/upload/201801/05/1515134423_529887.png)图片说明

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

14条回答 默认 最新

  • 已采纳
    sqbzo sqbzo 2018-01-05 07:32

    myeclipse中使用tomcat部署web应用时候,如何修改为部署路径;

    两个问题要,工程构建方式,maven方式构建(这里说的maven构建,是通过MyEclipse进行构建,不是通过mvn命令构建war类型应用),还是通过myeclipse工具构建;

    确认web应用构建是通过MyEclipse工具构建就方好处理;
    处理办法:
    1 鼠标左键选择你当前工程,使用快捷Alt+Enter图片说明
    2 选择选择Myeclispe-->Web图片说明

    点赞 1 评论 复制链接分享
  • wangjin9805 wangjin9805 2018-01-05 06:52

    应该是项目改过名,改的不彻底 看看项目属性 web的配置

    点赞 1 评论 复制链接分享
  • bokewangyu bokewangyu 2018-01-05 06:53

    你打出来的war 名是MyLibrary,tomcat根据war名访问项目的,你重新命名下,在放到webapp目录下,重启tomcat即可。

    点赞 1 评论 复制链接分享
  • HOORIYE 雨声咚咚 2018-01-05 06:52

    包名构建后的最终名称是什么,截下代码 这样光给现象不好猜

    点赞 评论 复制链接分享
  • lyfmocun 李小小狼 2018-01-05 07:07

    应该是项目改过名字,重新配置一下吧

    点赞 评论 复制链接分享
  • sj18182656342 黄河默默 2018-01-05 07:20

    部署项目的名字改一下就好了

    点赞 评论 复制链接分享
  • qq_33322121 努力VS幸福 2018-01-05 07:25

    您是修改项目名称了,你可以选中你的项目名称,
    第一种:点击鼠标右键选择properties → 搜索web → 修改 Web Context - root 后面的参数改为你的项目名称 → 再点击 OK ,重新编译项目即可;
    第二种:点击鼠标右键选择properties → MyEclipse → Project Facets → Web → 修改 Web Context - root 后面的参数改为你的项目名称 → 点击 OK ,重新编译项目即可

    点赞 评论 复制链接分享
  • nn3027275 nn3027275 2018-01-05 07:25

    赶紧换idea吧 换过的都说好

    点赞 评论 复制链接分享
  • meng20166 乐古 2018-01-05 07:54

    选中你的项目名称,
    第一种:点击鼠标右键选择properties → 搜索web → 修改 Web Context - root 后面的参数改为你的项目名称 → 再点击 OK ,重新编译项目即可;
    第二种:点击鼠标右键选择properties → MyEclipse → Project Facets → Web → 修改 Web Context - root 后面的参数改为你的项目名称 → 点击 OK ,重新编译项目即可

    点赞 评论 复制链接分享
  • qq_41224644 菜鸟灬筱伟 2018-01-05 08:21

    点击鼠标右键选择properties → MyEclipse → Project Facets → Web → 修改 Web Context - root 后面的参数改为你的项目名称 → 点击 OK ,重新编译项目即可

    点赞 评论 复制链接分享
  • loowooowool loowooowool 2018-01-05 08:26

    不知道你是用编译器部署的还是打好war包手动部署的,总之改一下名字就可以了

    点赞 评论 复制链接分享
  • qq_37002134 小白,先生 2018-01-05 10:06

    一般这种情况,很有可能就是因为你的代码是复制别人的,这种情况在项目中很常见
    解决方法:
    选中你的项目,点击鼠标右键选择properties → 搜索web → 修改 Web Context - root 后面的参数改为你的项目名称 → 再点击 OK ,重新编译项目即可;

    点赞 评论 复制链接分享
  • Mr_Liu0710 Mr_Liu0710 2018-01-05 10:41

    项目右键Properties
    Web Project Setting - Content root: 改名即可

    点赞 评论 复制链接分享
  • qq_40946611 啊柳 2018-01-06 01:49

    应该是你改过自己项目名字的原因

    点赞 评论 复制链接分享

相关推荐