James_201512
James_201512
采纳率80%
2018-01-08 06:20 阅读 2.2k

AndroidStudio无法启动Gradle守护进程

160

图片说明图片说明

1.删除文件夹c:\users{username}.gradle然后重启Android Studiao,更新gradle。
2.打开工程的gradle.properties文件,添加如下配置项org.gradle.jvmargs=-Xmx512m -XX:MaxPermSize=512m

这两种方法都试过,studio我都重装过,还是一打开项目就报错(项目没问题,因为新建一个项目也报这种错),studio版本是3.0的 ,有没有遇到这种问题并解决的高手啊

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

12条回答 默认 最新

  • 已采纳
    NakajimaFN ErwinNakajima 2018-01-30 03:46

    android studio3.0以上版本,Project中的build.gradle文件对应的 classpath 'com.android.tools.build:gradle:3.0.0',项目的gradle文件夹--wrapper文件夹--gradle-wrapper.properties文件对应的distributionUrl=https://services.gradle.org/distributions/gradle-4.1-all.zip

    点赞 评论 复制链接分享
  • qq_37043246 路边小树苗 2018-01-11 09:10

    我记得我好想碰到过你这种情况,刚开始更新Studio的时候,就是挂, HelloWorld都跑不起来,你在上面描述的方法,我都试过,没用,后来,发现就是更新之后, project 项目下使用的gradle版本是2.2左右,具体我记不清,如果你更新的话,你看看你项目下的gradle是不是2.2,注意,我说的是gradle版本--->build.gradle里面,更改为3.0.0或者3.0.1应该就可以了

    点赞 1 评论 复制链接分享
  • qq_38074369 wkp111 2018-01-08 06:38

    看一下你项目的gradle文件夹--wrapper文件夹--gradle-wrapper.properties文件,Android Studio3.0+必须要用gradle4.1以上

    点赞 评论 复制链接分享
  • James_201512 James_201512 2018-01-08 06:41

    图片说明

    点赞 评论 复制链接分享
  • niaonao niaonao 2018-01-08 06:48

    AndroidStudio->Preferences->Gradle:

    -XX:MaxPermSize=1024m

    点赞 评论 复制链接分享
  • qq_38074369 wkp111 2018-01-08 07:44

    可能是多个版本的jdk(jre)导致

    点赞 评论 复制链接分享
  • Qiang89416 有趣的 2018-01-08 07:54
    点赞 评论 复制链接分享
  • qq_30356875 qq_30356875 2018-01-08 07:59

    项目的gradle文件夹--wrapper文件夹--gradle-wrapper.properties文件,Android Studio3.0+必须要用gradle4.1以上

    点赞 评论 复制链接分享
  • pxh7103 CS_Shit_DN 2018-01-08 11:20
    点赞 评论 复制链接分享
  • qq_33756493 昵称_Justin 2018-01-09 10:41

    删除gradle不完全导致,把之前Gradle的还原,然后去官网下载4.1的gradle,重新配置目录就OK了

    点赞 评论 复制链接分享
  • qq_38074369 wkp111 2018-01-16 07:11

    我刚才碰见相似的问题了,直接注释掉#org.gradle.jvmargs=-Xmx1536m就好了

    点赞 评论 复制链接分享
  • like_lgg like_lgg 2018-01-23 07:28

    http://blog.csdn.net/like_lgg/article/details/79140064 可以试试这个方法 添加一个系统变量

    点赞 评论 复制链接分享

相关推荐