【Hadoop部署】Ubuntu下不断报错JDK版本不支持 10C

# 已经在网上看了不下十篇博客了,每篇博客都尝试过了,可是每次出现的错误都不一样,实在要抓狂了。

# 希望各位前辈、大牛能够指导一下,实在感谢

# 以下为报错内容以及 java -version / javac -version的内容

出错内容

java / javac

# 还需要什么信息(配置,core-site,$java_home)请告知一声,谢谢。

6个回答

一般这种情况和hadoop的配置文件,环境的配置有关,你可以去点击我的头像,去看我的博客,里面有单节点,集群和测试样例,你可以对比看,找出问题!

senver_wen
言文七 回复setpercision:你的Linux版本是14.04的现在已经不支持了,安装的默认的openjdk版本为1.7和Hadoop3.1不匹配,所以你现在有两种阶级办法,一,通过手动下载tar包的方式安装jdk1.8,二,换Linux16版本,三,换Hadoop2的版本
接近 2 年之前 回复
senver_wen
言文七 回复setpercision:你的Linux版本是14.04的现在已经不支持了
接近 2 年之前 回复
senver_wen
言文七 我用的版本是jdk1.8,你现在用的是什么版本
接近 2 年之前 回复
setpercision
ian_coder 你好,我已经按照您的那个博客照做了,还是错误,错误还是一样。csdn好像没办法私信你,没办法把我所有的配置文件信息给你看,真麻烦
接近 2 年之前 回复

一般这种情况和hadoop的配置文件,环境的配置有关,你可以去点击我的头像,去看我的博客,里面有单节点,集群和测试样例,你可以对比看,找出问题!

setpercision
ian_coder 你好,点进您的主页我并没有看到你有发布过博客。
接近 2 年之前 回复

52是jdk1.8,怎么显示jdk的版本是1.7呢

setpercision
ian_coder 我也不知道,很疑惑。而且我新建了的ubuntu的虚拟机里就算没安装jdk,我输入java -version也显示了jdk的版本。
接近 2 年之前 回复

你去hadoop官网查看一下你下载的hadoop版本支持什么版本的JDK,去年下半年我使用的hadoop2.7版本,jdk选用的是jdk1.8.0_144

你hadoop、jdk的版本不兼容,这是官方给出的hadoop、java的版本匹配要求
图片说明

把你的openjdk卸载了按个1.8就好了

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问