降版本编译报错,不知道怎么回事

平台改成sdk 23编译就报这个错,但是我看了这个api是在23的时候就开始用了啊。为什么会这样。
The import android.support.annotation.RequiresApi cannot be resolved

4个回答

降库会造成很多问题,而不是单单改一下你的compileSdkVersion和targetSdkVersion,gradle文件中的dependencies也要匹配你当前sdk版本

android.support.annotation.RequiresApi cannot be resolved,看下你引用的注解在哪个版本加进去的,你目前使用的版本肯定是没有了

步骤1:在gradle中修改 compile sdk 版本,比如 8.

步骤2:在gradle中删除v7包的依赖

步骤3:在manifest中修改theme,supportsRtl。theme需要修改成当前编译版本支持的主题,可以使用DeviceDefault主题等。删除supportsRtl属性。

步骤4:将继承appcompatActivity修改为Activity

在编写安卓程序时,当我import android.support.v4.app.FragmentActivity;出现题目中的错误,主要是缺少android.support的库,解决方法为下述链接:

http://www.qbmob.com/?p=854

在ADT中需要按照以下步骤:

1、右击当前工程,查找Properties

2、选择Java Build Path

3、选择Libraries tab,点击右边面板的Add External JARs按钮

4、选择android-support-v4.jar文件,这一文件的常见路径为:YOUR_DRIVE\android-sdks\extras\android\support\v4\android-support-v4.jar

5、完成添加后,选择Order and Export标签,确认即可。

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐