appium+java1.8运行时出错 5C

图片说明appium报错需要java1.6版本,但是我java环境变量是1.8,注册表也是1.8,eclipse配置的也是1.8,求大神支援,appium怎么能在java1.8环境运行

2个回答

可以下载最新的桌面版试一下https://github.com/appium/appium-desktop

自己写个启动脚本 比如叫 startAppium.bat

set PATH=
set JAVA_HOME=pathtojdk1.8

start "" xxxxx.exe

说明:
第一句是为了清空环境变量,防止已有的环境变量对后边有影响
第二句是声明java_home
第三句是执行 exe

很多需要环境变量才能执行的程序,都可以用这种方式来执行,尤其是环境变量可能冲突的

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问