nginx下使用python,用smtp.qq.com发送邮件

在pycharm本地测试ok,使用uwsgi代理访问ok,用nginx连接报错。邮箱的smtp功能已开启,use_ssl=True use_tls=False. 有人遇到过吗?还请不吝赐教。下面是错误回溯
send: 'ehlo localhost.localdomain\r\n'
reply: b'250-smtp.qq.com\r\n'
reply: b'250-PIPELINING\r\n'
reply: b'250-SIZE 73400320\r\n'
reply: b'250-AUTH LOGIN PLAIN\r\n'
reply: b'250-AUTH=LOGIN\r\n'
reply: b'250-MAILCOMPRESS\r\n'
reply: b'250 8BITMIME\r\n'
reply: retcode (250); Msg: b'smtp.qq.com\nPIPELINING\nSIZE 73400320\nAUTH LOGIN PLAIN\nAUTH=LOGIN\nMAILCOMPRESS\n8BITMIME'
send: 'AUTH PLAIN AGNoZW50ZW5nQHdheXNhdXRvbWF0aW9uLmNvbQBDajEyMzQ1Ng==\r\n'
reply: b'535 Error: authentication failed, system busy\r\n'
reply: retcode (535); Msg: b'Error: authentication failed, system busy'
send: 'AUTH LOGIN Y2hlbnRlbmdAd2F5c2F1dG9tYXRpb24uY29t\r\n'
reply: b'334 UGFzc3dvcmQ6\r\n'
reply: retcode (334); Msg: b'UGFzc3dvcmQ6'
send: 'Q2oxMjM0NTY=\r\n'
reply: b'535 Error: authentication failed, system busy\r\n'
reply: retcode (535); Msg: b'Error: authentication failed, system busy'
Exception in thread Thread-1:
Traceback (most recent call last):
File "/usr/local/lib/python3.6/lib/python3.6/threading.py", line 916, in bootstrap_inner
self.run()
File "/usr/local/lib/python3.6/lib/python3.6/threading.py", line 864, in run
self._target(*self._args, **self._kwargs)
File "./app/email.py", line 8, in send_async_eamil
mail.send(msg)
File "/home/www/.virtualenvs/env/lib/python3.6/site-packages/flask_mail.py", line 491, in send
with self.connect() as connection:
File "/home/www/.virtualenvs/env/lib/python3.6/site-packages/flask_mail.py", line 144, in __enter
_
self.host = self.configure_host()
File "/home/www/.virtualenvs/env/lib/python3.6/site-packages/flask_mail.py", line 165, in configure_host
host.login(self.mail.username, self.mail.password)
File "/usr/local/lib/python3.6/lib/python3.6/smtplib.py", line 730, in login
raise last_exception
File "/usr/local/lib/python3.6/lib/python3.6/smtplib.py", line 721, in login
initial_response_ok=initial_response_ok)
File "/usr/local/lib/python3.6/lib/python3.6/smtplib.py", line 642, in auth
raise SMTPAuthenticationError(code, resp)
smtplib.SMTPAuthenticationError: (535, b'Error: authentication failed, system busy')

2个回答

和ngnix没有关系,你的web服务器,也就是真正发邮件的那个服务器,是否能使用ssl连上smtp.qq.com。端口是否打开,以及用户名密码的认证,这里显示报错。

可能是qq邮件系统的问题,早上来又好了,最后显示系统繁忙可能是,晚上发邮件的人太多了?

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
无法连接到ssl://smtp.gmail.com:465名称或服务未知(0)

<div class="post-text" itemprop="text"> <p>I have some strange problem here, socket connection to smtp.gmail.com fails when I try to execute script on site with <code>Warning: stream_socket_client(): unable to connect to ssl://smtp.gmail.com:465 (php_network_getaddresses: getaddrinfo failed: Name or service not known) in /var/www/test/test.php on line 2 php_network_getaddresses: getaddrinfo failed: Name or service not known (0)</code> , but work fine if i run it in shell like <code>php test.php</code>, telnet works fine too and openssl connection as well, but web script just fail. I looked a lot of similar issues and didn't found an answer for that, any suggestions? I run nginx + php-fpm if, openssl enabled</p> <p>UPD: here is my test script:</p> <pre><code>$fp = fsockopen("ssl://smtp.gmail.com", 465, $errno, $errstr, 10); if (!$fp) { echo "$errstr ($errno)&lt;br /&gt; "; } else { echo "opened"; } </code></pre> </div>

[SMTP:无法连接套接字:fsockopen():无法连接到ssl://smtp.gmail.com:465(未知错误)(代码:-1,响应:)

<div class="post-text" itemprop="text"> <p>I have been troubleshooting this issue for the last two months and have gotten no results on how to fix this. I am using PHP 5.6.3 with PEAR 1.10.1, the emailing pages in question worked fine with our 3-party emailing software on our local server only designed to use port 25 for SMTP. Now the PHP pages do reference an XML template that contains all the host, password, and username information. I want to switch to using google email servers with SSL. I implemented the changes provided by my email administrator and change the MX records accordingly. It was functioning properly for two weeks. After that I was getting the following error </p> <p><strong><em>"Failed to connect to ssl://smtp.gmail.com:465 [SMTP: Failed to connect socket: fsockopen(): unable to connect to ssl://smtp.gmail.com:465 (Unknown error) (code: -1, response: )]"</em></strong>.</p> <p>I have changed the code several times, I removed the ssl://, I have changed the protocol type to TLS with the port number 587, etc. Nothing was working! I reached out to the contractor to construct a simple hard-coded page that just said hello world using the gmail server configuration. He refused and made myself make a simple php page, mind you I had zero background in PHP programming until now, so on a side note entirely happy that this was thrown my way, but regardless I did complete the task. I have a page that sends a simple message, using the smtp server with the account desired using the PHPMailer library. (See the code below)</p> <pre><code> &lt;?php require_once 'C:\Webpage\PHPMailer-5.2-stable/PHPMailerAutoload.php'; $mail = new PHPMailer(); $mail-&gt;isSMTP(); $mail-&gt;SMTPAuth = true; $mail-&gt;SMTPDebug = SMTP::DEBUG_SERVER; $mail-&gt;SMTPDebug = 4; // 2 to enable SMTP debug information $mail-&gt;Host = 'smtp.gmail.com'; $mail-&gt;Username = 'username@gmail.com'; $mail-&gt;Password = 'XXXXXXXXXXXXXXXXXXX'; $mail-&gt;SMTPSecure ='ssl'; $mail-&gt;Port = 465; /*$mail-&gt;SMTPOptions = array( 'ssl' =&gt; array( 'verify_peer' =&gt; false, 'verify_peer_name' =&gt; false, //'allow_self_signed' =&gt; true ) );*/ $mail-&gt;From = 'XXXXt@abc.com'; $mail-&gt;FromName = 'Example'; $mail-&gt;addReplyTo('testing@abc.com','Example'); $mail-&gt;AddAddress('user1@xyz.com', 'John Doe'); $mail-&gt;Subject = 'Hello World'; $mail-&gt;Body ='A test email!'; $mail-&gt;AltBody = 'A test email!'; if(!$mail-&gt;Send()) { echo "Mailer Error: " . $mail-&gt;ErrorInfo; } else { echo "Message has been sent"; } ?&gt; </code></pre> <p>Now I know this is not using PEAR, but from this I found out some interesting information that I think is related. The code only works if the line with </p> <pre><code> $mail-&gt;SMTPOptions = array( 'ssl' =&gt; array( 'verify_peer' =&gt; false, 'verify_peer_name' =&gt; false, //'allow_self_signed' =&gt; true ) ); </code></pre> <p>is not commented out it works, but when it is commented out, I receive an error regarding this. </p> <pre><code>Connection failed. Error #2: stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed [C:\Webpage\PHPMailer-5.2-stable\class.smtp.php line 299] </code></pre> <p>So I googled this error and was lead to the php.ini file to change the openssl.cafile and the openssl.capath values. I entered in the download CA certificates and entered the correct pathway for the values, but still it is not working. Am I placing these in the wrong area? Or is there an easier way to fix this issue using the PEAR library? Please any help on this subject will be appreciated!:) </p> <p>UPDATE(02/20/2018):</p> <p>I have downloaded the bundle and set the pathway to it's correct location,<code>curl.cainfo ="C:\OpenSSL-Win64\bin\PEM\cacert.pem"</code>,<code>openssl.cafile="C:\OpenSSL-Win64\bin\PEM\cacert.pem"</code>. I still am getting the error I ran the following check of the ssl locations to see if it was using the <code>php.ini</code> file and got the following.</p> <pre><code> &lt;?php error_reporting(E_ALL); print " If you've got this far without errors then problem is with your SSL config "; $calocns=openssl_get_cert_locations(); if (count($calocns)) { print "Check you've got your cacerts deployed in one of the following locations "; foreach ($calocns as $k=&gt;$v) print "$k = $v "; } else { print "You've not configured your openssl installation on this host "; } $calocns=openssl_get_cert_locations(); //var_dump(openssl_get_cert_locations()); ?&gt; </code></pre> <p>Result:</p> <pre><code> If you've got this far without errors then problem is with your SSL config Check you've got your cacerts deployed in one of the following locations default_cert_file = f: epo\winlibs_openssl_vc11_x86/cert.pem default_cert_file_env = SSL_CERT_FILE default_cert_dir = f: epo\winlibs_openssl_vc11_x86/certs default_cert_dir_env = SSL_CERT_DIR default_private_dir = f: epo\winlibs_openssl_vc11_x86/private default_default_cert_area = f: epo\winlibs_openssl_vc11_x86 ini_cafile = ini_capath = </code></pre> <p>I seem to be doing this wrong or need to know how to change the locations because those locations are not existent on my computer and I don't understand how it goes to those by default when I changed the pathway in the configuration file itself. Any thoughts?</p> </div>

nginx配置if的问题....

location /work { set $backend ""; set $protocol ""; access_by_lua_file '/usr/bin/nginx/conf/servers/test.lua'; if ( $backend != "" ) { proxy_pass $protocol://$backend; } if ( $backend = "" ) { proxy_pass $protocol://test_com; } } 这是nginx配置文件 test.lua中主要做的功能是读取redis中的ip和port 如果redis中获取的ip和port为空 那么就走nginx轮询机制(在upstream.conf配置的) 否则就直接打到后端的服务器。 现在的问题是 nginx配置文件中的第1个if可以走的通,第2个if有问题,直接返回502 求教大神!

nginx.pid 不见了,nginx启动失败

公司搬家,机器没有关好。 后来启动机器上的nginx(openresty中集成的nginx),但是启动会卡住,如果nginx -s reload,机会如下图 ![图片说明](https://img-ask.csdn.net/upload/201710/10/1507627990_857418.png) 网上的解决办法是nginx -c ....../nginx/conf/nginx.conf,但是还是会卡住不动,希望大佬神指点。 第一次提问,以前没有C币的意识,仅有1个铜板,见谅见谅

nginx+php部署关于nginx.conf配置问题,请教熟悉的朋友

我使用的lnmp包安装的,安装提示成功。也能正常访问phpinfo页面。 把自己项目放上去后,更改了php.ini的doc_root 改为项目地址;然后就是nginx改成以下: user root; worker_processes auto; error_log /home/wwwlogs/nginx_error.log crit; pid /usr/local/nginx/logs/nginx.pid; #Specifies the value for maximum file descriptors that can be opened by this process. worker_rlimit_nofile 51200; events { use epoll; worker_connections 51200; multi_accept on; } http { include mime.types; default_type application/octet-stream; server_names_hash_bucket_size 128; client_header_buffer_size 32k; large_client_header_buffers 4 32k; client_max_body_size 50m; sendfile on; tcp_nopush on; keepalive_timeout 60; tcp_nodelay on; fastcgi_connect_timeout 300; fastcgi_send_timeout 300; fastcgi_read_timeout 300; fastcgi_buffer_size 64k; fastcgi_buffers 4 64k; fastcgi_busy_buffers_size 128k; fastcgi_temp_file_write_size 256k; gzip on; gzip_min_length 1k; gzip_buffers 4 16k; gzip_http_version 1.1; gzip_comp_level 2; gzip_types text/plain application/javascript application/x-javascript text/javascript text/css application/xml application/xml+rss; gzip_vary on; gzip_proxied expired no-cache no-store private auth; gzip_disable "MSIE [1-6]\."; #limit_conn_zone $binary_remote_addr zone=perip:10m; ##If enable limit_conn_zone,add "limit_conn perip 10;" to server section. server_tokens off; #log format log_format access '$remote_addr - $remote_user [$time_local] "$request" ' '$status $body_bytes_sent "$http_referer" ' '"$http_user_agent" $http_x_forwarded_for'; access_log off; upstream OfficeFPM { server 127.0.0.1:8266 weight=1; keepalive 100; } server { listen 81 default_server; server_name localhost; index index.html index.php; root /home/wwwroot/default; #error_page 404 /404.html; include enable-php.conf; if (-d $request_filename){rewrite ^/(.*)([^/])$ $scheme://$http_host/$1$2/ permanent; } #charset gbk; #access_log logs/host.access.log main; location ~* ^/(attachment|static|images|theme|templates|wav)/.*\.(php|.php3|.php5|jsp|asp)$ { deny all; } # pass the PHP scripts to FastCGI server listening on 127.0.0.1:8266 # location ~ \.php$ { fastcgi_pass OfficeFPM; fastcgi_index index.php; include fastcgi.conf; } location /general/document/index.php/ { fastcgi_pass OfficeFPM; fastcgi_index index.php; include fastcgi.conf; fastcgi_param SCRIPT_FILENAME /home/wwwroot/default/general/document/index.php; fastcgi_param SCRIPT_NAME /general/document/index.php; fastcgi_split_path_info ^(.+\.php)/(.*)$; fastcgi_param PATH_INFO $fastcgi_path_info; fastcgi_param PATH_TRANSLATED $document_root$fastcgi_path_info; } location /general/itask/router.php/ { fastcgi_pass OfficeFPM; fastcgi_index index.php; include fastcgi.conf; fastcgi_param SCRIPT_FILENAME /home/wwwroot/default/general/itask/router.php; fastcgi_param SCRIPT_NAME /general/itask/router.php; } location ~* ^/attachment/(background|im|new_sms|reportshop|cache|data_center) { allow all; } location ~* ^/attachment { deny all; } location ~ /\. { deny all; } location / { if (!-e $request_filename){ rewrite ^/(.*) /index.php last; } } access_log /home/wwwlogs/access.log access; } include vhost/*.conf; } 当时访问出现如下图错误,index.php报错 ![图片说明](https://img-ask.csdn.net/upload/201603/06/1457263996_477379.png) 当我改成静态页面时候却能正常访问,请教了,本人第一次搞这个对这些配置文件很模糊,请高手帮忙改下。

Linux下 rpm安装nginx

]$ sudo yum install nginx Loaded plugins: fastestmirror nginx | 2.9 kB 00:00:00 nginx/x86_64/primary_db | 15 kB 00:00:00 Loading mirror speeds from cached hostfile * base: mirrors.163.com * extras: mirrors.sina.cn * updates: centos.ustc.edu.cn Resolving Dependencies --> Running transaction check ---> Package nginx.x86_64 0:1.10.1-1.el6.ngx will be installed --> Processing Dependency: libpcre.so.0()(64bit) for package: nginx-1.10.1-1.el6.ngx.x86_64 --> Finished Dependency Resolution Error: Package: nginx-1.10.1-1.el6.ngx.x86_64 (nginx) Requires: libpcre.so.0()(64bit) You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

windows环境下nginx上用fastcgi配置python环境

我按照这个人的方法(http://blog.csdn.net/revolver/article/details/50465636)做,到后面运行python hello.py --method=prefork/threaded minspare=50 maxspare=50 maxchildren=1000,结果就半天没得反应,也不报错。

用Nginx部署时,python收集静态文件时出现编码问题

命令python manage.py collectstatic 然后 ![图片说明](https://img-ask.csdn.net/upload/201808/24/1535114243_977307.png)

Nginx如何直接访问index.php时返回404

<div class="post-text" itemprop="text"> <p>For security purpose, I am attempting to hide almost all the fingerprint info of my web application. The most important thing is to hide <code>PHP</code> from any visitors. So I try to modify my <code>Nginx</code>'s configuration file. The configuration will show as follows.</p> <pre><code>location / { root /data/site/public; index index.html index.htm index.php; try_files $uri /index.php; location /index.php { fastcgi_pass unix:/var/run/php5-fpm.sock; include fastcgi.conf; } } </code></pre> <p>By this way, I successfully hide <code>index.php</code> from URL. However, Hackers could also directly access my website by using some URL such as <code>http://example.com/index.php</code>, which shows that my website is written by <code>PHP</code>. Sometimes it maybe dangerous. So, I modify the <code>Nginx</code>'s config second time, longing for <code>404</code> when access <code>index.php</code> directly, and it looks like</p> <pre><code>location / { root /data/site/public; if ( $request_uri ~ /index\.php ) { return 404; } index index.html index.htm index.php; try_files $uri /index.php; location /index.php { fastcgi_pass unix:/var/run/php5-fpm.sock; include fastcgi.conf; } } </code></pre> <p>However..., it seems that <code>Nginx</code> acts nothing different from the previous one.</p> <p>Could anyone tell me the reason ? or any other solutions...</p> </div>

如何指定uwsgi在启动时默认的python版本

最近用django写了个项目,用的是python3.6,想放在服务器上用uwsgi+nginx运行的,因为服务器默认的是python2.7,所以我在服务器上安装了python3并创建软连接,这是我的uwsgi的配置文件,名字叫uwsgi.ini: ![图片说明](https://img-ask.csdn.net/upload/201908/26/1566809048_585549.png) 我的项目在python2中运行不了,但是uwsgi启动时默认的是python2,所以我在配置文件中加了这样一句:plugin=python3 然后当我执行命令:uwsgi --ini uwsgi.ini时出现问题: ![图片说明](https://img-ask.csdn.net/upload/201908/26/1566809370_212703.png) 我也知道问题在这里, open(“./ python3_plugin.so”):没有这样的文件或目录[core / utils.c line 3724] !无法加载uWSGI插件:./ python3_plugin.so:无法打开共享对象文件:没有这样的文件或目录! 但是我不知道创建这个文件之后我应该做什么? 恳请大佬解答。

ubuntu安装nginx进行到进入nginx-1.8.1的目录执行sudo ./make的时候报错:sudo: ./make:找不到命令

环境:ubuntu虚拟机16.04 问题:在网上找了一个FASTDFS的安装教程,链接是https://blog.csdn.net/michael_xwb/article/details/90267890 前面几步进行得都没有问题,但是到了安装Nginx + fastdfs-nginx-module时出现了问题,行到进入nginx-1.8.1的目录执行sudo ./make的时候报错:sudo: ./make:找不到命令 ![图片说明](https://img-ask.csdn.net/upload/201910/12/1570845361_573257.png) 他文章里要求的前置组件 ``` sudo apt-get install zlib1g-dev sudo apt-get install libpcre3 libpcre3-dev sudo apt-get install openssl libssl-dev ``` 这些我都安装了,但是依然没有成功,后面的步骤我一直没进行,在nginx1.8.1下也找不到make文件 ![图片说明](https://img-ask.csdn.net/upload/201910/12/1570845687_926181.png) 后来我又试了试nginx1.12.1版本,也是同样的问题,依旧是找不到make命令。 请问一下有没有大手子知道是怎么回事的?万分感谢!

安装nginx,添加它为系统服务,nano /etc/init.d/nginx添加的配置代码看不懂

#!/bin/sh # # nginx - this script starts and stops the nginx daemon # # chkconfig: - 85 15 # description: Nginx is an HTTP(S) server, HTTP(S) reverse \ # proxy and IMAP/POP3 proxy server # processname: nginx # config: /data/nginx/nginx.conf # config: /etc/sysconfig/nginx # pidfile: /var/run/nginx.pid # Source function library. . /etc/rc.d/init.d/functions # Source networking configuration. . /etc/sysconfig/network # Check that networking is up. [ "$NETWORKING" = "no" ] && exit 0 nginx="/data/nginx/sbin/nginx" prog=$(basename $nginx) NGINX_CONF_FILE="/data/nginx/conf/nginx.conf" [ -f /etc/sysconfig/nginx ] && . /etc/sysconfig/nginx lockfile=/var/lock/subsys/nginx start() { [ -x $nginx ] || exit 5 [ -f $NGINX_CONF_FILE ] || exit 6 echo -n $"Starting $prog: " daemon $nginx -c $NGINX_CONF_FILE retval=$? echo [ $retval -eq 0 ] && touch $lockfile return $retval } stop() { echo -n $"Stopping $prog: " killproc $prog -QUIT retval=$? echo [ $retval -eq 0 ] && rm -f $lockfile return $retval killall -9 nginx } restart() { configtest || return $? stop sleep 1 start } reload() { configtest || return $? echo -n $"Reloading $prog: " killproc $nginx -HUP RETVAL=$? echo } force_reload() { restart } configtest() { $nginx -t -c $NGINX_CONF_FILE } rh_status() { status $prog } rh_status_q() { rh_status >/dev/null 2>&1 } case "$1" in start) rh_status_q && exit 0 $1 ;; stop) rh_status_q || exit 0 $1 ;; restart|configtest) $1 ;; reload) rh_status_q || exit 7 $1 ;; force-reload) force_reload ;; status) rh_status ;; condrestart|try-restart) rh_status_q || exit 0 ;; *) echo $"Usage: $0 {start|stop|status|restart|condrestart|try-restart|reload|force-reload|configtest}" exit 2 esac 请有空的大神指导下几个主要步骤的作用(详细的当然更好),先谢过啦!本人是纯新手,只知道一点简单命令,对着文档知其然而不知其所以然,真心很苦恼。。。。。。

nginx配置中访问域名www.xxx.com怎样定向到www.xxx.com/xxx/xxx/

nginx配置中访问域名www.xxx.com怎样定向到www.xxx.com/xxx/xxx/

局域网内部署smtp正向代理

现在的环境是这样的:有一台双网卡的linux服务器A,可以上外网;还有一台只有一块内网网卡的web服务器(linux系统)B,现在B有程序需要发邮件到客户注册的邮箱,A上部署了nginx反向代理,那么如何操作才能使内网服务器B通过代理发送邮件呢?

Oracle VM VirtualBox 进行 vim /usr/local/nginx/conf/nginx.conf 配置以后怎么保存退出到如图状态 萌新求助!!!

![图片说明](https://img-ask.csdn.net/upload/201912/05/1575538326_513802.png)![图片说明](https://img-ask.csdn.net/upload/201912/05/1575538364_819541.png)

如何在服务器中一直运行python manage.py runserver 这条命令

完成了一个django的项目,放在阿里云服务器上,用xshell连接,无奈nginx +uwsgi +django部署不会,只能使用最基本的python manage.py runserver跑起来,网站访问正常,但是我一关闭xshell,命令马上就不执行了,我的网站也马上就访问不了了,现在想请问如何让我在关闭xshell的时候,该命令仍然可以在我的项目目录下运行从而使我的网站可以在任何时候都可以访问。

nginx 配置了index index.php,但是域名无法访问

nginx 配置了index index.php,但是域名无法访问![图片说明](https://img-ask.csdn.net/upload/201506/05/1433498346_414014.png)![图片说明](https://img-ask.csdn.net/upload/201506/05/1433498308_329504.png)![图片说明](https://img-ask.csdn.net/upload/201506/05/1433498369_40667.png)

nginx 为什么 192.168.25.133打不开欢迎页呢?

我./nginx 运行后是这个结果![图片说明](https://img-ask.csdn.net/upload/201606/21/1466438623_714335.png)

如何使用通配符使用nginx部署laravel

<div class="post-text" itemprop="text"> <p>I want to deploy my laravel application with nginx using wildcard domain. But that not work correctly. I have this error:</p> <pre><code>Corrupted Content Error </code></pre> <p><em>The site at <a href="http://www.exemple.com/" rel="nofollow noreferrer">http://www.exemple.com/</a> has experienced a network protocol violation that cannot be repaired. The page you are trying to view cannot be shown because an error in the data transmission was detected. Please contact the website owners to inform them of this problem.</em></p> <p>An example for my laravel routing</p> <pre><code>&lt;?php Route::group(['domain' =&gt; "{sub}.exemple.com"], function() { // load site content }); </code></pre> <p>This is my nginx configuration:</p> <pre><code>server { # Update max body size client_max_body_size 20M; # SSL configuration listen 443 ssl http2 default_server; listen [::]:443 ssl http2 default_server ipv6only=on; ssl on; include /etc/nginx/snippets/self-signed.conf; include /etc/nginx/snippets/ssl-params.conf; # Route and app index root /var/www/site/public; index index.php index.html; # Make site accessible from https://www.exemple.com server_name ~^([a-z]+)\.exemple\.com$; location / { if ($http_x_forwarded_proto != "https") { return 301 https://$1.exemple.com$request_uri; } try_files $uri $uri/ /index.php?$query_string; } location ~ \.php$ { try_files $uri =404; fastcgi_split_path_info ^(.+\.php)(/.+)$; fastcgi_pass unix:/var/run/php/php7.1-fpm.sock; fastcgi_index index.php; fastcgi_param SERVER_NAME $host; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; include fastcgi_params; } location ~ /\.ht { deny all; } location ~* \.(?:ico|gif|jpe?g|png)$ { expires 7d; add_header Pragma public; add_header Cache-Control "public"; access_log off; } location ~* \.(css|js|ttf)$ { expires 1d; access_log off; add_header Cache-Control "public"; } } </code></pre> </div>

大学四年自学走来,这些私藏的实用工具/学习网站我贡献出来了

大学四年,看课本是不可能一直看课本的了,对于学习,特别是自学,善于搜索网上的一些资源来辅助,还是非常有必要的,下面我就把这几年私藏的各种资源,网站贡献出来给你们。主要有:电子书搜索、实用工具、在线视频学习网站、非视频学习网站、软件下载、面试/求职必备网站。 注意:文中提到的所有资源,文末我都给你整理好了,你们只管拿去,如果觉得不错,转发、分享就是最大的支持了。 一、电子书搜索 对于大部分程序员...

在中国程序员是青春饭吗?

今年,我也32了 ,为了不给大家误导,咨询了猎头、圈内好友,以及年过35岁的几位老程序员……舍了老脸去揭人家伤疤……希望能给大家以帮助,记得帮我点赞哦。 目录: 你以为的人生 一次又一次的伤害 猎头界的真相 如何应对互联网行业的「中年危机」 一、你以为的人生 刚入行时,拿着傲人的工资,想着好好干,以为我们的人生是这样的: 等真到了那一天,你会发现,你的人生很可能是这样的: ...

程序员请照顾好自己,周末病魔差点一套带走我。

程序员在一个周末的时间,得了重病,差点当场去世,还好及时挽救回来了。

技术大佬:我去,你写的 switch 语句也太老土了吧

昨天早上通过远程的方式 review 了两名新来同事的代码,大部分代码都写得很漂亮,严谨的同时注释也很到位,这令我非常满意。但当我看到他们当中有一个人写的 switch 语句时,还是忍不住破口大骂:“我擦,小王,你丫写的 switch 语句也太老土了吧!” 来看看小王写的代码吧,看完不要骂我装逼啊。 private static String createPlayer(PlayerTypes p...

和黑客斗争的 6 天!

互联网公司工作,很难避免不和黑客们打交道,我呆过的两家互联网公司,几乎每月每天每分钟都有黑客在公司网站上扫描。有的是寻找 Sql 注入的缺口,有的是寻找线上服务器可能存在的漏洞,大部分都...

点沙成金:英特尔芯片制造全过程揭密

“亚马逊丛林里的蝴蝶扇动几下翅膀就可能引起两周后美国德州的一次飓风……” 这句人人皆知的话最初用来描述非线性系统中微小参数的变化所引起的系统极大变化。 而在更长的时间尺度内,我们所生活的这个世界就是这样一个异常复杂的非线性系统…… 水泥、穹顶、透视——关于时间与技艺的蝴蝶效应 公元前3000年,古埃及人将尼罗河中挖出的泥浆与纳特龙盐湖中的矿物盐混合,再掺入煅烧石灰石制成的石灰,由此得来了人...

讲一个程序员如何副业月赚三万的真实故事

loonggg读完需要3分钟速读仅需 1 分钟大家好,我是你们的校长。我之前讲过,这年头,只要肯动脑,肯行动,程序员凭借自己的技术,赚钱的方式还是有很多种的。仅仅靠在公司出卖自己的劳动时...

上班一个月,后悔当初着急入职的选择了

最近有个老铁,告诉我说,上班一个月,后悔当初着急入职现在公司了。他之前在美图做手机研发,今年美图那边今年也有一波组织优化调整,他是其中一个,在协商离职后,当时捉急找工作上班,因为有房贷供着,不能没有收入来源。所以匆忙选了一家公司,实际上是一个大型外包公司,主要派遣给其他手机厂商做外包项目。**当时承诺待遇还不错,所以就立马入职去上班了。但是后面入职后,发现薪酬待遇这块并不是HR所说那样,那个HR自...

女程序员,为什么比男程序员少???

昨天看到一档综艺节目,讨论了两个话题:(1)中国学生的数学成绩,平均下来看,会比国外好?为什么?(2)男生的数学成绩,平均下来看,会比女生好?为什么?同时,我又联想到了一个技术圈经常讨...

副业收入是我做程序媛的3倍,工作外的B面人生是怎样的?

提到“程序员”,多数人脑海里首先想到的大约是:为人木讷、薪水超高、工作枯燥…… 然而,当离开工作岗位,撕去层层标签,脱下“程序员”这身外套,有的人生动又有趣,马上展现出了完全不同的A/B面人生! 不论是简单的爱好,还是正经的副业,他们都干得同样出色。偶尔,还能和程序员的特质结合,产生奇妙的“化学反应”。 @Charlotte:平日素颜示人,周末美妆博主 大家都以为程序媛也个个不修边幅,但我们也许...

MySQL数据库面试题(2020最新版)

文章目录数据库基础知识为什么要使用数据库什么是SQL?什么是MySQL?数据库三大范式是什么mysql有关权限的表都有哪几个MySQL的binlog有有几种录入格式?分别有什么区别?数据类型mysql有哪些数据类型引擎MySQL存储引擎MyISAM与InnoDB区别MyISAM索引与InnoDB索引的区别?InnoDB引擎的4大特性存储引擎选择索引什么是索引?索引有哪些优缺点?索引使用场景(重点)...

如果你是老板,你会不会踢了这样的员工?

有个好朋友ZS,是技术总监,昨天问我:“有一个老下属,跟了我很多年,做事勤勤恳恳,主动性也很好。但随着公司的发展,他的进步速度,跟不上团队的步伐了,有点...

我入职阿里后,才知道原来简历这么写

私下里,有不少读者问我:“二哥,如何才能写出一份专业的技术简历呢?我总感觉自己写的简历太烂了,所以投了无数份,都石沉大海了。”说实话,我自己好多年没有写过简历了,但我认识的一个同行,他在阿里,给我说了一些他当年写简历的方法论,我感觉太牛逼了,实在是忍不住,就分享了出来,希望能够帮助到你。 01、简历的本质 作为简历的撰写者,你必须要搞清楚一点,简历的本质是什么,它就是为了来销售你的价值主张的。往深...

我说我不会算法,阿里把我挂了。

不说了,字节跳动也反手把我挂了。

优雅的替换if-else语句

场景 日常开发,if-else语句写的不少吧??当逻辑分支非常多的时候,if-else套了一层又一层,虽然业务功能倒是实现了,但是看起来是真的很不优雅,尤其是对于我这种有强迫症的程序"猿",看到这么多if-else,脑袋瓜子就嗡嗡的,总想着解锁新姿势:干掉过多的if-else!!!本文将介绍三板斧手段: 优先判断条件,条件不满足的,逻辑及时中断返回; 采用策略模式+工厂模式; 结合注解,锦...

离职半年了,老东家又发 offer,回不回?

有小伙伴问松哥这个问题,他在上海某公司,在离职了几个月后,前公司的领导联系到他,希望他能够返聘回去,他很纠结要不要回去? 俗话说好马不吃回头草,但是这个小伙伴既然感到纠结了,我觉得至少说明了两个问题:1.曾经的公司还不错;2.现在的日子也不是很如意。否则应该就不会纠结了。 老实说,松哥之前也有过类似的经历,今天就来和小伙伴们聊聊回头草到底吃不吃。 首先一个基本观点,就是离职了也没必要和老东家弄的苦...

为什么你不想学习?只想玩?人是如何一步一步废掉的

不知道是不是只有我这样子,还是你们也有过类似的经历。 上学的时候总有很多光辉历史,学年名列前茅,或者单科目大佬,但是虽然慢慢地长大了,你开始懈怠了,开始废掉了。。。 什么?你说不知道具体的情况是怎么样的? 我来告诉你: 你常常潜意识里或者心理觉得,自己真正的生活或者奋斗还没有开始。总是幻想着自己还拥有大把时间,还有无限的可能,自己还能逆风翻盘,只不是自己还没开始罢了,自己以后肯定会变得特别厉害...

男生更看重女生的身材脸蛋,还是思想?

往往,我们看不进去大段大段的逻辑。深刻的哲理,往往短而精悍,一阵见血。问:产品经理挺漂亮的,有点心动,但不知道合不合得来。男生更看重女生的身材脸蛋,还是...

为什么程序员做外包会被瞧不起?

二哥,有个事想询问下您的意见,您觉得应届生值得去外包吗?公司虽然挺大的,中xx,但待遇感觉挺低,马上要报到,挺纠结的。

当HR压你价,说你只值7K,你该怎么回答?

当HR压你价,说你只值7K时,你可以流畅地回答,记住,是流畅,不能犹豫。 礼貌地说:“7K是吗?了解了。嗯~其实我对贵司的面试官印象很好。只不过,现在我的手头上已经有一份11K的offer。来面试,主要也是自己对贵司挺有兴趣的,所以过来看看……”(未完) 这段话主要是陪HR互诈的同时,从公司兴趣,公司职员印象上,都给予对方正面的肯定,既能提升HR的好感度,又能让谈判气氛融洽,为后面的发挥留足空间。...

面试:第十六章:Java中级开发(16k)

HashMap底层实现原理,红黑树,B+树,B树的结构原理 Spring的AOP和IOC是什么?它们常见的使用场景有哪些?Spring事务,事务的属性,传播行为,数据库隔离级别 Spring和SpringMVC,MyBatis以及SpringBoot的注解分别有哪些?SpringMVC的工作原理,SpringBoot框架的优点,MyBatis框架的优点 SpringCould组件有哪些,他们...

面试阿里p7,被按在地上摩擦,鬼知道我经历了什么?

面试阿里p7被问到的问题(当时我只知道第一个):@Conditional是做什么的?@Conditional多个条件是什么逻辑关系?条件判断在什么时候执...

你打算用Java 8一辈子都不打算升级到Java 14,真香

我们程序员应该抱着尝鲜、猎奇的心态,否则就容易固步自封,技术停滞不前。

无代码时代来临,程序员如何保住饭碗?

编程语言层出不穷,从最初的机器语言到如今2500种以上的高级语言,程序员们大呼“学到头秃”。程序员一边面临编程语言不断推陈出新,一边面临由于许多代码已存在,程序员编写新应用程序时存在重复“搬砖”的现象。 无代码/低代码编程应运而生。无代码/低代码是一种创建应用的方法,它可以让开发者使用最少的编码知识来快速开发应用程序。开发者通过图形界面中,可视化建模来组装和配置应用程序。这样一来,开发者直...

面试了一个 31 岁程序员,让我有所触动,30岁以上的程序员该何去何从?

最近面试了一个31岁8年经验的程序猿,让我有点感慨,大龄程序猿该何去何从。

大三实习生,字节跳动面经分享,已拿Offer

说实话,自己的算法,我一个不会,太难了吧

程序员垃圾简历长什么样?

已经连续五年参加大厂校招、社招的技术面试工作,简历看的不下于万份 这篇文章会用实例告诉你,什么是差的程序员简历! 疫情快要结束了,各个公司也都开始春招了,作为即将红遍大江南北的新晋UP主,那当然要为小伙伴们做点事(手动狗头)。 就在公众号里公开征简历,义务帮大家看,并一一点评。《启舰:春招在即,义务帮大家看看简历吧》 一石激起千层浪,三天收到两百多封简历。 花光了两个星期的所有空闲时...

《经典算法案例》01-08:如何使用质数设计扫雷(Minesweeper)游戏

我们都玩过Windows操作系统中的经典游戏扫雷(Minesweeper),如果把质数当作一颗雷,那么,表格中红色的数字哪些是雷(质数)?您能找出多少个呢?文中用列表的方式罗列了10000以内的自然数、质数(素数),6的倍数等,方便大家观察质数的分布规律及特性,以便对算法求解有指导意义。另外,判断质数是初学算法,理解算法重要性的一个非常好的案例。

《Oracle Java SE编程自学与面试指南》最佳学习路线图(2020最新版)

正确选择比瞎努力更重要!

一文带你入门Java Stream流,太强了

两个星期以前,就有读者强烈要求我写一篇 Java Stream 流的文章,我说市面上不是已经有很多了吗,结果你猜他怎么说:“就想看你写的啊!”你看你看,多么苍白的喜欢啊。那就“勉为其难”写一篇吧,嘻嘻。 单从“Stream”这个单词上来看,它似乎和 java.io 包下的 InputStream 和 OutputStream 有些关系。实际上呢,没毛关系。Java 8 新增的 Stream 是为...

立即提问
相关内容推荐