Python pip安装出现问题

安装时出现
图片说明

安装了get-pip.py
也设置了环境变量..

1

9个回答

两行命令
python -m ensurepip
easy_install pip

0
actx23a
actx23a 你qq多少,帮我解决??
12 个月之前 回复
actx23a
actx23a 都没有名为pip的模块,我的pip后缀是exe可以吗
12 个月之前 回复
actx23a
actx23a 回复m0_37885968: 是的
12 个月之前 回复
m0_37885968
m0_37885968 回复actx23a: python -m pip install -U pip 升级一下pip试试,Windows是吗?
12 个月之前 回复
actx23a
actx23a 回复m0_37885968: 还是不行,python3时不是内部或外部命令,也不是可运行的程序 或批处理文件。F:\python3.6.5\python.exe: No module named ensurepip
12 个月之前 回复
m0_37885968
m0_37885968 回复m0_37885968: python -m ensurepip 可以直接运行这条命令
12 个月之前 回复
m0_37885968
m0_37885968 回复actx23a: Python3直接可以使用:python3 -m pip
12 个月之前 回复
actx23a
actx23a F:\python3.6.5\python.exe: No module named ensurepip
12 个月之前 回复
actx23a
actx23a F:\python3.6.5\python.exe: No module named ensurepip
12 个月之前 回复

Python 3.6已经自带pip了,可能你的环境变量设置的不对,“%PYTHON_HOME%;%PYTHON_HOME%\Scripts;”,出了Python安装目录还要加上Scripts目录。如果还是不行建议重装Python

1

直接找到你的pip.exe所在目录,在该目录打开终端然后使用pip。 如果可以使用则因该是环境变量添加的有问题

1

图片说明
图片说明

0

安装时出现 图片说明 安装了get-pip.py 也设置了环境变量

0

建议直接安装python3.6以上版本,pip自带

0

3.6.5版本的python,不行啊

0

你的python中没有安装pip模块,安装一下就好了,安装过程可以百度

0

解决方法:
1,找到你的Python版本对应的解释器的名称
首先你需要进入安装Python相应版本所在的文件夹。以我的Python版本为例,这是我的Python2.7版本对应的解释器名称:

这是我的Python3.6版本对应的解释器的名称:

2,使用“解释器名称 -m pip install XXX”来安装相应的库
同样以我的Python版本为例,
如果我想安装Python2.7的sklearn库,我需要输入的命令是“python2 -m pip install sklearn”
如果我想安装Python3.6的sklearn库,我需要输入的命令是“python -m pip install sklearn”

0
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
下载 pip 工具
下载 python ,pip 安装工具,获取pip, python <3.3, python pip, pip install something
pip 安装更新遇到问题
关于pip Requirement already up-to-date: pip in 。。。 的问题 安装包时遇到更新提示 在win下用cmd使用命令“python -m pip install –upgrade pip” 更新pip时,第一次更新只是下载了相关文件但是并没有更新成功,之后再尝试更新时出现 发现在site-packages目录下的pip-9.01…egg文件(具...
flask 安装报错
用 py -3 -m pip install flask 能够正常安装 但 py -3 后使用 import flask 出现如下问题 卸载了flask:  py -3 -m pip uninstall flask 卸载了makeupsafe: py -3 -m pip uninstall makeupsafe 安装了makeupsafe: py -3 -m pip install
pip3 安装python库的时候报错ssl证书问题
    不改变原有基础环境下,可以采用跳过不验证的方式解决 # pip install --index-url=http://pypi.python.org/simple/ --trusted-host pypi.python.org 包名 # pip --trusted-host pypi.python.org install 包名 如果想彻底解决: 引用地址:https://blo...
python菜鸟踩坑系列-pika版本带来的问题
运行公司python项目报错,缺少pika,然后就安装pika呗,按照老司机的指引: pip install pika 然后运行说缺少nullhandler,而报错的地方在pika包里,pika版本0.12 百度找了半天,乱七八糟的也看不懂,没解决。 后来去python pika官网上看了下,0.12版本支持python2.7,而公司的项目运行环境是python2.6 这个坑爹玩意是今年...
python解决pip安装问题
今天刚开始学习python,跟同事要了一个免安装的压缩包(实际是他把本地达成rar,直接解压使用了),我习惯使用dos窗口,故配置了环境变量,如何配置环境变量这里就不说了。配置好环境变量后pip命令用不了,提示如下 Fatal error in launcher: Unable to create process using '&quot;' 上网百度发现有各种解决办法,最终我才用了升级pi...
如何解决用pip指令装包出现问题的情况
如何解决用pip指令装包出现问题的情况
pip安装flask报错问题
有时在中文windows环境下pip install flask会报错。 具体是在安装flask依赖markupsafe时报错: UnicodeDecodeError: 'utf-8' codec can't decode byte 0xd5 in position 2: invalid continuation byte 这是编码问题导致的。 查看错误产...
ubuntu16.04切换默认python版本以及使用pip安装包时遇到的问题
1. 切换默认Python版本 使用下面命令查看可以替换的版本号信息: update-alternatives --list python 如果执行命令后出现错误提示 update-alternatives: error: no alternatives for python 说明Python的替代版本尚未安装,执行下面命令进行安装: sudo update-alternatives --i...
python下安装easy_install、pip遇到的问题
如果对python安装不太熟悉,可以先安装python。如何安装python 问题背景: 我是把python2.7安装在D盘下DOWNLOADS,然后是python2.7的。即D:\Downloads\python2.7 然后在其中也安装好了   pip 和 easy_install了,这两者都是在D:\Downloads\python2.7\Scripts。 但是在
如何解决python2和python3中pip共存
在电脑中同时安装python2与python3可以为开发提供很大的便利,而在同时安装两个版本时却需要注意python2和python3中pip工具的共存问题。安装的步骤就不再赘述。在安装好python2和3后,需要将python目录下的python.exe改为python3.exe,为方便命令的区别之后,再将scripts中的pip文件删除,同样是为了命令的区分。打开cmd命令输入pip -V时,...
python在pip install 时遇到的问题!
解决问题:You are using pip version 9.0.1, however version 9.0.3 is available. You should consider upgrading via the ‘python -m pip install –upgrade pip’ command.解决方法:直接运行命令:python -m pip install –upgrade
安装keras的坑--pip install安装成功后显示No model named keras
据说keras使用非常方便,安装使用下,之前安装tensorflow==1.3.0(这为后面埋了个坑。。。。)和不同版本的python pip3 install keras 安装后import keras [1] 没问题哇,但是,运行代码后报错:No model named keras find / -name keras 发现安装到python3.5下面去了。。。。我用python3...
pip install 安装出现问题
在Python目录 Python27\Lib\site-packages 建一个文件sitecustomize.py import sysreload(sys)sys.setdefaultencoding('utf-8')
python-pip工具
pip安装文件,pip install 需要安装的name, 适合python开发者
Ubuntu中虚拟环境pip安装包超时问题
做爬虫的时使用pip安装一些爬虫框架经常容易报错或者国内镜像资源不足,或者做量化使用开源的vn.py,但只有py27版本的,解决这些问题一个所以这个时候Anaconda中的conda管理工具就非常的必需了。 解决pip安装包超时问题 1)首先检查linux软件下载源,主下载源是最全的,但是服务器在国外,速度较慢。所以需要按照自己的所在地选择合适的国内下载源。2)直接摒弃pip,选择conda……比
beautifulsoap 安装失败问题
使用pip install beautifulsoap 安装失败 C:\Users\JASON>pip install beautifulsoup Collecting beautifulsoup   Using cached BeautifulSoup-3.2.1.tar.gz     Complete output from command python setup.py egg_in
pip python2.7
pip安装文件,pip install 需要安装的name, 适合python开发者,
Python_pygame版本飞机大战源码
python版本飞机大战,第一个python测试项目,运行前安装python,python自带pip,然后用pip安装pygame,本项目测试可用,安装Pycharm编辑器直接运行就可以使用
linux下pip自动安装脚本
python pip linux 联网安装
Python双版本的pip冲突问题怎么解决
有好多朋友会碰到这样的问题,就是一台电脑上安装两个版本的python,然后pip安装模块的时候 pip install XXXX  会有问题。 网上乱七八糟的教程干扰太多,各抒己见并不能真正的解决问题 今天我也遇到了这样的问题,把解决办法整理了一下 其实python 在安装的时候就为我们提供了两个版本的解决方案 在C盘的windows 目录下有个 py.exe 我们用p
moviepy安装过程中的问题
在测试ObjectDetectionAPI过程中遇到了一些问题,做个记录。以备后用。 1、安装moviepy过程中,在cmd下,使用pip命令pip install moviepy安装遇到如下问题: 1.  Exception:   2.  Traceback (most recent call last):   3.    File "C:\ProgramData\
关于在python3.5下配置opencv3.0出现的问题
最近想在Python中使用opencv库进行图像处理。遇到了一些问题, 首先我的Python版本是3.5 64 bit,opencv版本是3.0。这2个东西的安装不再说明。 在CMD中敲入 python -m pip install -U pip 安装PIP。安装完后将pip的路径加到PATH里,例如”C:\Python27\Scripts”(这些如果在安装python时候全部打上勾应该自动
Pip 安装pymongo失败
需要用pip install pymongo 安装pymongo用于连接mongodb。但是试了很多次都不行。尝试使用代理后,成功安装。pip install pymongo -i http://pypi.douban.com/simple/ --trusted-host pypi.douban.com...
Python—解决pip版本更新无法继续安装第三库问题
在装第三方库时,使用pip install 进行安装时,可能会出现这样的情况   由于网络原因导致第三库无法安装时,误以为确实是版本的问题 于是就手贱的把python安装文件夹script里面的pip手动删除了,以及lib里sit-packages里的pip文件夹也删了,然后将高版本的直接解压到了lib的sit-packages里,话说也是很傻了,初学者易犯的错误啊。 然后就导致再继续安装...
Termux 详细安装 -- 解决 pip 更新 , scrapy 无法安装问题
     Termux是一款强大的安卓终端模拟APP,无需root直接启动,自动安装最小化linux系统,支持apt管理软件包,完美支持python,ruby,go,nodejs。一.软件下载:    两个不需要翻墙的方法:    1.酷安网下载: https://www.coolapk.com/apk/com.termux         可以将termux成功安装到手机。但此版本在安装Beau...
pyodbc安装问题
最近在新服务器上安装pyodbc,遇到安装上的问题: error: initializer expression list treated as compound expression 总认为是C/C++编译器的支持不够,没有成功。 再次确定是否unixodbc是否支持不够,安装好unixodbc-devel也没有成功。 仔细看看错误的原因,才知道没找到 python.c,执行: y
Windows下使用命令安装Python的scipy库出错的解决
python 安装scipy,matplot等数学库。
pip装了一个包,但是python里Import的时候出错的处理办法
具体处理如下: 第一步:打开setting 第二步:打开项目的解析器,再点开设置图标,选择Add Loacl ... 第三步:选择existing environment,选择Anaconda3/python.exe文件,点击确定即可。 ...
推荐系统算法库scikit-surprise安装问题的解决
有关推荐系统算法库scikit-surprise安装问题的解决 scikit-surprise的使用官网算是比较详细的了,但安装经常会出现问题,本文对scikit-surprise库安装的可能问题给出了解决办法。 安装 一般情况可以直接用: pip install numpy ##scikit-surprise需要依赖numpy,如果已经安装则不需要此步 pip instal...
Windows安装Anaconda导致原有python pip无法使用问题
        今天在Windows上安装Anaconda,安装完成后再使用Python时,用Pycharm创建Virtualenv Environment类型的工程文件时,在用部分第三方库会显示未安装该模块。     然后打开cmd,使用pip命令暗转numpy库,那么问题来了,开始疯狂报错........     然后发现,使用的pip是Anaconda中的pip,那么如何在不适用Anacon...
Python-docx安装失败
报错:’libxml/xmlversion.h’ file not found先在终端输入: xcode-select –install 会提示安装,安装然后再 pip install python-docx 如果再报: error: could not create ‘/Library/Python/2.7/site-packages/lxml’: Permission denied
windows下多版本python与pip安装和pip使用.docx
windows7 下多版本python与pip安装和pip使用。包括python2和python3下安装使用pip
python以及pip在win10中的安装(64位操作系统)
系统信息:win10,64位 1、python官网下载python3.5.3-amd64.exe; 2、完成后直接运行。期间有是否下载pip的选择,选择上,pip就自动安装好了。 3、环境变量也在安装时自动装好。 最后输入:在cmd中输入python显示: Python 3.5.3 (v3.5.3:1880cb95a742, Jan 16 2017, 16:02:32) [MSC v.1
python3.6 安装Twisted出错怎么办
从pip 里安装发现如下出错:要解决这个问题,只能到网站:下载地址:http://www.lfd.uci.edu/~gohlke/pythonlibs/下载到文件:Twisted-17.5.0-cp36-cp36m-win_amd64.whl然后安装:pip install Twisted-17.5.0-cp36-cp36m-win_amd64.whl这样才可以安装成功。最后就可以安装: pip 
windows环境下python安装pycrypto遇到的问题解决
最近在学习使用python管理服务器,所以需要使用ssh等远程登录服务。在安装对于的python库pycrypto的时候,遇到了一些小问题,终于在参考别人的方法之后,成功安装。     我使用的是python 2.7.13版本,有些问题在python3下解决方法不同。     首先,。一般在官方网站下载:https://www.dlitz.net/software/pycrypto/。然后使用
python安装PIL失败原因及解决方案
在windows下的虚拟环境安装PIL: pip install PIL 出现报错信息: 原因: 经过查询资料发现,python2可以使用pip install PIL安装PIL第三方包。而我是使用的是python3,现在python3已经用Pillow代替PIL。 解决办法: 使用 pip install Pillow 安装即可,效果如下: ...
Linux下将python2.6升级到2.7 安装pip 以及升级中遇到问题的解决方法
python2.6版本有很多局限性:最重要的就是,当前最新的pip版本已经不再支持python2.6;这给我们安装很多python库增加了很多不便;所以这里把我升级python2.6--2.7的过程及遇到的坑 记录一下:实验系统版本centos6+ ;centos7+版本自带的python版本就是2.7+的。第一步:安装相关的编译依赖包:[root@lexsaints ~]# yum instal...
pip install pyltp报错解决办法
报错一:error: Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual C++ Build Tools”: http://landinghub.visualstudio.com/visual-cpp-build-tools笔者安装Microsoft Visual C++ 14.0后,依然不能顺利安装pyltp,...
pip使用问题汇总
使用pip遇到错误ImportError: No module named packaging.version的解决方法 本人Python默认是2.7,然而pip指定路径是python3.6 由于需要用到pip,所以在Ubuntu上安装了一个,由于Python是2.7版本的,所以装的并不是pip3。 附pip安装命令: sudo apt-get install python-pip...
文章热词 机器学习教程 Objective-C培训 交互设计视频教程 颜色模型 设计制作学习
相关热词 mysql关联查询两次本表 native底部 react extjs glyph 图标 python删除pip教程 javaee学习安装