Vue初学者问题:webstorm里js报错
 <template>
<div>
  <h1>{{msg}}</h1>
</div>
</template>

<script>
  export default {
    name: 'NewHello',
    data (){
      return {
        msg:'Hello World'
      }
    }
  }
</script>

<style scoped>

</style>

图片说明

请问我的vue模板里js区域是什么原因出错啊?我初学Vue,不懂,我的IDE是webstorm,配置支持了ES6的。

图片说明

0

1个回答

你看报错的内容,你不应该缩进的地方出现了两个空格的缩进,所以说是缩进格式问题。。。去掉应该就可以了

0
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
webstorm 开发vue.js项目总提示空格报错
 webstorm总是提示空格报错,然后怎么删除都不行  看了下网上的 方法,修改.eslintrc.js // https://eslint.org/docs/user-guide/configuring module.exports = { root: true, parserOptions: { parser: 'babel-eslint' }, env:...
webstorm中es6语法报错,.vue文件中es6语法报错
1.webstorm中es6语法报错,解决方法:打开 Settings =&amp;gt; Languages &amp;amp; Frameworks =&amp;gt; Javascript把 Javascript Language version 改为 ECMAScript 6这样做所有的.js文件中es6不再报错,但是.vue文件中es6语法依然报错。2.  .vue文件中es6语法报错(1)打开 Setting...
webstorm 在编写Vue过程中出现空格不规范报错的问题
build文件夹下的webpack.base.conf.js文件。 注释或删除这些代码 注释掉之后(重启vue服务),再进行子页面等编写的时候,空格不规范的情况下也不会再报错啦。 ...
vue指令在webstorm里面报错解决方法
image.png 打开setting--inspections--XML,把 Unbound XML namespace prefix的勾去掉; 如果想让webstorm支持vue代码提示的话,推荐http://blog.csdn.net/mingcai_xiong/article/details/55652645 ...
webstorm升级2017.1后vue文件中的sass报错、报红问题
webstorm升级2017.1后vue文件中的sass报错
webstrom中js文件JSHint报错问题
首先我的报错是这样的,但是js文件是可以被执行的 修改方案file-&amp;gt;setting,在其中搜索jshint设置 将选项设置为 Default即可
初学者可能不知道的 vue.js技巧
技巧/坑点 1.setTimeout/ setInterval 场景一 :this指向改变无法用this访问vue实例 mounted(){ setTimeout( function () { //setInterval同理 console.log(this); //此时this指向Window对象 },1000) ; } 解决方法 :使用箭头函数或者缓...
webstorm和vue中es6语法报错的解决方式
1.webstorm中es6语法报错,解决方法: 打开 Settings =&amp;gt; Languages &amp;amp; Frameworks =&amp;gt; Javascript 把 Javascript Language version 改为 ECMAScript 6 这样做所有的.js文件中es6不再报错,但是.vue文件中es6语法依然报错。 .vue文件中es6语法报错 (1)打开 Sett...
webstorm 的es6设置之后还是出现红线的解决方式
1,设置的时候我的mac 需要设置2个地方 在文件中设置之后 还要在preferences  和default 2这个是专制看着不舒服的实际是治标不治本  在webstorm下边有个设置高亮的地方 调节到前边2个就好了     3 这是个别人的问题  就是用webstorm打开代码的时候 需要检查打开的文件夹中是否含有其他 webstorm不支持的文本格式  如zip,xmin...
Webstorm 代码格式化空格不一致问题
问题背景:vue开发,使用ESLlint作为代码格式校验问题描述:webstorm for windows和for mac os,使用快捷键代码格式化结果不一致,导致有些格式需要自己手动修改的问题。问题图述:mac环境-格式化前:mac环境-格式化后:windows环境-格式化后问题就在于,在windows环境下data后面的空格消失了,如何与mac os保持一直?解决方法:1.将webstorm...
webstorm之Vue未知html标签警告取消方法
-
webstorm中es6红色波浪线报错
webstorm中es6红色波浪线报错 **Webstrom -&amp;gt; Preferences -&amp;gt; Languages &amp;amp; FrameWorks -&amp;gt; JavaScript 选择ES6,然后重新打开以下文件** 设置–语言–javascript–选择es6版本,setting–language–javascript–ECMAScript 6.0; 简单做法,点击键盘...
在webstorm中编译vue模板使用less,webstorm报错的解决方案
&amp;lt;style scoped lang='less' type='text/less'&amp;gt; .demo { .list{ color: red; } } &amp;lt;/style&amp;gt;
webstrom使用es6语法报错
es6更新了很多的语法,这些语法并不是所有的浏览器都支持,由于webstrom默认的是es5语法,使用es6会提示报错。尤其是在使用vue框架的时候。很是烦人,这是因为webstorm默认的是支持es5语法,不支持es6语法。只要将webstrom设置成es6即可 如图: 改完之后,由于有的浏览器不支持es5,最好有个东西能够自动将其转换为es5就好了。这个时候可以安装 Babel 执行 np
webstorm已经设置了ES6,.js文件还是出现了红色波浪警告(VUE-CLI项目中)
原先版本:webstorm 2016。 报错:在router.js中出现大量红色波浪警告!网友提示为:(file--&gt;setting--&gt;languages and framworks--&gt;javascript--&gt;ECMAScript6) 最开始我的是ES5,然后换成了ES6,还是有少量波浪,然后百度又说需要babel来改变:es5--&gt;es6,然后并没有什么用...
webstrom中vue文件编译报错
1.webstorm中es6语法报错,解决方法:打开 Settings =&amp;gt; Languages &amp;amp; Frameworks =&amp;gt; Javascript把 Javascript Language version 改为 ECMAScript 6这样做所有的.js文件中es6不再报错,但是.vue文件中es6语法依然报错。 2.  .vue文件中es6语法报错(1)打开 Settin...
webstorm 配置Vue.js 语法提示
1.5 解决写模板的时候没有vue指令智能提示:设置 – Inspections – HTML – Unknown HTML tags,添加customs v-text v-html v-once v-if v-show v-else v-for v-on v-bind v-model v-ref v-el v-pre v-cloak v-on:click v-on:
webstrom编译.vue遇到的报错问题
1.webstorm中.vue文件中写stylus,总是出现警告和错误,但不影响编译 解决方案1: 装个vue插件,idea 里面插件名:vue-for-idea 解决方案2: 新版本的webstorm(2012以上)可用下面的方式解决: &amp;amp;amp;lt;style lang=&amp;amp;quot;stylus&amp;amp;quot; rel=&amp;amp;quot;stylesheet/stylus&amp;amp;quot;&amp;amp;amp;gt;
关于webstorm编辑器识别less的问题,我是在vue里使用less
不知道是不是版本的原因,大家请记住最新的webStorm(2017版的)是这样配置less的&amp;lt;style scoped lang=&quot;less&quot; type=&quot;text/less&quot;&amp;gt; export default{ ··· } &amp;lt;/style&amp;gt;是改type=&quot;text/less&quot; 改 rel 是没用的。...
关于webstorm 对 vue的设置
首先安装vue插件,安装方法:  setting –> plugin ,点击plugin,在内容部分的左侧输入框输入vue,会出现两个关于vue的插件,点击安装即可。安装完成后,就可以看到,新建文件时,会有vue文件的提示。  如下图所示:    设置vue新建文件模板。  步骤: settings –> file and code templates .在内容区域左侧点击vue f
解决在WebStorm中使用Vue的v-bind,v-on报错
虽然这个报错并不会影响代码执行,但看起来就像代码写错了一样,不爽 解决方法: 在webstrom设置里找到XML,把 Unbound XML namespace prefix的勾去掉 对于不同版本的 WebStorm,这个选项有可能不在同一个位置,如果按这个步骤找不到,就直接搜索 Unbound XML namespace prefix ...
WebStorm中let关键字报错解决办法。
let报错是因为WebStorm默认版本是ECMAScript5而let是6中才出现的,所以报错咯。解决方法,修改版本到6.
webstorm不能识别一些js方法,如require
直接上图吧 js运行不会报错,但webstorm却不认识这个方法,怎么办呢? 添加个支持就好了 还是直接上图吧 ECMAScript中几乎包含了当前所有开源js的源码支持。 我这边需要的是nodejs的require方法。 上面实际上我已经下载了Nodejs,我把他删除了重新下载。 下载好之后 require方法就可以识别啦,还可以直接看源码。 其他的一些方法支持
为什么webstorm中语法没有错误却有红线?
1.为什么webstorm中语法没有错误却有红线? 描述:当我在做一个项目用vuecli的时候,再更改的过程中出现了如图所示的错误 ,因为我仅仅只改了一个主页面,就是将App.vue里面的内容删除了,这个问题应该怎样解决呢? 根据错误提示,我们知道是当前JavaScript版本不支持导入声明 解决方法: 第一步:点击webstorm上面的File 第二步:Ctrl+Alt+S 第三步: 第四步:...
关闭WebStrom在写vue的import使用双引号报错提示
在webstorm的设置里面找到以下图片的位置将enable勾选去掉即可
关于webstorm的报错,警告等方式的提醒设置
前俩天webstorm突然就对node,es6等语法提示,出现这样的情况 该代码是可以运行的,逼死强迫症,通过百度等各种方式,然后确定可以使用下列方法设置提示方式。 如过出现不能识别es6或是node语法,运行提示错误,则可以通过下面方式设置...
webstorm开发vue组件时,支持scss/less等预处理语言
vue组件支持预处理语言的关键点: <style rel="stylesheet/scss" lang="scss"> .mint-swipe { height: 300px; .mint-swipe-indicators { width: 98%; text-align: right; left: 0;
webstorm 里面vue 文件显示高亮的问题
    在设置里面的Plugin  搜vue  ,如果没有就下载vue.js      然后重启webstorm    然后在编辑器的文件和代码模板里面添加vue  File  ,并且设置模板    &amp;lt;template&amp;gt;&amp;lt;/template&amp;gt;    &amp;lt;script&amp;gt;&amp;lt;/script&amp;gt;    &amp;lt;style&amp;gt;&amp;lt;/style&amp;gt;   ...
webstorm 设置ES6语法支持以及添加vuejs开发配置
本篇文章主要是针对上篇博客vue项目构建中构建的项目在webstorm中的一些ES6语法支持以及vue高亮和语法支持。webstorm中ES6语法配置当我们用webstorm打开我们所构建的elma项目中的main.js文件的时候,发现有标红的红线,原因是webstorm不支持es6语法,需要配置一下。 配置方法: 打开file–>setting,做如下操作 如果想实现es6直接转化为
webstorm中.vue格式文件中代码高亮显示
http://blog.csdn.net/qq_33008701/article/details/56486893
vue 红色波浪线报错
报错的原因:es6的问题 解决:phpstorm -&amp;gt; preferences -&amp;gt; 语言和框架 -&amp;gt; JavaScript -&amp;gt; js的版本改成ECMAScrept 6
webstorm下vuejs开发配置
(1)vue.js插件安装 1、file-->setting-->plugins-->Browse repositories, 搜索vue.js 2、点击Install,即可。 (2)配置自动更新 file-setting-system setting
在WebStorm中添加Vue.js单文件组件的高亮及语法支持
能来看这篇文章的想必不用我来介绍vue是什么了。先让我们膜拜大神!vue项目的创建者尤大写了个sublime下语法高亮的插件,有人问他how about webstorm support?他是这么回答的。默哀一分钟。
[webstorm设置] 红色波浪线报错
[webstorm设置] 对es6语法红色波浪线报错 是因为编辑器没有设置为es6语法 解决步骤: settings -&amp;gt;Languages &amp;amp; FrameWorks -&amp;gt; JavaScript -&amp;gt;选择es6语法则可以 ...
WebStorm JS中出现大量红色波浪
[size=large][size=large][size=medium]最近是用React-native来实现夸平台的项目,同事建立好的工程,我git clone下来之后在我的环境打开之后,满屏的红色波浪线,但可以项目可以正常编译运行。问了同事他们会不会这样,他们说不会,去看了同事的配的环境得版本都不一样,我的node version是v8.1.2,npm是5.0.3 后来发现需要在设置工...
webstorm 调整js缩进量
webstorm调整缩进量,ctrl + alt + s打开settings,找到editor下的code style 下的javascript,点击就会出现调整缩进的设置。如果调整完之后,没有变化,这时要注意了,你得js代码是不是写在了html页面中,如果是可以调整下html的缩进或者拿出来放在js文件下。
webstorm 写Vue项目中遇到的坑
1.单词底部有波浪线,提示typo in word 打开偏好设置,输入typo,找到右侧的Effects,选择不勾选,立即解决。 2.Unresolved variable or type module 解决办法
使用vue框架运行npm run dev 时报错解决
使用使用vue框架运行npm run dev 时报错 如下: 原因:  localhost:8080 有可能其他软件占用了,导致其他问题的出现 我们可以动态修改地址 解决:     进入项目文件的config文件夹E:\myapp\myproject\config,找到index.js,修改里面的8080端口,改成8088(确定不被别的程序使用的都可以) 解
WebStorm编写RN JS中出现大量红色波浪
最近是用React-native来实现夸平台的项目,同事建立好的工程,我git clone下来之后在我的环境打开之后,满屏的红色波浪线,但可以项目可以正常编译运行。问了同事他们会不会这样,他们说不会,去看了同事的配的环境得版本都不一样,我的node version是v8.1.2,npm是5.0.3 后来发现需要在设置工程的 JavaScript: File–&gt;settings–&gt;Lan...
WebStorm 里 import 文件的时候使用单引号
自动 import 的时候, 文件名用了双引号, 每次都得改, 可以改一下设置: 顺便, 把列表总是加上 , 也设置了: References How to change the default double quote marks to single quote mark in Intellij(IDEA) once yo...
文章热词 机器学习教程 Objective-C培训 交互设计视频教程 颜色模型 设计制作学习
相关热词 mysql关联查询两次本表 native底部 react extjs glyph 图标 产品经理初学者 区块链初学者