weixin_39086917
2019-01-11 10:41
采纳率: 33.3%
浏览 4.8k

pycharm使用时,出现模块调用失败,怎么解决?

Traceback (most recent call last):
File "C:/Temp/lassos/first.py", line 4, in
from sklearn.preprocessing import Imputer
File "C:\Users\Dell\Anaconda3\lib\site-packages\sklearn__init__.py", line 134, in
from .base import clone
File "C:\Users\Dell\Anaconda3\lib\site-packages\sklearn\base.py", line 13, in
from .utils.fixes import signature
File "C:\Users\Dell\Anaconda3\lib\site-packages\sklearn\utils__init__.py", line 10, in
from .validation import (as_float_array,
File "C:\Users\Dell\Anaconda3\lib\site-packages\sklearn\utils\validation.py", line 18, in
from ..utils.fixes import signature
File "C:\Users\Dell\Anaconda3\lib\site-packages\sklearn\utils\fixes.py", line 144, in
from scipy.sparse.linalg import lsqr as sparse_lsqr # noqa
File "C:\Users\Dell\Anaconda3\lib\site-packages\scipy\sparse\linalg__init__.py", line 114, in
from .isolve import *
File "C:\Users\Dell\Anaconda3\lib\site-packages\scipy\sparse\linalg\isolve__init__.py", line 8, in
from .lgmres import lgmres
File "C:\Users\Dell\Anaconda3\lib\site-packages\scipy\sparse\linalg\isolve\lgmres.py", line 10, in
from scipy.linalg import get_blas_funcs, get_lapack_funcs
File "C:\Users\Dell\Anaconda3\lib\site-packages\scipy\linalg__init__.py", line 190, in
from .misc import *
File "C:\Users\Dell\Anaconda3\lib\site-packages\scipy\linalg\misc.py", line 5, in
from .blas import get_blas_funcs
File "C:\Users\Dell\Anaconda3\lib\site-packages\scipy\linalg\blas.py", line 214, in
from scipy.linalg import _fblas
ImportError: DLL load failed: The specified module could not be found.

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

相关推荐 更多相似问题