xiaqing0403
ashley.xia
采纳率0%
2021-03-04 17:05

VSCode:Python Tools server报错

VSCode报错:The Python Tools server crashed 5 times in the last 3 minutes. The server will not be restarted.

出现原因:左下角切换python版本导致

1.系统首先安装python3.9.0版本

2.安装python扩展程序,此时一切正常,所有提示都可以

3.安装python3.7.6版本

4.重新加载python扩展,提示标题所示错误

5.更换回python3.9.0版本,正常运行

6.难道3.7.6版本的python,就不能使用python扩展了吗?

补充:中间将3.9.0的版本卸载了,安装的3.7.6,但是3.7.6版本仍然不行,后续重新安装3.9.0发现又可以!

希望两个版本的python都能正常运行!!!

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

1条回答

  • qq_34124780 qq_34124780 1月前

    你想多了,说个简单的numpy,py37和py39都不能共用,更不用说其他扩展了,一般每个包都是只能对应版本的用

    点赞 评论 复制链接分享