编程介的小学生 2019-02-20 21:26 采纳率: 20.5%
浏览 386

第m大的质因数的计算的方式,如何不排序去求解?采用C语言的计算

Problem Description
Now give you two integers n m, you just tell me the m-th number after radix point in 1/n,for example n=4,the first numble after point is 2,the second is 5,and all 0 followed

Input
Each line of input will contain a pair of integers for n and m(1<=n<=10^7,1<=m<=10^5)

Output
For each line of input, your program should print a numble on a line,according to the above rules

Sample Input
4 2
5 7
123 123

Sample Output
5
0
8

  • 写回答

1条回答 默认 最新

  • IT学长 2019-02-21 11:39
    关注

    不知道能否有用

    #include<stdio.h>
    
    int arr[100000];
    l=0;
    void fun(int n)
    {
        int temp=n%10;
        if(temp<0) temp=-temp;
        arr[l++]=temp;
    }
    int main()
    {
        long long n,m;
        int i;
        while(scanf("%lld %lld",&n,&m)!=EOF)
        {
           double temp=1.0/n;
           double tt=1.0;
           for(i=1;i<=m;i++)
           {
               tt*=10;
           }
           temp*=tt;
           fun((int)temp);
          // printf("%lf\n",temp);
        }
        for(i=0;i<l;i++)
            printf("%d\n",arr[i]);
        return 0;
    }
    
    
    评论

报告相同问题?

悬赏问题

  • ¥15 HFSS 中的 H 场图与 MATLAB 中绘制的 B1 场 部分对应不上
  • ¥15 如何在scanpy上做差异基因和通路富集?
  • ¥20 关于#硬件工程#的问题,请各位专家解答!
  • ¥15 关于#matlab#的问题:期望的系统闭环传递函数为G(s)=wn^2/s^2+2¢wn+wn^2阻尼系数¢=0.707,使系统具有较小的超调量
  • ¥15 FLUENT如何实现在堆积颗粒的上表面加载高斯热源
  • ¥30 截图中的mathematics程序转换成matlab
  • ¥15 动力学代码报错,维度不匹配
  • ¥15 Power query添加列问题
  • ¥50 Kubernetes&Fission&Eleasticsearch
  • ¥15 報錯:Person is not mapped,如何解決?