1455:An Easy Problem
查看提交统计提问
总时间限制: 1000ms 内存限制: 65536kB
描述
As we known, data stored in the computers is in binary form. The problem we discuss now is about the positive integers and its binary form.
Given a positive integer I, you task is to find out an integer J, which is the minimum integer greater than I, and the number of '1's in whose binary form is the same as that in the binary form of I.
For example, if "78" is given, we can write out its binary form, "1001110". This binary form has 4 '1's. The minimum integer, which is greater than "1001110" and also contains 4 '1's, is "1010011", i.e. "83", so you should output "83".
输入
One integer per line, which is I (1 <= I <= 1000000).
A line containing a number "0" terminates input, and this line need not be processed.
输出
One integer per line, which is J.
样例输入
1
2
3
4
78
0
样例输出
2
4
5
8
83
#include <iostream>
#include <cstring>
using namespace std;
int a[21],b[21],len,t,n,m;
void lowtrans(int);
void uptrans(int y[],int l);
int main()
{
while(cin >> n && n)
{
memset(a,0,sizeof(a)); memset(b,0,sizeof(b));
lowtrans(n);
for(int i = 2; i <= len; i++)
{
if(!(a[i]))
{
b[i] = 1;
for(i = 1; i <= t; i++) b[i] = 0;
break;
}
}
uptrans(b[len + 1],len + 1);
}
return 0;
}
void lowtrans(int x)
{
len = 1; t = 0;
while(x % 2)
{
x /= 2;
a[len] = x % 2;
if(a[len]) t++;
len++;
}
cout << "lowtrans : ";
for(int i = 1; i <= len; i++) cout << a[i];
cout << endl;
}
void uptrans(int y[],int l)
{
for(int i = 1; i <= l; i++)
{
if(y[i])
for(int j = i; j > 0; j--)
y[i] *= 2;
b[i] = y[i];
}
cout << "uptrans : ";
for(int i = 1; i <= len; i++) cout << a[i];
cout << endl;
}