编程介的小学生 2019-04-02 00:19 采纳率: 20.5%
浏览 352

计算比最大公约数小的数字的和怎么算,采用C语言程序设计的技术的办法

Problem Description
We call a positive number X P-number if there is not a positive number that is less than X and the greatest common divisor of these two numbers is bigger than 1.
Now you are given a sequence of integers. You task is to calculate the sum of P-numbers of the sequence.

Input
There are several test cases.
In each test case:
The first line contains a integer N(1≤N≤1000). The second line contains N integers. Each integer is between 1 and 1000.

Output
For each test case, output the sum of P-numbers of the sequence.

Sample Input
3
5 6 7
1
10

Sample Output
12
0

  • 写回答

1条回答 默认 最新

  • wudengyu 2019-04-02 22:02
    关注
    #include <stdio.h>
    int prime(int x) {
        for (int i = 2; i*i < x; i++)
            if (x%i == 0)
                return 0;
        return 1;
    }
    void main() {
        int n,m;
        while (scanf("%d\n", &n) != -1) {
            m = 0;
            for (int i = 0; i < n; i++) {
                int k = 0;
                scanf("%d", &k);
                m +=prime(k)*k;
            }
            printf("%d\n", m);
        }
    }
    
    
    评论

报告相同问题?

悬赏问题

  • ¥15 HFSS 中的 H 场图与 MATLAB 中绘制的 B1 场 部分对应不上
  • ¥15 如何在scanpy上做差异基因和通路富集?
  • ¥20 关于#硬件工程#的问题,请各位专家解答!
  • ¥15 关于#matlab#的问题:期望的系统闭环传递函数为G(s)=wn^2/s^2+2¢wn+wn^2阻尼系数¢=0.707,使系统具有较小的超调量
  • ¥15 FLUENT如何实现在堆积颗粒的上表面加载高斯热源
  • ¥30 截图中的mathematics程序转换成matlab
  • ¥15 动力学代码报错,维度不匹配
  • ¥15 Power query添加列问题
  • ¥50 Kubernetes&Fission&Eleasticsearch
  • ¥15 報錯:Person is not mapped,如何解決?