编程介的小学生 2019-04-02 00:19 采纳率: 20.5%
浏览 352

计算比最大公约数小的数字的和怎么算,采用C语言程序设计的技术的办法

Problem Description
We call a positive number X P-number if there is not a positive number that is less than X and the greatest common divisor of these two numbers is bigger than 1.
Now you are given a sequence of integers. You task is to calculate the sum of P-numbers of the sequence.

Input
There are several test cases.
In each test case:
The first line contains a integer N(1≤N≤1000). The second line contains N integers. Each integer is between 1 and 1000.

Output
For each test case, output the sum of P-numbers of the sequence.

Sample Input
3
5 6 7
1
10

Sample Output
12
0

  • 写回答

1条回答

  • wudengyu 2019-04-02 22:02
    关注
    #include <stdio.h>
    int prime(int x) {
        for (int i = 2; i*i < x; i++)
            if (x%i == 0)
                return 0;
        return 1;
    }
    void main() {
        int n,m;
        while (scanf("%d\n", &n) != -1) {
            m = 0;
            for (int i = 0; i < n; i++) {
                int k = 0;
                scanf("%d", &k);
                m +=prime(k)*k;
            }
            printf("%d\n", m);
        }
    }
    
    
    评论

报告相同问题?

悬赏问题

  • ¥50 永磁型步进电机PID算法
  • ¥15 sqlite 附加(attach database)加密数据库时,返回26是什么原因呢?
  • ¥88 找成都本地经验丰富懂小程序开发的技术大咖
  • ¥15 如何处理复杂数据表格的除法运算
  • ¥15 如何用stc8h1k08的片子做485数据透传的功能?(关键词-串口)
  • ¥15 有兄弟姐妹会用word插图功能制作类似citespace的图片吗?
  • ¥200 uniapp长期运行卡死问题解决
  • ¥15 latex怎么处理论文引理引用参考文献
  • ¥15 请教:如何用postman调用本地虚拟机区块链接上的合约?
  • ¥15 为什么使用javacv转封装rtsp为rtmp时出现如下问题:[h264 @ 000000004faf7500]no frame?