Vivianluolita
Vivianluolita
采纳率70.9%
2019-04-09 19:24

react脚手架项目npm start报错,求大佬指点

5

npm start之后报错

图片说明
####报错信息:

./src/index.js
Module build failed: Error: The 'decorators' plugin requires a 'decoratorsBeforeExport' option, whose value must be a boolean. If you are migrating from Babylon/Babel 6 or want to use the old decorators proposal, you should use the 'decorators-legacy' plugin instead of 'decorators'.```

### 解决:
- 网上说的:<br>
- ```.babelic文件 修改```

图片说明

{
"presets": [
"module:metro-react-native-babel-preset",
"@babel/preset-flow"
],
"plugins": [
["@babel/plugin-proposal-decorators", { "legacy" : true }]
]
}

- 更新以使用这些插件的Babel 7版本,例如@babel/plugin-proposal-decorators和@babel/plugin-proposal-class-properties

## 都不起作用!!大佬来帮帮我!!
  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

3条回答

  • qq_35366269 郭宝 2年前

    删除项目的node_modules文件夹,然后重新npm install即可

    点赞 评论 复制链接分享
  • qq_28496877 qq_28496877 2年前
            "plugins": [
                ["@babel/plugin-proposal-decorators", { "legacy": true , "decoratorsBeforeExport": true}],
            ]
    
    点赞 评论 复制链接分享
  • dabocaiqq dabocaiqq 2年前
    点赞 评论 复制链接分享

相关推荐