zhuchenxi113 2021-11-17 23:48 采纳率: 100%
浏览 62
已结题

python版本更新这么快,难以适应怎么办?

学那会儿才3.8.1,现在都3.10了。以前总结经验不要轻易升级最新版本Python,很多第三方库可能还没适配。于是不升虚拟机的Python,把主机的版本换成了3.10,发现不只是Python,很多模块后面的版本都多多少少有些变化,什么request变parse,模块变名字等等。如果坚持用旧版本Python编程的话,多年以后会不会像个野人,都不敢随意升级任何一个库?但是升又要一直使用变化,一直百度,Python就没有那种非常稳定,人群基数特别大,支持特别久的版本吗?我的3.8.1好像也就支持到2025年,话说支持都都支持些什么内容,版本内小修小改吗?那么不涉及影响程序运行的关系也不大。哎,一日编程,终身学习。

  • 写回答

4条回答 默认 最新

  • CSDN专家-HGJ 2021-11-18 01:37
    关注

    其实个人觉得用得比较舒适,与各种库较为适配的版本就可,比如3.7.X,3.8.x都不错,没必要’追新‘。因为确实有些库会更新跟不上影响使用。一个例外情况是有重大更新,或者所经常使用的库需要python更高版本时即要更新到高一些稳定版本中。

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(3条)

报告相同问题?

问题事件

  • 系统已结题 11月26日
  • 已采纳回答 11月18日
  • 创建了问题 11月17日

悬赏问题

  • ¥50 悬赏帮写C++编程 诚信
  • ¥15 在竞速练习时输出和输入可以同时进行
  • ¥15 安卓数据提交之后格式不对
  • ¥15 需要数据库运行的图片
  • ¥15 如何获取vue-video-editor?
  • ¥100 vs2019 mfc程序如何实现64*64/48*48大小的真彩色工具栏
  • ¥15 全志v3s耳机音频输出口怎么外接功放
  • ¥15 华为ensp使用基本ACL限制公司网络访问
  • ¥15 帮我做下照片上的PLC题
  • ¥15 labview2022 使用modbus报缺少依赖?