今天开始减肥了吗? 2021-11-27 16:45 采纳率: 72.5%
浏览 63
已结题

The first line is a number The second line is an operator (+,-,*,/) The last line is a number

Input Format:
The first line is a number The second line is an operator (+,-,*,/) The last line is a number

Output Format:
Output the result of an operation(2 decimal places) If the divisor is zero, the error 'divided by zero' is displayed.

Sample Inputs1:
7
/
3
结尾无空行
Sample Output1:
2.33
结尾无空行
Sample Inputs2:
10
/
0
结尾无空行
Sample Output2:
divided by zero
结尾无空行

  • 写回答

2条回答 默认 最新

  • 关注
    x=input()
    code=input()
    y=input()
    if code=='/' and y=='0':
        print('divided by zero')
    elif x.isdigit() and y.isdigit():
        print(round(eval(x+code+y),2),end='')
    

    img

    img

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

问题事件

  • 已结题 (查看结题原因) 11月27日
  • 已采纳回答 11月27日
  • 创建了问题 11月27日

悬赏问题

  • ¥15 Llama如何调用shell或者Python
  • ¥20 eclipse连接sap后代码跑出来空白
  • ¥20 谁能帮我挨个解读这个php语言编的代码什么意思?
  • ¥15 win10权限管理,限制普通用户使用删除功能
  • ¥15 minnio内存占用过大,内存没被回收(Windows环境)
  • ¥65 抖音咸鱼付款链接转码支付宝
  • ¥15 ubuntu22.04上安装ursim-3.15.8.106339遇到的问题
  • ¥15 blast算法(相关搜索:数据库)
  • ¥15 请问有人会紧聚焦相关的matlab知识嘛?
  • ¥15 网络通信安全解决方案