今天开始减肥了吗? 2021-11-27 08:45 采纳率: 72.5%
浏览 63
已结题

The first line is a number The second line is an operator (+,-,*,/) The last line is a number

Input Format:
The first line is a number The second line is an operator (+,-,*,/) The last line is a number

Output Format:
Output the result of an operation(2 decimal places) If the divisor is zero, the error 'divided by zero' is displayed.

Sample Inputs1:
7
/
3
结尾无空行
Sample Output1:
2.33
结尾无空行
Sample Inputs2:
10
/
0
结尾无空行
Sample Output2:
divided by zero
结尾无空行

  • 写回答

2条回答 默认 最新

  • 关注
    x=input()
    code=input()
    y=input()
    if code=='/' and y=='0':
        print('divided by zero')
    elif x.isdigit() and y.isdigit():
        print(round(eval(x+code+y),2),end='')
    

    img

    img

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)
编辑
预览

报告相同问题?

问题事件

  • 已结题 (查看结题原因) 11月27日
  • 已采纳回答 11月27日
  • 创建了问题 11月27日
手机看
程序员都在用的中文IT技术交流社区

程序员都在用的中文IT技术交流社区

专业的中文 IT 技术社区,与千万技术人共成长

专业的中文 IT 技术社区,与千万技术人共成长

关注【CSDN】视频号,行业资讯、技术分享精彩不断,直播好礼送不停!

关注【CSDN】视频号,行业资讯、技术分享精彩不断,直播好礼送不停!

客服 返回
顶部