syfei0518 2022-07-04 14:03 采纳率: 61.1%
浏览 36
已结题

Python库版本冲突怎么办?

已知pytorch版本为1.4.0,CUDA版本为10.1。requirement中要求tensorflow-gpu版本为1.4.0,对应cuda8。这个该如何解决?是下载更高版本的TensorFlow吗?

  • 写回答

3条回答 默认 最新

  • 爱晚乏客游 2022-07-04 15:01
    关注

    0.cuda可以多环境共存,只要设置好环境变量即可。
    1.升级tf到cuda10.1的版本,应该是1.13还是1.12来着,具体你可以去官网查一下对应关系
    2.如果你真的要tf1.4的同时也要torch1.4,那么用anaconda新建环境,这两个环境分开安装,torch1.4+cuda10.1同一个环境,tf1.4+cuda8.0一个环境。

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(2条)

报告相同问题?

问题事件

  • 系统已结题 7月13日
  • 已采纳回答 7月5日
  • 创建了问题 7月4日

悬赏问题

  • ¥15 如何证明高斯噪声的包络公式
  • ¥150 寻找王者荣耀开发作者,合作或者解答
  • ¥15 乳腺癌数据集 相关矩阵 特征选择
  • ¥15 我的游戏账号被盗取,请问我该怎么做
  • ¥15 通关usb3.0.push文件,导致usb频繁断连
  • ¥15 有没有能解决微信公众号,只能实时拍照,没有选择相册上传功能,我不懂任何技术,,有没有给我发个软件就能搞定的方法
  • ¥15 Pythontxt文本可视化
  • ¥15 如何基于Ryu环境下使用scapy包进行数据包构造
  • ¥15 springboot国际化
  • ¥15 搭建QEMU环境运行OP-TEE出现错误