fuys_Simon 2022-08-18 14:47 采纳率: 40%
浏览 60
已结题

MQTT broker的版本号如何确定?

问题遇到的现象和发生背景

本人最近在依据MQTT_paho库写一个MQTT client,MQTT_paho库的一些参数选择是与服务器端的MQTT broker的版本号相关的,但是我用 sudo mosquitto 安装完MQTT broker之后,参看版本号时,发现是MQTT v3.1/v3.1.1 Broker,如下图:

img

操作环境、软件版本等信息

操作系统是 Ubuntu 22.04

我想要达到的结果

我想要问的是,“MQTT v3.1/v3.1.1 Broker”指的是 MQTT broker的版本是 3.1 还是3.1.1, 或者说是 既可以把它当做3.1版本,也可以把它当做3.1.1版本?

请教!

  • 写回答

2条回答 默认 最新

  • .魚肉 2022-08-18 14:59
    关注

    好像是支持两个版本的mqtt协议

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

问题事件

  • 系统已结题 8月27日
  • 已采纳回答 8月19日
  • 创建了问题 8月18日

悬赏问题

  • ¥30 代码本地运行正常,但是TOMCAT部署时闪退
  • ¥15 关于#python#的问题
  • ¥15 主机可以ping通路由器但是连不上网怎么办
  • ¥15 数据库一张以时间排好序的表中,找出多次相邻的那些行
  • ¥50 关于DynamoRIO处理多线程程序时候的问题
  • ¥15 kubeadm部署k8s出错
  • ¥15 Abaqus打不开cae文件怎么办?
  • ¥20 双系统开机引导中windows系统消失问题?
  • ¥15 小程序准备上线,软件开发公司需要提供哪些资料给甲方
  • ¥15 关于生产日期批次退货退款,库存回退的问题