退堂鼓艺术家459 2022-09-21 16:51 采纳率: 0%
浏览 23

libselinux-devel-2.9-5.el8. i686 has inferior architecture

问题遇到的现象和发生背景

最近花了近一个月写了一个基于SpringBoot的前后端分离系统。但在使用XShell进行网站部署的同时,需要用Nginx。在安装Nginx前,下载相关依赖包的时候遇到了这个问题,在网上搜索了一下也没得到一个结果,不知道为什么,希望能解答。

运行结果及报错内容

输入指令:yum -y install gcc gcc-c++ automake pcre pcre-devel zlib zlib-devel openssl-devel
结果中显示的错误:libselinux-devel-2.9-5.el8.i686 has inferior architecture

img

恳请解答。
  • 写回答

1条回答 默认 最新

  • IT民工金鱼哥 运维领域新星创作者 2022-09-22 09:09
    关注

    img

    问题1,先明确已经弄好YUM源,包括基础源,EPEL源
    问题2,提示有包冲突,所以,找出冲突的包,然后做法有2个,1:卸载冲突的包,再重装1次,2:按图片的参数进行尝试。
    我的做法一般都是卸载冲突的,重新进行安装。

    评论

报告相同问题?

问题事件

  • 创建了问题 9月21日

悬赏问题

  • ¥15 显示两个unsuccessful(标签-pytorch|关键词-软件版本)
  • ¥15 串口通信传输字符的质量控制
  • ¥50 xslt如何让block撑满页面
  • ¥15 vs的显示无法启动IIS Express Web服务器,怎么解决?
  • ¥20 一个python博客项目的相关图例
  • ¥15 轮廓提取也提取不到,有没有别的方法,如何解决?
  • ¥50 Js和c++如何将含有图片的excel文件上传到后台服务器
  • ¥15 光电神经网络,FPGA
  • ¥20 通过防火墙出入站阻止游戏程序联网失效
  • ¥15 鼠标是可以在QT界面上移动的,但是热拔插鼠标无法移动了同时板子上是没问题的,如何解决?