douhuan1257
2017-02-22 18:11
浏览 95
已采纳

找不到类'App \ Http \ Controllers \ Saml2'

I'm on Laravel 5, I'm trying to integrate SAML 2.0 with it. I've found this package = https://github.com/aacotroneo/laravel-saml2

I tried follow their steps,

But at the end when I use

<?php

namespace App\Http\Controllers;

class SAMLController extends Controller {


    public function adminSignIn(){
        return Saml2::login(URL::full());
    }
}

I've already added

provider

'Aacotroneo\Saml2\Saml2ServiceProvider',

aliases

'Saml2'               => 'Aacotroneo\Saml2\Facades\Saml2Auth',

Why do I still getting ?

Class 'App\Http\Controllers\Saml2' not found

Note : I've even retry after sudo composer dumpauto, same result.


I'm opening to any suggestions at this moment.

Any hints / suggestions / helps on this be will be much appreciated !

图片转代码服务由CSDN问答提供 功能建议

我在Laravel 5上,我正在尝试将SAML 2.0与它集成。 我发现这个包= https://github.com/aacotroneo/laravel-saml2

我尝试按照他们的步骤,

但最后我使用

   &lt;?php 
 
namespace App \ Http \ Controllers; 
 
class SAMLController扩展Controller {
 
 
公共函数adminSignIn(){
返回Saml2 :: login(URL :: full());  
} 
} 
   
 
 

我已添加

提供商

 'Aacotroneo \ Saml2 \ Saml2ServiceProvider',
   
 
 

别名 <前> 'Saml2'=&gt; 'Aacotroneo \ Saml2 \ Facades \ Saml2Auth',


为什么我还能得到?

未找到类'App \ Http \ Controllers \ Saml2'

注意: 我甚至在 sudo composer dumpauto 之后重试,结果相同。


我现在正在接受任何建议。

任何提示/建议/帮助都将是 非常感谢!

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

3条回答 默认 最新

  • dongyun8138 2017-02-22 18:13
    已采纳

    You need to use full namespace for the facade:

    \Saml2::login(URL::full());
    

    Or add this to the top of the class:

    use Saml2;
    
    已采纳该答案
    评论
    解决 无用
    打赏 举报
  • duanjinchi1982 2017-02-22 18:17

    Because you modified config/app.php, you may also want to clear config cache:

    php artisan config:cache
    
    评论
    解决 无用
    打赏 举报
  • dongxi8297 2017-02-22 18:57

    you need to explicitly write "use" on top

    use Saml2;

    This might work.

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题