持续总结ing 2019-09-09 20:25 采纳率: 0%
浏览 331
已结题

求助!!c语言编程求解。

  1. 题目描述: Given S, a set of integers, find the largest d such that a + b + c = d where a, b, c, and d are distinct elements of S
  2. 解答要求: 语言:C,时间限制:1000ms, 内存限制:64MB。
  3. 输入: Several S, each consisting of a line containing an integer 1 <= n <= 1000 indicating the number of elements in S, followed by the elements of S, one per line. Each element of S is a distinct integer between -536870912 and +536870911 inclusive. The last line of input contains 0.
  4. 输出:
    For each S, a single line containing d, or a single line containing “no solution”.

  5. 样例
    输入样例
    5
    2
    3
    5
    7
    12
    5
    2
    16
    64
    256
    1024
    0
    输出样例
    12
    no solution

  • 写回答

1条回答 默认 最新

  • threenewbee 2019-09-09 21:46
    关注
    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    #define INF -0x3f3f3f3f
    using namespace std;
    int a[1010];
    int main()
    {
        int n;
        int i,j;
        while(scanf("%d",&n),n)
        {
            for(i=0;i<n;i++)
                scanf("%d",&a[i]);
            sort(a,a+n);
            int ans=INF;
            for(i=n-1;i>=0;i--)
            {
                for(j=n-1;j>=0;j--)
                {
                    if(i==j)
                        continue;
                    int sum=a[i]-a[j];
                    int l=0,r=j-1;
                    while(l<r)
                    {
                        if(a[l]+a[r]==sum)
                        {
                            ans=a[i];
                            break;
                        }
                        if(a[l]+a[r]>sum)
                            r--;
                        else
                            l++;
                    }
                    if(ans!=INF)
                        break;
                }
                if(ans!=INF)
                    break;
            }
            if(ans==INF)
                printf("no solution\n");
            else
                printf("%d\n",ans);
        }
        return 0;
    }
    

    http://www.voidcn.com/article/p-dquihsug-bs.html
    http://www.bubuko.com/infodetail-1473358.html

    评论

报告相同问题?

悬赏问题

  • ¥15 急matlab编程仿真二阶震荡系统
  • ¥20 TEC-9的数据通路实验
  • ¥15 ue5 .3之前好好的现在只要是激活关卡就会崩溃
  • ¥50 MATLAB实现圆柱体容器内球形颗粒堆积
  • ¥15 python如何将动态的多个子列表,拼接后进行集合的交集
  • ¥20 vitis-ai量化基于pytorch框架下的yolov5模型
  • ¥15 如何实现H5在QQ平台上的二次分享卡片效果?
  • ¥15 python爬取bilibili校园招聘网站
  • ¥30 求解达问题(有红包)
  • ¥15 请解包一个pak文件