2201_75986063 2022-12-22 10:25 采纳率: 100%
浏览 34
已结题

R语言载入excel

我从官网下载了最新的14.2的版本R studios(mac),安装后拟导入excel中的数据,结果提示no package of cli。我试图安装instll.package(cli),却提示错误,怎么办。

  • 写回答

1条回答 默认 最新

  • ShowMeAI 2022-12-22 10:35
    关注

    望采纳

    在R中导入Excel数据通常使用readxl包,因此您需要在R中安装该包。

    如果在安装readxl包时提示"no package of cli"错误,则可能是因为你使用的是R高版本,该版本中的readxl包默认不再包含CLI(命令行界面)版本。

    解决此问题的一种方法是使用低版本,它的readxl包默认包含CLI版本。

    另一种方法是在安装readxl包时指定使用CLI版本:

    install.package("readxl", type = "cli")
    
    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

问题事件

  • 系统已结题 12月30日
  • 已采纳回答 12月22日
  • 创建了问题 12月22日

悬赏问题

  • ¥20 Yolov5训练报错
  • ¥15 Unity发布gzip压缩的webgl之后让浏览器可以正常显示画面
  • ¥15 有没有人知道这种提示怎么关?现在不做ts项目了不知道咋关了,求解,现在我以前的js项目都是这种提示了
  • ¥15 为什么mysql做了碎片化处理data_free还是很高
  • ¥15 single positional indexer is out-of-bounds
  • ¥15 LSTM 模型数据量需要多少?
  • ¥15 mysql数据抓包开发报表
  • ¥15 linux系统下安装office打不开
  • ¥20 rsync脚本分发错误,文件不齐全
  • ¥15 labview顺序结构与时间延时