小墨墨墨 2023-02-12 11:38 采纳率: 88.2%
浏览 16
已结题

ubuntu16.04运行qemu时出错

ubuntu16.04运行韦东山lao师提供的qemu时( ./install_sdl.sh )有下面的一堆错误,请问怎么解决啊


正在将 zlib1g-dev:amd64 (1:1.2.8.dfsg-2ubuntu4.1) 解包到 (1:1.2.8.dfsg-2ubuntu4.1) 上 ...
正在设置 libasound2-dev:amd64 (1.1.0-0ubuntu1) ...
dpkg: 依赖关系问题使得 libdbus-1-dev:amd64 的配置工作不能继续:
 libdbus-1-dev:amd64 依赖于 libdbus-1-3 (= 1.10.6-1ubuntu3.4);然而:
系统中 libdbus-1-3:amd64 的版本为 1.10.6-1ubuntu3.6。

dpkg: 处理软件包 libdbus-1-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
正在设置 libdrm-dev:amd64 (2.4.91-2~16.04.1) ...
正在设置 libgles2-mesa:amd64 (18.0.5-0ubuntu0~16.04.1) ...
dpkg: 依赖关系问题使得 libglib2.0-dev 的配置工作不能继续:
 libglib2.0-dev 依赖于 libglib2.0-0 (= 2.48.2-0ubuntu4.4);然而:
系统中 libglib2.0-0:amd64 的版本为 2.48.2-0ubuntu4.8。
 libglib2.0-dev 依赖于 libglib2.0-bin (= 2.48.2-0ubuntu4.4);然而:
系统中 libglib2.0-bin 的版本为 2.48.2-0ubuntu4.8。

dpkg: 处理软件包 libglib2.0-dev (--install)时出错:
 依赖关系问题 - 仍未被配置
正在设置 libmircookie2:amd64 (0.26.3+16.04.20170605-0ubuntu1.1) ...
正在设置 libmircookie-dev:amd64 (0.26.3+16.04.20170605-0ubuntu1.1) ...
正在设置 libmircore-dev:amd64 (0.26.3+16.04.20170605-0ubuntu1.1) ...
正在设置 libpcre32-3:amd64 (2:8.38-3.1) ...
正在设置 libpcrecpp0v5:amd64 (2:8.38-3.1) ...
正在设置 libpthread-stubs0-dev:amd64 (0.3-4) ...
dpkg: 依赖关系问题使得 libpulse-dev:amd64 的配置工作不能继续:
 libpulse-dev:amd64 依赖于 libpulse0 (= 1:8.0-0ubuntu3.10);然而:
系统中 libpulse0:amd64 的版本为 1:8.0-0ubuntu3.15。
 libpulse-dev:amd64 依赖于 libpulse-mainloop-glib0 (= 1:8.0-0ubuntu3.10);然而:
系统中 libpulse-mainloop-glib0:amd64 的版本为 1:8.0-0ubuntu3.15。
 libpulse-dev:amd64 依赖于 libglib2.0-dev;然而:
  软件包 libglib2.0-dev 尚未配置。

dpkg: 处理软件包 libpulse-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 libsdl2-dev 的配置工作不能继续:
 libsdl2-dev 依赖于 libdbus-1-dev;然而:
  软件包 libdbus-1-dev:amd64 尚未配置。
 libsdl2-dev 依赖于 libpulse-dev;然而:
  软件包 libpulse-dev:amd64 尚未配置。

dpkg: 处理软件包 libsdl2-dev (--install)时出错:
 依赖关系问题 - 仍未被配置
正在设置 libsndio6.1:amd64 (1.1.0-2) ...
正在设置 libsndio-dev:amd64 (1.1.0-2) ...
dpkg: 依赖关系问题使得 libudev-dev:amd64 的配置工作不能继续:
 libudev-dev:amd64 依赖于 libudev1 (= 229-4ubuntu21.22);然而:
系统中 libudev1:amd64 的版本为 229-4ubuntu21.31。

dpkg: 处理软件包 libudev-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
正在设置 libwayland-bin (1.12.0-1~ubuntu16.04.3) ...
正在设置 libwayland-dev:amd64 (1.12.0-1~ubuntu16.04.3) ...
dpkg: 依赖关系问题使得 libx11-dev:amd64 的配置工作不能继续:
 libx11-dev:amd64 依赖于 libx11-6 (= 2:1.6.3-1ubuntu2.1);然而:
系统中 libx11-6:amd64 的版本为 2:1.6.3-1ubuntu2.2。

dpkg: 处理软件包 libx11-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
正在设置 libx11-doc (2:1.6.3-1ubuntu2.1) ...
dpkg: 依赖关系问题使得 libx11-xcb-dev:amd64 的配置工作不能继续:
 libx11-xcb-dev:amd64 依赖于 libx11-xcb1 (= 2:1.6.3-1ubuntu2.1);然而:
系统中 libx11-xcb1:amd64 的版本为 2:1.6.3-1ubuntu2.2。
 libx11-xcb-dev:amd64 依赖于 libx11-dev;然而:
  软件包 libx11-dev:amd64 尚未配置。

dpkg: 处理软件包 libx11-xcb-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 libxcursor-dev:amd64 的配置工作不能继续:
 libxcursor-dev:amd64 依赖于 libx11-dev;然而:
  软件包 libx11-dev:amd64 尚未配置。

dpkg: 处理软件包 libxcursor-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 libxdamage-dev:amd64 的配置工作不能继续:
 libxdamage-dev:amd64 依赖于 libx11-dev;然而:
  软件包 libx11-dev:amd64 尚未配置。

dpkg: 处理软件包 libxdamage-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 libxext-dev:amd64 的配置工作不能继续:
 libxext-dev:amd64 依赖于 libx11-dev;然而:
  软件包 libx11-dev:amd64 尚未配置。

dpkg: 处理软件包 libxext-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 libxfixes-dev:amd64 的配置工作不能继续:
 libxfixes-dev:amd64 依赖于 libx11-dev;然而:
  软件包 libx11-dev:amd64 尚未配置。

dpkg: 处理软件包 libxfixes-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 libxi-dev 的配置工作不能继续:
 libxi-dev 依赖于 libx11-dev;然而:
  软件包 libx11-dev:amd64 尚未配置。
 libxi-dev 依赖于 libxext-dev;然而:
  软件包 libxext-dev:amd64 尚未配置。
 libxi-dev 依赖于 libxfixes-dev;然而:
  软件包 libxfixes-dev:amd64 尚未配置。

dpkg: 处理软件包 libxi-dev (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 libxinerama-dev:amd64 的配置工作不能继续:
 libxinerama-dev:amd64 依赖于 libx11-dev;然而:
  软件包 libx11-dev:amd64 尚未配置。
 libxinerama-dev:amd64 依赖于 libxext-dev;然而:
  软件包 libxext-dev:amd64 尚未配置。

dpkg: 处理软件包 libxinerama-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
正在设置 libxkbcommon-dev (0.5.0-1ubuntu2.1) ...
dpkg: 依赖关系问题使得 libxrandr-dev:amd64 的配置工作不能继续:
 libxrandr-dev:amd64 依赖于 libx11-dev;然而:
  软件包 libx11-dev:amd64 尚未配置。
 libxrandr-dev:amd64 依赖于 libxext-dev;然而:
  软件包 libxext-dev:amd64 尚未配置。

dpkg: 处理软件包 libxrandr-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 libxrender-dev:amd64 的配置工作不能继续:
 libxrender-dev:amd64 依赖于 libx11-dev (>= 2:1.0.0);然而:
  软件包 libx11-dev:amd64 尚未配置。

dpkg: 处理软件包 libxrender-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
正在设置 libxshmfence-dev:amd64 (1.2-1) ...
dpkg: 依赖关系问题使得 libxss-dev:amd64 的配置工作不能继续:
 libxss-dev:amd64 依赖于 libx11-dev;然而:
  软件包 libx11-dev:amd64 尚未配置。
 libxss-dev:amd64 依赖于 libxext-dev;然而:
  软件包 libxext-dev:amd64 尚未配置。

dpkg: 处理软件包 libxss-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 libxt-dev:amd64 的配置工作不能继续:
 libxt-dev:amd64 依赖于 libx11-dev;然而:
  软件包 libx11-dev:amd64 尚未配置。

dpkg: 处理软件包 libxt-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 libxv-dev:amd64 的配置工作不能继续:
 libxv-dev:amd64 依赖于 libx11-dev;然而:
  软件包 libx11-dev:amd64 尚未配置。
 libxv-dev:amd64 依赖于 libxext-dev;然而:
  软件包 libxext-dev:amd64 尚未配置。

dpkg: 处理软件包 libxv-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 libxxf86vm-dev:amd64 的配置工作不能继续:
 libxxf86vm-dev:amd64 依赖于 libx11-dev;然而:
  软件包 libx11-dev:amd64 尚未配置。

dpkg: 处理软件包 libxxf86vm-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 mesa-common-dev:amd64 的配置工作不能继续:
 mesa-common-dev:amd64 依赖于 libx11-dev;然而:
  软件包 libx11-dev:amd64 尚未配置。

dpkg: 处理软件包 mesa-common-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
正在设置 x11proto-dri2-dev (2.8-2) ...
正在设置 x11proto-gl-dev (1.4.17-1) ...
正在设置 x11proto-kb-dev (1.0.7-0ubuntu1) ...
正在设置 x11proto-randr-dev (1.5.0-1) ...
正在设置 x11proto-video-dev (2.3.2-1) ...
正在设置 x11proto-xf86vidmode-dev (2.3.1-2) ...
正在设置 x11proto-xinerama-dev (1.2.1-2) ...
正在设置 xorg-sgml-doctools (1:1.11-1) ...
正在设置 xtrans-dev (1.3.5-1) ...
dpkg: 依赖关系问题使得 zlib1g-dev:amd64 的配置工作不能继续:
 zlib1g-dev:amd64 依赖于 zlib1g (= 1:1.2.8.dfsg-2ubuntu4.1);然而:
系统中 zlib1g:amd64 的版本为 1:1.2.8.dfsg-2ubuntu4.3。

dpkg: 处理软件包 zlib1g-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 libegl1-mesa-dev:amd64 的配置工作不能继续:
 libegl1-mesa-dev:amd64 依赖于 libx11-dev;然而:
  软件包 libx11-dev:amd64 尚未配置。
 libegl1-mesa-dev:amd64 依赖于 libxext-dev;然而:
  软件包 libxext-dev:amd64 尚未配置。
 libegl1-mesa-dev:amd64 依赖于 libxxf86vm-dev;然而:
  软件包 libxxf86vm-dev:amd64 尚未配置。
 libegl1-mesa-dev:amd64 依赖于 libxdamage-dev;然而:
  软件包 libxdamage-dev:amd64 尚未配置。
 libegl1-mesa-dev:amd64 依赖于 libxfixes-dev;然而:
  软件包 libxfixes-dev:amd64 尚未配置。
 libegl1-mesa-dev:amd64 依赖于 libx11-xcb-dev;然而:
  软件包 libx11-xcb-dev:amd64 尚未配置。

dpkg: 处理软件包 libegl1-mesa-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 libgl1-mesa-dev:amd64 的配置工作不能继续:
 libgl1-mesa-dev:amd64 依赖于 mesa-common-dev (= 18.0.5-0ubuntu0~16.04.1);然而:
  软件包 mesa-common-dev:amd64 尚未配置。
 libgl1-mesa-dev:amd64 依赖于 libx11-dev;然而:
  软件包 libx11-dev:amd64 尚未配置。
 libgl1-mesa-dev:amd64 依赖于 libx11-xcb-dev;然而:
  软件包 libx11-xcb-dev:amd64 尚未配置。
 libgl1-mesa-dev:amd64 依赖于 libxdamage-dev;然而:
  软件包 libxdamage-dev:amd64 尚未配置。
 libgl1-mesa-dev:amd64 依赖于 libxext-dev;然而:
  软件包 libxext-dev:amd64 尚未配置。
 libgl1-mesa-dev:amd64 依赖于 libxfixes-dev;然而:
  软件包 libxfixes-dev:amd64 尚未配置。
 libgl1-mesa-dev:amd64 依赖于 libxxf86vm-dev;然而:
  软件包 libxxf86vm-dev:amd64 尚未配置。

dpkg: 处理软件包 libgl1-mesa-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 libgles2-mesa-dev:amd64 的配置工作不能继续:
 libgles2-mesa-dev:amd64 依赖于 libegl1-mesa-dev;然而:
  软件包 libegl1-mesa-dev:amd64 尚未配置。

dpkg: 处理软件包 libgles2-mesa-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 libglu1-mesa-dev:amd64 的配置工作不能继续:
 libglu1-mesa-dev:amd64 依赖于 libgl1-mesa-dev | libgl-dev;然而:
  软件包 libgl1-mesa-dev:amd64 尚未配置。
  未安装软件包 libgl-dev。
  软件包 libgl1-mesa-dev:amd64 提供了 libgl-dev,但它尚未被配置。

dpkg: 处理软件包 libglu1-mesa-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
正在设置 libpcre3-dev:amd64 (2:8.38-3.1) ...
dpkg: 依赖关系问题使得 libprotobuf-dev:amd64 的配置工作不能继续:
 libprotobuf-dev:amd64 依赖于 zlib1g-dev;然而:
  软件包 zlib1g-dev:amd64 尚未配置。

dpkg: 处理软件包 libprotobuf-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
正在设置 libsdl2-2.0-0:amd64 (2.0.4+dfsg1-2ubuntu2.16.04.2) ...
正在设置 x11proto-core-dev (7.0.31-1~ubuntu16.04.2) ...
正在设置 x11proto-input-dev (2.3.1-1) ...
正在设置 x11proto-render-dev (2:0.11.1-2) ...
正在设置 x11proto-scrnsaver-dev (1.2.2-1) ...
正在设置 x11proto-xext-dev (7.3.0-1) ...
正在设置 libice-dev:amd64 (2:1.0.9-1) ...
dpkg: 依赖关系问题使得 libmirclient-dev:amd64 的配置工作不能继续:
 libmirclient-dev:amd64 依赖于 libprotobuf-dev (>= 2.4.1);然而:
  软件包 libprotobuf-dev:amd64 尚未配置。

dpkg: 处理软件包 libmirclient-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
dpkg: 依赖关系问题使得 libmircommon-dev:amd64 的配置工作不能继续:
 libmircommon-dev:amd64 依赖于 libprotobuf-dev (>= 2.4.1);然而:
  软件包 libprotobuf-dev:amd64 尚未配置。

dpkg: 处理软件包 libmircommon-dev:amd64 (--install)时出错:
 依赖关系问题 - 仍未被配置
正在设置 libsm-dev:amd64 (2:1.2.2-1) ...
正在设置 libxau-dev:amd64 (1:1.0.8-1) ...
正在设置 libxdmcp-dev:amd64 (1:1.1.2-1.1) ...
正在设置 x11proto-fixes-dev (1:5.0-2ubuntu2) ...
正在设置 libxcb1-dev:amd64 (1.11.1-1ubuntu1) ...
正在设置 libxcb-dri2-0-dev:amd64 (1.11.1-1ubuntu1) ...
正在设置 libxcb-dri3-dev:amd64 (1.11.1-1ubuntu1) ...
正在设置 libxcb-glx0-dev:amd64 (1.11.1-1ubuntu1) ...
正在设置 libxcb-render0-dev:amd64 (1.11.1-1ubuntu1) ...
正在设置 libxcb-shape0-dev:amd64 (1.11.1-1ubuntu1) ...
正在设置 libxcb-sync-dev:amd64 (1.11.1-1ubuntu1) ...
正在设置 libxcb-xfixes0-dev:amd64 (1.11.1-1ubuntu1) ...
正在设置 x11proto-damage-dev (1:1.2.1-2) ...
正在设置 libxcb-randr0-dev:amd64 (1.11.1-1ubuntu1) ...
正在设置 libxcb-present-dev:amd64 (1.11.1-1ubuntu1) ...
正在处理用于 man-db (2.7.5-1) 的触发器 ...
正在处理用于 libc-bin (2.23-0ubuntu11.3) 的触发器 ...
正在处理用于 libglib2.0-0:amd64 (2.48.2-0ubuntu4.8) 的触发器 ...
在处理时有错误发生:
 libdbus-1-dev:amd64
 libglib2.0-dev
 libpulse-dev:amd64
 libsdl2-dev
 libudev-dev:amd64
 libx11-dev:amd64
 libx11-xcb-dev:amd64
 libxcursor-dev:amd64
 libxdamage-dev:amd64
 libxext-dev:amd64
 libxfixes-dev:amd64
 libxi-dev
 libxinerama-dev:amd64
 libxrandr-dev:amd64
 libxrender-dev:amd64
 libxss-dev:amd64
 libxt-dev:amd64
 libxv-dev:amd64
 libxxf86vm-dev:amd64
 mesa-common-dev:amd64
 zlib1g-dev:amd64
 libegl1-mesa-dev:amd64
 libgl1-mesa-dev:amd64
 libgles2-mesa-dev:amd64
 libglu1-mesa-dev:amd64
 libprotobuf-dev:amd64
 libmirclient-dev:amd64
 libmircommon-dev:amd64

  • 写回答

2条回答 默认 最新

  • CSDN-Ada助手 CSDN-AI 官方账号 2023-02-12 14:08
    关注
    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

问题事件

  • 系统已结题 3月1日
  • 已采纳回答 2月21日
  • 创建了问题 2月12日

悬赏问题

  • ¥15 首次运行OmniEvent运行报错
  • ¥15 有没有人知道这个问题怎么解决
  • ¥15 comsol电力电缆载流量仿真
  • ¥15 webSocket可以接TCP socket接口吗
  • ¥60 mpi并行出错,CFD++计算
  • ¥15 c#:vsto,powerpoint的外接程序中换主题颜色
  • ¥15 状态机/汽车转向灯/Sateflow
  • ¥15 这个有点复杂 有没有人看看
  • ¥15 用python如何确定子孙元素在父元素中的位置
  • ¥15 obj文件滤除异常高程