dougaodi8895
2017-10-08 11:34
浏览 261
已采纳

在Laravel 5.5中安装Passport包的问题

I can't install "Passport" package in my laravel 5.5.

When i try to install passport package by composer, i face lot of package stability issues.

I use the following,

"require": {
    "php": ">=7.0.0",
    "fideloper/proxy": "~3.3",
    "laravel/framework": "5.5.*",
    "laravel/tinker": "~1.0",
    "laravelcollective/html": "^5.2.0",
    "laravel/passport": "^1.0"
}

when i try to install by,

 composer update

I got following error,

  Your requirements could not be resolved to an installable set of packages.

Problem 1
- Conclusion: don't install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install lucadegasperi/oauth2-server-laravel 4.0.2
- Conclusion: remove lucadegasperi/oauth2-server-laravel 4.0.1
- Conclusion: don't install laravel/passport v1.0.18|don't install league/oauth2-server 4.1.5|install league/oauth2-server 5.1.5
- Conclusion: don't install laravel/passport v1.0.18|don't install league/oauth2-server 4.1.4|install league/oauth2-server 5.1.4|install league/oauth2-server 5.1.5
- Conclusion: don't install laravel/passport v1.0.18|don't install league/oauth2-server 4.1.3|install league/oauth2-server 5.1.3|install league/oauth2-server 5.1.4|install league/oauth2-server 5.1.5
- Conclusion: don't install laravel/passport v1.0.18|don't install league/oauth2-server 4.1.2|install league/oauth2-server 5.1.2|install league/oauth2-server 5.1.3|install league/oauth2-server 5.1.4|install league/oauth2-server 5.1.5
- Conclusion: don't install laravel/passport v1.0.18|don't install league/oauth2-server 4.1.1|install league/oauth2-server 5.1.1|install league/oauth2-server 5.1.2|install league/oauth2-server 5.1.3|install league/oauth2-server 5.1.4|install league/oauth2-server 5.1.5
- Conclusion: don't install lucadegasperi/oauth2-server-laravel 4.0.0
- Conclusion: don't install laravel/passport v1.0.18|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: remove league/oauth2-server 4.1.6|install laravel/passport v1.0.18
- Conclusion: don't install league/oauth2-server 5.1.5|keep league/oauth2-server 4.1.6|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.17|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.16|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.15|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.14|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.13|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.12|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.11|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.10|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.9|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.8|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.7|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.6|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.5|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.4|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.3|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.2|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install laravel/passport v1.0.1|keep league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install league/oauth2-server 4.1.5|install league/oauth2-server 5.1.5|install laravel/passport v1.0.18
- Conclusion: don't install league/oauth2-server 4.1.6|install league/oauth2-server 5.1.5|install laravel/passport v1.0.18
- Conclusion: don't install league/oauth2-server 5.0.1|keep league/oauth2-server 4.1.6|install league/oauth2-server 4.1.5|install league/oauth2-server 4.1.6|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install league/oauth2-server 5.0.2|keep league/oauth2-server 4.1.6|install league/oauth2-server 4.1.5|install league/oauth2-server 4.1.6|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install league/oauth2-server 5.0.3|keep league/oauth2-server 4.1.6|install league/oauth2-server 4.1.5|install league/oauth2-server 4.1.6|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install league/oauth2-server 5.1.0|keep league/oauth2-server 4.1.6|install league/oauth2-server 4.1.5|install league/oauth2-server 4.1.6|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install league/oauth2-server 5.1.1|keep league/oauth2-server 4.1.6|install league/oauth2-server 4.1.5|install league/oauth2-server 4.1.6|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install league/oauth2-server 5.1.2|keep league/oauth2-server 4.1.6|install league/oauth2-server 4.1.5|install league/oauth2-server 4.1.6|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Installation request for lucadegasperi/oauth2-server-laravel 4.0.x@dev -> satisfiable by lucadegasperi/oauth2-server-laravel[4.0.0, 4.0.1, 4.0.2, 4.0.x-dev].
- Conclusion: don't install league/oauth2-server 5.1.3|keep league/oauth2-server 4.1.6|install league/oauth2-server 4.1.5|install league/oauth2-server 4.1.6|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- laravel/passport v1.0.0 requires league/oauth2-server ~5.0 -> satisfiable by league/oauth2-server[5.0.0, 5.0.1, 5.0.2, 5.0.3, 5.1.0, 5.1.1, 5.1.2, 5.1.3, 5.1.4, 5.1.5].
- Conclusion: don't install league/oauth2-server 5.1.4|keep league/oauth2-server 4.1.6|install league/oauth2-server 4.1.5|install league/oauth2-server 4.1.6|install lucadegasperi/oauth2-server-laravel 4.0.0|install lucadegasperi/oauth2-server-laravel 4.0.2|install lucadegasperi/oauth2-server-laravel 4.0.x-dev
- Conclusion: don't install league/oauth2-server 4.1.1|install league/oauth2-server 5.1.1|install league/oauth2-server 5.1.2|install league/oauth2-server 5.1.3|install league/oauth2-server 5.1.4|install league/oauth2-server 5.1.5|install laravel/passport v1.0.17|install laravel/passport v1.0.18
- Conclusion: don't install league/oauth2-server 4.1.2|install league/oauth2-server 5.1.2|install league/oauth2-server 5.1.3|install league/oauth2-server 5.1.4|install league/oauth2-server 5.1.5|install laravel/passport v1.0.17|install laravel/passport v1.0.18
- Installation request for laravel/passport ^1.0 -> satisfiable by laravel/passport[v1.0.0, v1.0.1, v1.0.10, v1.0.11, v1.0.12, v1.0.13, v1.0.14, v1.0.15, v1.0.16, v1.0.17, v1.0.18, v1.0.2, v1.0.3, v1.0.4, v1.0.5, v1.0.6, v1.0.7, v1.0.8, v1.0.9].
- Conclusion: don't install league/oauth2-server 4.1.3|install league/oauth2-server 5.1.3|install league/oauth2-server 5.1.4|install league/oauth2-server 5.1.5|install laravel/passport v1.0.17|install laravel/passport v1.0.18
- lucadegasperi/oauth2-server-laravel 4.0.1 requires league/oauth2-server 4.1.* -> satisfiable by league/oauth2-server[4.1.6, 4.1.0, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.5].
- don't install league/oauth2-server 5.0.0|don't install league/oauth2-server 4.1.0
- Conclusion: don't install league/oauth2-server 4.1.4|install league/oauth2-server 5.1.4|install league/oauth2-server 5.1.5|install laravel/passport v1.0.17|install laravel/passport v1.0.18

How to install passport package to my laravel (5.5) ?

Thanks in advance !

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • douman6679 2017-10-08 12:33
    已采纳

    You are getting this error because you are trying to install an old version of passport into the latest version of Laravel. In order to install passport using composer First thing first, remove the "laravel/passport": "^1.0" from your composer.json your composer json should look like this.

    "require": {
        "php": ">=7.0.0",
        "fideloper/proxy": "~3.3",
        "laravel/framework": "5.5.*",
        "laravel/tinker": "~1.0",
        "laravelcollective/html": "^5.2.0",
    }
    

    and then Follow the steps that are given in docs

    Try to install passport using composer require laravel/passport as it will automatically install the latest version of passport for your Laravel 5.5 but make sure you haven't included passport in require section of your composer.json.

    已采纳该答案
    打赏 评论
  • dousong8187 2017-10-08 12:00

    Please use

        "php": ">=7.0.0",
        "fideloper/proxy": "~3.3",
        "laravel/framework": "5.5.*",
        "laravel/passport": "^4.0",
        "laravel/tinker": "~1.0"
    
    打赏 评论

相关推荐 更多相似问题