doushi9376
2015-04-06 10:41
浏览 54
已采纳

Laravel在XAMPP中安装在Mac上

When I try to run laravel app using XAMPP localhost, it gives me a white screen of death. However, when I use artisan serve, the app works fine.

Here are the steps that I did: 1. I installed composer globally. 2. Install laravel using the zip file and also through composer. Through zip file, I ran composer install.

When I run localhost/my_app/public, it gives me blank white screen.

Seeing previous answers, I did some things

Added this to bash_profile:

export PATH=/Applications/XAMPP/xamppfiles/bin:$PATH

On running which php, I get this:

/Applications/XAMPP/xamppfiles/bin/php

Not able to figure out what would be the exact issue.

图片转代码服务由CSDN问答提供 功能建议

当我尝试使用XAMPP localhost运行laravel app时,它会给我一个白色的死亡屏幕。 但是,当我使用 artisan serve 时,该应用程序运行正常。

以下是我执行的步骤: 1。 我在全球安装了composer。 \ N2。 使用zip文件和composer安装laravel。 通过zip文件,我运行 composer install

当我运行 localhost / my_app / public 时,它会给我一个空白屏幕。

看到以前的答案,我做了一些事情

将此添加到bash_profile:

  export  PATH = / Applications / XAMPP / xamppfiles / bin:$ PATH 
   
 
 

在运行 php 时,我明白了:

  / Applications / XAMPP / xamppfiles / bin / php 
   
 
 

无法弄清楚究竟是什么问题。< / p>

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

3条回答 默认 最新

  • dongma7725 2015-04-06 13:18
    已采纳

    I think there is a problem with the storage directory access rights. You can change it's mod to 777 or assign the user(with which apache runs in XAMPP) the ownership of the storage directory.

    Here is an example of the command to use:

    sudo chmod -R 777 storage

    Similarly, for assigning ownership:

    sudo chown storage [user]:[group]

    点赞 打赏 评论
  • donglun2010 2015-04-06 13:18

    have u tried pointing to htdocs and run ?

     composer create-project laravel/laravel myproject --prefer-dist
    
    点赞 打赏 评论
  • dongxun1244 2016-05-20 06:14

    Try: php artisan cache:clear

    then chmod -R 777 your_laravel_folder_path/storage

    finally php artisan dump-autoload

    If you trying in XAMPP then your_laravel_folder_path will /Applications/XAMPP/htdocs/YOUR_PROJECT_FOLDER . That folder contains storage directory.

    Thanks in advance.

    点赞 打赏 评论

相关推荐 更多相似问题